Firefox Extensions in Ubuntu

Flashblock crashes Firefox 3

Reported by Fridtjof Busse on 2008-06-11
96
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Firefox Extensions
Wishlist
Unassigned
Hardy Backports
Undecided
Unassigned
Intrepid Ibex Backports
Undecided
Unassigned
flashblock (Ubuntu)
Medium
Philippe Coval
Nominated for Hardy by Fabián Rodríguez
Nominated for Intrepid by Fabián Rodríguez
Nominated for Jaunty by Fabián Rodríguez

Bug Description

The current version of flashblock in hardy seems to be not fully compatible with firefox3.
Firefox crashes randomly on websites with flash, after manually installing the current version of the plugin, the problems went away.
Please bump the package to a more recent version.

Philippe Coval (rzr) wrote :

Hi, It doesnt crash for, but I'll update it soon or later

Changed in flashblock:
assignee: nobody → rzr
Philippe Coval (rzr) wrote :
Changed in flashblock:
status: New → In Progress
wizard10000 (wizard10000) wrote :

I bugged this with Mozilla - https://www.mozdev.org/bugs/show_bug.cgi?id=19261

If you whitelist cnn.com in flashblock it crashes FF3 final about 75% of the time when you visit the site.

Mozilla asked me to install the official version of FF3 from their site - and I cannot reproduce the issue with Mozilla code, so I'm calling this an Ubuntu bug ;-)

Terminal output from FF3RC1 crash -

firefox
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
**
**
Gtk:ERROR:(/build/buildd/gtk+2.0-2.12.9/gtk/gtkplug.c:182):gtk_plug_set_is_child:
assertion failed: (!GTK_WIDGET (plug)->parent)
Aborted

Alexander Sack (asac) wrote :

anyone still sees this with flashblock and latest firefox from ubuntu archives?

Alexander Sack (asac) on 2008-06-18
Changed in firefox-extensions:
importance: Undecided → Wishlist
status: New → Fix Committed
Alexander Sack (asac) wrote :

I merged this to the release branch. However, I would like to have a separate bug in changelog for "new upstream" and keep this one to track the crash.

wizard10000 (wizard10000) wrote :

--> anyone still sees this with flashblock and latest firefox from ubuntu archives?

Yes - was able to duplicate it this morning. As I mentioned, it happens in the Ubuntu distribution but not with a vanilla install from mozilla.org.

On Wed, Jun 18, 2008 at 04:11:51PM -0000, wizard10000 wrote:
> --> anyone still sees this with flashblock and latest firefox from
> ubuntu archives?
>
> Yes - was able to duplicate it this morning. As I mentioned, it happens
> in the Ubuntu distribution but not with a vanilla install from
> mozilla.org.
>

Can you test the package from the branch attached to this bug report?
I think rzr prepared a test package in his PPA archive. Get the .deb's
from there.

 - Alexander

Hi,

> If you whitelist cnn.com in flashblock it crashes FF3 final about 75% of the time when you visit the site.

And does it crash when flashblock is uninstalled ? if yes then this bug is not flashblock side :)
I tested http://cnn.com without problem with the version in my branch

> I think rzr prepared a test package in his PPA archive.

Yes I did , you can add my sources see page
https://launchpad.net/~rzr/+archive

> I merged this to the release branch. However, I would like to have a separate bug in changelog for "new upstream"
> and keep this one to track the crash.

Ok done please sync to r11
 bzr+ssh://<email address hidden>/~rzr/firefox-extensions/flashblock.ubuntu/

BTW, This bug is pretty confusing, I think it's safe to close it
since we're talking about 2 issues which is not present in latest version,
so please open new bug(s) if you experience some crash or problems with fb options with updated version(s)

Thanks for all and Regards

J. Carlos Navea (loconet) wrote :

I can confirm this is currently happening for me when I visit www.marca.com (amongst many other sites that have flash movies). I am 99% certain it is flashblock related because I disabled flashblock and was able to access the site without a problem, re-enabling it brings the problem again.

As a side note, I tried to get as much information about the crash as possible but it is proving to be a little hard for me since firefox-3.0-dbgsym & xulrunner-1.9-dbgsym won't install in my system (Repo problems for Hardy I guess? Broken packages - many others have reported the same problem) so I'm attaching what firefox dumped in the console. Let me know if there is a better way to provide the necessary information and I will do my best to get it here.

My setup:

Firefox:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

Flashblock 1.5.6

Shockwave Flash Plugin:
File name: libflashplayer.so - Shockwave Flash 9.0 r124

uname -a
Linux loconet 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux

Philippe Coval (rzr) wrote :

Hi,
thank you for reporting this
this is a known issue, can you please confirm if the issue is still present with latest version in intrepid (also backported in my PPA)...

The hardy backport is planned too, so please be patient ...

Regards

Sergio Ventura (sergioventura) wrote :

I confirm that the same issue is still present with the latest version in Intrepid

Philippe Coval (rzr) wrote :

Hi, there an updated version in jaunty ,
tell us if it's working ok on intrepid, it'll be merged then

Fabián Rodríguez (magicfab) wrote :

Raising importance, as this makes browsing any such sites impossible for all practical uses involving Flash:
As long as Flash and websites using it use 100% CPU and behave as if they owned the system they run in, Flashblock is a critical component to block such content. Flash is often used in menus, full website content, videos, etc, which makes it impossible to avoid without Flashblock. An SRU may not seem crazy for this one.

For problems with Flash block in other Ubuntu versions see:
 Intrepid (8.10): Bug #309390
 Jaunty (9.04): Bug #345125

Changed in flashblock (Ubuntu):
importance: Undecided → Medium
summary: - flashblock crashes firefox3
+ Hardy: Flashblock crashes Firefox 3
summary: - Hardy: Flashblock crashes Firefox 3
+ [MASTER] Flashblock crashes Firefox 3

@John, please don't change the title again. There are other bugs about Flashblock in Intrepid and Jaunty. Labeling this as Master may confuse others.

summary: - [MASTER] Flashblock crashes Firefox 3
+ Hardy: Flashblock crashes Firefox 3

Fabian, They should all get fixed by new release.

Fabián Rodríguez (magicfab) wrote :

Thank you John. I've just marked the separate Intrepid and Jaunty separate bugs as duplicates of this one and nominated them.

summary: - Hardy: Flashblock crashes Firefox 3
+ Flashblock crashes Firefox 3
John Vivirito (gnomefreak) wrote :

Can someone please reject the nominations since this doesnt fit in SRU policy and should be in backports only.

Philippe Coval (rzr) wrote :

Hi,
I am back an ready to spare some time on flashblock,
now i am waiting on this :
https://code.edge.launchpad.net/~rzr/firefox-extensions/flashblock.ubuntu/+merge/3697

Regards

Philippe Coval (rzr) wrote :

You can test the (jaunty) version in my PPA

I am still waiting my branch to be merge

Hope this helps

Regards

--
http://rzr.online.fr/q/flashblock

Philippe Coval (rzr) wrote :
Changed in flashblock (Ubuntu):
status: In Progress → Fix Released
Mantas Kriaučiūnas (mantas) wrote :

I've noticed, that flashblock doesn't work at all in Ubuntu 8.04 (Hardy) when I use adobe-flashplugin 10 from Canonical "parter" repository. I simply installed newer flashblock package from Ubuntu 9.04 (Jaunty) and now flashblock works fine.
So, simple backport from jaunty to hardy would make Ubuntu 8.04 LTS users happy ;)

Changed in hardy-backports:
status: New → Confirmed
Alexander Sack (asac) wrote :

is flashblock shipped in hardy broken for everyone or just for some users? if its broken for everyone we should consider a SRU to fix this.

Last i heard a while ago people were only having issues with upstream
packacge but maybe this changed since we updated it,, if we did?

On Tue, Sep 29, 2009 at 10:14 AM, Alexander Sack <email address hidden> wrote:

> is flashblock shipped in hardy broken for everyone or just for some
> users? if its broken for everyone we should consider a SRU to fix this.
>
> --
> Flashblock crashes Firefox 3
> https://bugs.launchpad.net/bugs/239151
> You received this bug notification because you are a member of Ubuntu
> Backports Testing Team, which is subscribed to Hardy Backports.
>

--
Sincerely Yours,
   John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/Johnvivirito
http://freewebs.com/ubuntufreak
Linux User# 414246

Cosme Domínguez (cosme) wrote :
Changed in intrepid-backports:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.