Fedora

DVD drive doesn't work on MacBookPro8,2

Reported by bquenin on 2011-05-13
160
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
linux (Fedora)
New
Undecided
Unassigned
linux (Ubuntu)
High
Ming Lei
Oneiric
High
Ming Lei
Precise
High
Unassigned

Bug Description

The DVD drive is not detected by the kernel and is therefore not useable.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-9-generic 2.6.38-9.43
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tsug 1694 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xb0900000 irq 46'
   Mixer name : 'Cirrus Logic CS4206'
   Components : 'HDA:10134206,106b1d00,00100301'
   Controls : 22
   Simple ctrls : 13
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xb0840000 irq 47'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri May 13 22:29:13 2011
InstallationMedia: Ubuntu 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Apple Inc. MacBookPro8,2
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-9-generic root=UUID=ac396dfd-319a-4e2d-a096-81720d891c73 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-9-generic N/A
 linux-backports-modules-2.6.38-9-generic N/A
 linux-firmware 1.52
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-04-28 (14 days ago)
dmi.bios.date: 02/07/11
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP81.88Z.0047.B04.1102071707
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-94245A3940C91C80
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro8,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-94245A3940C91C80
dmi.modalias: dmi:bvnAppleInc.:bvrMBP81.88Z.0047.B04.1102071707:bd02/07/11:svnAppleInc.:pnMacBookPro8,2:pvr1.0:rvnAppleInc.:rnMac-94245A3940C91C80:rvrMacBookPro8,2:cvnAppleInc.:ct10:cvrMac-94245A3940C91C80:
dmi.product.name: MacBookPro8,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Proposed release note:

Currently DVD support for the Macbook Pro (8,1) , (8,2) ,and (8,3) is unavailable in 11.10. We intend to correct this with a post-release update.

bquenin (bquenin) wrote :
slyblade900 (tn-prasana-1991) wrote :

I'm having the same problem too. DVD will not get detected including the Ubuntu DVD from which i installed ubuntu. All CD's work fine though. And if some one could show me how to generate a BUG report like this one i would make one too.
OS: Natty
x64 system with 4GB DDR3 RAM, NVidea Graphic Card

slyblade900 (tn-prasana-1991) wrote :

Uh and i don't own a mac book. I think it's a problem with the kernel in general =)

bquenin (bquenin) wrote :

Maybe I wasn't clear enough, by DVD drive I mean the optical drive itself is not recognized by the kernel meaning neither CD nor DVD (or anything else) works.
And this problem is really specific to MacBookPro8,2.

Brad Figg (brad-figg) on 2011-05-14
Changed in linux (Ubuntu):
status: New → Confirmed
dozycat (lawrenceramirezde) wrote :

I have an sandy bridge i5 2400 with mother board asus p8h67-m pro and dvd lg installed in the sata 1 de 6 gigas.
The machine has Ubuntu 11.04 64 bits dual with windows.
And windows detects the dvd but ubuntu doesn´t.

dozycat (lawrenceramirezde) wrote :

My dvd worked once I changed in the bios the sata mode from ide to AHCI mode.
I read around the bugs there was an error in ubuntu 10.10 with sata 3.0 in ide mode, it looks like is the same in ubuntu 11.04.

Shaun ONeil (soneil) wrote :

Marked mine as a duplicate of this; just a note to say I've tested -i386, -amd64, and -amd64+mac images; all affected for natty-release. (Same hardware - macbook pro 8,2 with matshitadvd-r UJ-8A8)

"TEST_UNIT_READY failed (err_mask=0x4)" in dmesg appears to be the specific error.

bquenin (bquenin) wrote :

Is there anything I can do to help resolving this bug ?

aaron (aaron-zareason) wrote :

Please also mark this as a regression. It works in previous ubuntu releases. It doesn't work in the latest. That means that it's regressed, something's changed in the code that's broken support for the dvd's used in macbook pro 8,2.

Hachi (hemanzur) wrote :

my old compaq presario F700 has the same problem. With ubuntu 11.04 64bits unit was not recognized, but with 32bits version it shows up again. The problem is that I switched to xubuntu 11.04 32 bits and the problem persists.
Also I must say that when ubuntu 11.04 32b version was installed the dvd drive was ok until I decided to test the ubuntu-restricted-extras package: the drived disapeared and appeared again after I removed that package.
Might be some problem related to the multimedia codecs ??

Hope this helps

Axel Waggershauser (awagger) wrote :

Hi,

a 'workaround' with some side-effects that worked for me is the "grub2 + setpci"-trick to (re-)enable AHCI (see [1]). The positive side-effect is, you get somewhat better IO-performance (my SSD read throughput went up about 30%). The negative side-effect is, you loose suspend/resume support. To the latter, there seems hope (see [2]).

[1] http://en.gentoo-wiki.com/wiki/Apple_Macbook_Pro#AHCI
[2] https://bugs.launchpad.net/mactel-support/+bug/817017

My main goal was actually not fixing the DVD drive but getting rid of the wasted time during boot while waiting for the ata code to time-out.

 - Axel

Ming Lei (tom-leiming) wrote :

Could you try to test the attachment patch and see if it can fix
your problem?

If you can confirm the patch may fix the problem, we will add the
pci device id(0x1c01) into the quirk patch, which has been submitted into
kernel maillist before[1] and will enter Oneiric.

BTW: the bug is very similar with 794642, and both are using
sandybridge chipsets.

[1], http://www.linux-archive.org/ubuntu-kernel-team/575856-ata-make-dvd-drive-recognisable-systems-sandybridge-cpt-chipset.html

thanks,
--
Ming Lei

Rohan Garg (rohangarg) wrote :

With the latest kernel updates ( 3.0.0-11-generic ) the DVD drive starts working, i can confirm reading CD's at this point, will try and burn a couple of CD's later this week and let you know.

Ming Lei (tom-leiming) wrote :

Hi Rohan,

On Mon, Sep 26, 2011 at 2:37 AM, Rohan Garg <email address hidden> wrote:
> With the latest kernel updates ( 3.0.0-11-generic ) the DVD drive starts
> working, i can confirm reading CD's at this point, will try and burn a
> couple of CD's later this week and let you know.

Could you help to post the output of 'lspci -v -nn' on your machine?

Could you make sure that it is 3.0.0-11-generic which starts to make
your DVD working?

And which previous release made your DVD not working?

thanks,
--
Ming Lei

Rohan Garg (rohangarg) wrote :

Hi
I remember that when i first installed Oneiric on my Macbook Pro 8,2 sometime in June, it did not work, i've tried previous kernels and i don't know how, but its working on all of them. Attached is the output of lspci, dmesg and a couple of other commands that might help you. Let me know if you require any other info.

Rohan Garg (rohangarg) wrote :
Rohan Garg (rohangarg) wrote :
Ming Lei (tom-leiming) wrote :

Hi,

On Tue, Sep 27, 2011 at 1:09 AM, Rohan Garg <email address hidden> wrote:
> Hi
> I remember that when i first installed Oneiric on my Macbook Pro 8,2 sometime in June, it did not work, i've tried previous kernels and i don't know how, but its working on all of them. Attached is the output of lspci, dmesg and a couple of other commands that might help you. Let me know if you require any other info.
>
> ** Attachment added: "lspci.txt"

From [1], you have enabled ahci mode, so it does work for you.
If you switch to IDE compatible mode in BIOS, I think your dvd drive
won't work even on 3.0.0-11-generic .

[1], ahci
00:1f.2 SATA controller [0106]: Intel Corporation 6 Series/C200 Series
Chipset Family 6 port SATA AHCI Controller [8086:1c03] (rev 05)
(prog-if 01 [AHCI 1.0])
 Subsystem: Intel Corporation Device [8086:7270]
 Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 45
 I/O ports at 3148 [size=8]
 I/O ports at 315c [size=4]
 I/O ports at 3140 [size=8]
 I/O ports at 3158 [size=4]
 I/O ports at 3060 [size=32]
 Memory at 8fa00000 (32-bit, non-prefetchable) [size=2K]
 Capabilities: <access denied>
 Kernel driver in use: ahci
 Kernel modules: ahci

thanks
--
Ming Lei

watgrad (watgrad) wrote :

I would like to confirm.
I have a macbookpro8,1

DVD does not work. Quits during installation of Ubuntu 11.04. I was able to get ubuntu loaded with a usb stick and DVD. Not recognized by Ubuntu after installation.

Current version:
Linux 2.6.39-020639rc4-generic #201104191410 SMP Tue Apr 19 14:19:01 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

I have attached the output of lspci -v -nn to this post as well.

I hope this helps work toward a solution...

Ming Lei (tom-leiming) wrote :

Hi,

Thanks for your report.

On Sat, Oct 1, 2011 at 3:39 AM, watgrad <email address hidden> wrote:
> I would like to confirm.
> I have a macbookpro8,1
>
> DVD does not work.  Quits during installation of Ubuntu 11.04.  I was

Intel Corporation 6 Series Chipset Family 4 port SATA IDE Controller
[8086:1c01] (rev 05)

Intel guy has confirmed that 1c01 is the affected one, and the patch
below[1] was
confirmed to be able to fix the issue. Once it is merged into ide tree
or linus tree, we
will integrate it into ubuntu tree.

[1], http://marc.info/?l=linux-ide&m=131737197214541&w=2
[2], http://marc.info/?t=131665670300001&r=1&w=2

thanks,
--
Ming Lei

Rohan Garg (rohangarg) wrote :

Well, I can't even get the CD too boot, gives me a "Could not find live file system" error and drops me to a iniramfs shell. Would this bug be causing this issue ?

tags: added: iso-testing
bquenin (bquenin) wrote :

> Well, I can't even get the CD too boot, gives me a "Could not find live file system" error and drops me to a iniramfs shell. Would this bug be causing this issue ?

That's the symptom I had (and I still have). Now just have to wait for the patch to be integrated, it seems to fix the issue.

Ming Lei (tom-leiming) on 2011-10-10
Changed in linux (Ubuntu):
assignee: nobody → Ming Lei (tom-leiming)
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu Oneiric):
milestone: none → oneiric-updates
description: updated
Rohan Garg (rohangarg) wrote :

A couple of notes here :
You *can* boot a live session using both a USB and a CD, here are the steps :

Note 1 :
Step 1 : Burn ISO image to a CD
Step 2 : dd or use usb-creator to write ISO to a usb thumbdrive
Step 3 : Insert both the CD and the USB disk during the boot sequence and hold down 'C' to boot the CD
Step 4 : Wait for everything to load and proceed with installation ( At this point, you can remove the CD since the session is being run from the USB thumb drive )

Note 2 :
Interestingly, my DVD/CD drive does work if you hold the 'option' key during the boot sequence, if you use reFit the drive is not recognized. I would highly recommend using the option key to boot the other OS because that way most of your hardware works out of the box ( I couldn't get my backlight controls to work either with reFit )

Changed in ubuntu-release-notes:
status: New → Fix Committed
Changed in linux (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
tags: added: rls-mgr-p-tracking
Launchpad Janitor (janitor) wrote :
Download full text (10.3 KiB)

This bug was fixed in the package linux - 3.1.0-1.1

---------------
linux (3.1.0-1.1) precise; urgency=low

  [ Andiry Xu ]

  * SAUCE: (drop during 3.2 merge) xHCI: AMD isoc link TRB chain bit quirk
    - LP: #872811

  [ Andy Whitcroft ]

  * Revert "ubuntu: compcache -- follow changes to bd_claim/bd_release"
    - LP: #832694
  * Revert "ubuntu: compcache -- version 0.5.3"
    - LP: #832694
  * [Config] standardise CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP=m
  * [Config] Enable CONFIG_MACVTAP=m
    - LP: #822601
  * record the compiler in the ABI and check for inconsistant builds
  * [Config] move ECRYPT_FS back to =y for all architectures
    - LP: #827197
  * [Config] enable CONFIG_DRM_VMWGFX=m
    - LP: #698009
  * [Config] re-fix ECRYPT_FS=y
    - LP: #827197
  * enforcer -- ensure we have CONFIG_ECRYPT_FS=y
    - LP: #827197
  * [Config] dropping compcache configuration options
  * [Config] standardise on HZ=250
  * SAUCE: headers_install: fix #include "..." usage for userspace
    - LP: #824377
  * make module-inclusion selection retain the left overs
  * add a new linux-image-extras package for virtual

  [ Colin Watson ]

  * Deliver more Atheros, Ralink, and iwlagn NIC drivers to d-i

  [ edwin_rong ]

  * SAUCE: Staging: add driver for Realtek RTS5139 cardreader
    - LP: #824273

  [ Greg Kroah-Hartman ]

  * SAUCE: staging: rts5139: add vmalloc.h to some files to fix the build.
    - LP: #824273

  [ Jesse Sung ]

  * SAUCE: Unregister input device only if it is registered
    - LP: #839238

  [ Jiri Kosina ]

  * SAUCE: HID: add MacBookAir4, 2 to hid_have_special_driver[]

  [ Joshua V. Dillon ]

  * SAUCE: HID: add support for MacBookAir4,2 keyboard.

  [ Kees Cook ]

  * [Config] enable and enforce SECCOMP_FILTER on x86

  [ Keng-Yu Lin ]

  * [Config] Enable CONFIG_RTS5139=m on i386/amd64
    - LP: #824273

  [ Leann Ogasawara ]

  * Revert "ubuntu: overlayfs -- ovl: make lower mount read-only"
  * Revert "ubuntu: overlayfs -- fs: limit filesystem stacking depth"
  * Revert "ubuntu: overlayfs -- ovl: improve stack use of lookup and
    readdir"
  * Revert "ubuntu: overlayfs -- ovl: fix overlayfs over overlayfs"
  * Revert "ubuntu: overlayfs -- overlayfs: implement show_options"
  * Revert "ubuntu: overlayfs -- overlayfs: add statfs support"
  * Revert "ubuntu: overlayfs -- overlay filesystem"
  * Revert "ubuntu: overlayfs -- overlay: overlay filesystem documentation"
  * Revert "SAUCE: ARM: OMAP: Add macros for comparing silicon revision"
  * Revert "SAUCE: OMAP: DSS2: check for both cpu type and revision, rather
    than just revision"
  * Revert "SAUCE: OMAP: DSS2: enable hsclk in dsi_pll_init for OMAP36XX"
  * Revert "ubuntu: fsam7400 disable driver"
    - LP: #876030
  * rebase to v3.1-rc1
  * [Config] updateconfigs after rebase to v3.1-rc1
  * rebase to v3.1-rc2
  * [Config] Updateconfigs after rebase to v3.1-rc2
  * ubuntu: Yama - update calls to generic_permission() and
    inode->i_op->permission()
  * ubuntu: ndiswrapper -- remove netdev_priv macro
  * ubuntu: aufs -- Temporarily disable due to build failure
  * [Config] Diable INTEL_MID_PTI on armel
  * [Config] Temporarily disable CONFIG_FTMAC100 on armel
  * [Conf...

Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in ubuntu-release-notes:
status: Fix Committed → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel 3.0.0-13.21 for oneiric in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
derp herp (junkmail-trash) wrote :

Not sure how to test this as the issue was with the Ubuntu Installer CD. Is there a Ubuntu Installed CD image available with this fix included?

Ming Lei (tom-leiming) wrote :
Download full text (3.8 KiB)

On Fri, Oct 21, 2011 at 4:27 AM, derp herp <email address hidden> wrote:
> Not sure how to test this as the issue was with the Ubuntu Installer CD.
> Is there a Ubuntu Installed CD image available with this fix included?

You can just test CD access on the new update. If you can access CD correctly
with new update but not with old update, then the patch can fix the problem.

Please remind that you should put the SATA at IDE mode.

> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/782389
>
> Title:
>  DVD drive doesn't work on MacBookPro8,2
>
> Status in Release Notes for Ubuntu:
>  Fix Released
> Status in “linux” package in Ubuntu:
>  Fix Released
> Status in “linux” source package in Oneiric:
>  Confirmed
> Status in “linux” source package in Precise:
>  Fix Released
> Status in “linux” package in Fedora:
>  New
>
> Bug description:
>  The DVD drive is not detected by the kernel and is therefore not
>  useable.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: linux-image-2.6.38-9-generic 2.6.38-9.43
>  ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
>  Uname: Linux 2.6.38-9-generic x86_64
>  NonfreeKernelModules: fglrx
>  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
>  Architecture: amd64
>  AudioDevicesInUse:
>   USER        PID ACCESS COMMAND
>   /dev/snd/controlC0:  tsug       1694 F.... pulseaudio
>  CRDA: Error: [Errno 2] No such file or directory
>  Card0.Amixer.info:
>   Card hw:0 'PCH'/'HDA Intel PCH at 0xb0900000 irq 46'
>     Mixer name : 'Cirrus Logic CS4206'
>     Components : 'HDA:10134206,106b1d00,00100301'
>     Controls      : 22
>     Simple ctrls  : 13
>  Card1.Amixer.info:
>   Card hw:1 'Generic'/'HD-Audio Generic at 0xb0840000 irq 47'
>     Mixer name : 'ATI R6xx HDMI'
>     Components : 'HDA:1002aa01,00aa0100,00100200'
>     Controls      : 4
>     Simple ctrls  : 1
>  Card1.Amixer.values:
>   Simple mixer control 'IEC958',0
>     Capabilities: pswitch pswitch-joined penum
>     Playback channels: Mono
>     Mono: Playback [on]
>  Date: Fri May 13 22:29:13 2011
>  InstallationMedia: Ubuntu 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
>  IwConfig:
>   lo        no wireless extensions.
>
>   eth0      no wireless extensions.
>  MachineType: Apple Inc. MacBookPro8,2
>  ProcEnviron:
>   LANGUAGE=en_US:en
>   PATH=(custom, no user)
>   LANG=en_US.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-9-generic root=UUID=ac396dfd-319a-4e2d-a096-81720d891c73 ro quiet splash vt.handoff=7
>  RelatedPackageVersions:
>   linux-restricted-modules-2.6.38-9-generic N/A
>   linux-backports-modules-2.6.38-9-generic  N/A
>   linux-firmware                            1.52
>  RfKill:
>   0: hci0: Bluetooth
>    Soft blocked: no
>    Hard blocked: no
>  SourcePackage: linux
>  UpgradeStatus: Upgraded to natty on 2011-04-28 (14 days ago)
>  dmi.bios.date: 02/07/11
>  dmi.bios.vendor: Apple Inc.
>  dmi.bios.version: MBP81.88Z.0047.B04.1102071707
>  dmi.board.asset.tag: Base Board Asset Tag#
>  dmi.board.name: Mac-94245A3940C91C80
>  dmi.board.vendor: Apple Inc.
>  dmi.board.version: MacBookPro8,2...

Read more...

ridgerunner7 (ridgerunner7) wrote :

kernel 3.0.0-13.21 fixes it for me: MacBookPro 8,1

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Ming Lei (tom-leiming) on 2011-10-24
Changed in linux (Ubuntu Oneiric):
status: Confirmed → Fix Released

confirmed, kernel 3.0.0-13.21 fixes the problem on MacBookPro 8,2

Dominic Scheirlinck (dominics) wrote :

This fix is still unavailable to MacBookPro users who can't build their own image. There seems to be no +mac ISO available with the updated kernel, so Oneiric is still uninstallable on new Macbooks.

Rohan Garg (rohangarg) wrote :

I actually went ahead and tested this fix out using the precise daily ISO builds, and everything works as expected ( except for the part where I get a garbled screen and the fans don't work causing the machine to heat up ... ).

Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel for Natty in -proposed solves the problem (2.6.38-13.53). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-natty' to 'verification-done-natty'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-natty
Marcin Z (mlzcpe) wrote :

I can confirm that "linux-headers-2.6.38-13 2.6.38-13.53pre201112010400" on my MacBook Pro 8,1 with Ubuntu 11.04 fixes the DVD Drive problem. I have my DVD now ready and usable. Can't say if it burns cd/dvds but it surely reads them.

thanks guys. now only wifi/broadcast 4331 problem left.

Ming Lei (tom-leiming) on 2011-12-02
tags: added: verification-done-natty
removed: verification-needed-natty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.