Values Not Displaying for Active Column in SMS Carrier

Bug #1873539 reported by Jennifer Pringle
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.7
Medium
Unassigned

Bug Description

Evergreen 3.4 and 3.5

In the SMS Carriers interface (Administration -> Server Administration -> SMS Carriers) the Active column is not displaying the true/false values for the different carriers.

If you go in to edit a carrier you can see what the flag is set to.

Revision history for this message
Erica Rohlfs (erohlfs) wrote :

Confirming that the Active column within the SMS Carrier interface is blank (does not display true/false value).

Changed in evergreen:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Erica Rohlfs (erohlfs) wrote :

Just also confirming this behavior in 3.3 for anyone still on that version and reading this bug.

Revision history for this message
Galen Charlton (gmc) wrote :

Noting for whoever takes this on that the problem is almost certainly triggered by the fact that config.sms_carrier.active has (incorrectly) the oils_persist:i18n="true" flag set in the IDL.

tags: added: bitesize
Revision history for this message
Garry Collum (gcollum) wrote :
tags: added: pullrequest
Revision history for this message
Gina Monti (gmonti90) wrote :

I, Gina Monti, sign off on this bug fix. Flags do display the active status for SMS Carrier Administration.

tags: added: signedoff
Michele Morgan (mmorgan)
Changed in evergreen:
milestone: none → 3.6.2
Changed in evergreen:
milestone: 3.6.2 → 3.6.3
Changed in evergreen:
milestone: 3.6.3 → 3.6.4
Jane Sandberg (sandbej)
Changed in evergreen:
assignee: nobody → Jane Sandberg (sandbej)
Revision history for this message
Jane Sandberg (sandbej) wrote :

Works well for me. Thanks, Jennifer, Erica, Galen, Garry, and Gina! Pushed to rel_3_6, rel_3_7, and master.

Changed in evergreen:
assignee: Jane Sandberg (sandbej) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers