secondary permission groups (permission.usr_grp_map)

Bug #868653 reported by James Fournie on 2011-10-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

There is no interface for permission.usr_grp_map which allows users to have permissions from multiple permission groups.

I'm working on something for this.

~JF

James Fournie (jfournie) on 2011-10-05
summary: - secondary permission groups (usr_grp_perm_map)
+ secondary permission groups (permission.usr_grp_map)
Jason Stephenson (jstephenson) wrote :

James, I'm setting to incomplete until you confirm that you are still working on this.

If you are, please set it to in progress.

If not, please unassign yourself.

Thanks.

Changed in evergreen:
status: New → Incomplete
Changed in evergreen:
status: Incomplete → Triaged
Jeff Davis (jdavis-sitka) wrote :

James did write a fix for this, and Sitka has been using it for a few years now. I've pushed it to the user/jeffdavis/lp868653-secondary-perm-group-ui branch of the working repo. Here's the relevant commit:

git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=8a7a954

tags: added: pullrequest
Jeff Godin (jgodin) on 2014-03-19
Changed in evergreen:
assignee: James Fournie (jfournie) → nobody
milestone: none → 2.next
Remington Steed (rjs7) on 2014-03-20
tags: added: documentation
Jeff Davis (jdavis-sitka) wrote :

Looks like there was an additional commit as part of this, which I have now pushed to the user/jeffdavis/lp868653-secondary-perm-group-ui branch in the working repo:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=cbcdf74

This should probably be squashed into the previous one.

Galen Charlton (gmc) wrote :

I like the idea of adding a user interface so that secondary permission groups can be set.

Upon reviewing the patches, I have a few comments on issues to fix:

[1] This string, "Contact <email address hidden> and tell them you saw this.", should be removed or rewritten. Unless you really do want All The Questions! ;)
[2] More seriously, the strings for the new alert messages are not translatable in their current form as they're hardcoded. They should be added to Open-ILS/web/js/dojo/openils/actor/nls/register.js so that the translation tools can reach them.
[3] Even more seriously, this patch causes a regression on the new patron expiration date button added in bug 1246853. Please redo the rebasing so that this does not happen.

I'm removing the pullrequest tag on account of these issues.

tags: removed: pullrequest
Erica Rohlfs (erohlfs) wrote :

Thank you for taking a look at this, Galen! I think this feature would be highly beneficial to libraries who use the Acquisitions and Serials modules.

Galen Charlton (gmc) wrote :

I wonder if it would make more sense to put this on the user permission editor form rather than the patron registration form. My reasoning is that adding secondary permission groups is something that seems likely to be done only for staff users, and since you always have to use the UPE form when adding a staff user (in order to set working locations), putting it there removes a potential source of clutter on the registration form.

To be clear, this comment is meant only as food for thought; I don't feel strongly that the registration form is necessarily the wrong place for secondary groups, since one does set the primary profile there.

Jennifer Pringle (jpringle-u) wrote :

Thanks for taking a look at this Galen!

I understand the potential for clutter on the registration form but thus far we haven't had any comments about that from our users. This may be because we use a permission to control who actually sees the Secondary Group button so we have only about 15 people, not including Sitka Staff, who see the button. A library planning to allow more users to see the button may have a different opinion regarding where the button should be.

I would be hesitant at this point to put anything additional on the UPE form simply because it takes a long time (20 seconds or more) for that page to load right now, at least for us. But I'm willing to be persuaded if others would prefer the UPE.

Jeff Davis (jdavis-sitka) wrote :

I've pushed a cleaned-up version of the secondary groups UI to the working repo:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeffdavis/lp868653-secondary-perm-group-ui-2

This should fix the three issues Galen identified above.

tags: added: pullrequest
Kathy Lussier (klussier) wrote :

Hi Jeff,

Can you add a release notes entry for this branch? See http://wiki.evergreen-ils.org/doku.php?id=dev:meetings:2014-05-19 if you need any guidance on writing the release notes.

Thanks!
Kathy

tags: added: needsreleasenote
Ben Shum (bshum) on 2014-08-07
Changed in evergreen:
milestone: 2.next → 2.7.0-beta1
Ben Shum (bshum) wrote :

This was pushed to master for inclusion in 2.7 series. We still need to follow up with a release note entry, but I did grab Jennifer's docs commit.

Changed in evergreen:
status: Triaged → Fix Committed
Jeff Davis (jdavis-sitka) wrote :

I've pushed release notes to the user/jeffdavis/lp868653-secondary-perm-group-ui-2 branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commitdiff;h=8843d0b

tags: removed: needsreleasenote
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers