SIP2 Fee Paid Message support (37/38)

Bug #803121 reported by Jason Stephenson on 2011-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Bill Erickson
Nominated for 2.2 by Bill Erickson
Nominated for Master by Bill Erickson

Bug Description

I have been working on code to add support for the SIP2 fee paid message response pair (message 37, response 38) to the SIP perl modules.

The current state of the code seems to be working and is available here for testing, comment, or additional work.

git://git.evergreen-ils.org/working/Evergreen.git user/dyrcona/SIP23738

The above has the latest code as of 2011-08-09. You can ignore most of the gibberish in my other comments below.

Jason Stephenson (jstephenson) wrote :

The branch has been rebased to master as of 2011-06-30 11:49 EDT (-0400) and squashed to a single commit.

Elses have been given some love and cuddled.

I've tested it somewhat and it seems to work. I think others ought to test it before it goes into master. I'm still waiting on some of my consortium members who said that they could test it.

tags: added: newfeature
Jason Stephenson (jstephenson) wrote :

The code branch is also available here:

git://git.evergreen-ils.org/jason/ILS SIP23738

Jason Stephenson (jstephenson) wrote :

Permissions note:

If you've not already done so, you will need to add the CREATE_PAYMENT permission to your sip circulators group.

Jason Stephenson (jstephenson) wrote :

Just a FYI: we are going to use the latest commits to this branch in production started next week.

Jason Stephenson (jstephenson) wrote :

Looks like I can ignore the transaction id when checking for bills to pay. So I've changed the code to reflect that.

I'm getting occasional SIPServer daemon crashes when a patron attempts to pay a bill, but I have not isolated the exact cause, yet. I have seen this on our production box but haven't been able to reproduce it in the lab, yet.

You might want to hold off using this in production.

Jason Stephenson (jstephenson) wrote :

Ok. Think I've got a fix for the previously mentioned problems in the latest branch. It appears that we're either getting undef back from users_transactions in O::A::Actor.pm or that method is crashing the drone under certain circumstances. I've added some code to check that the returned value from open-ils.actor.user.transactions.history.have_balance is reasonably sane. If it isn't, we now return a failure status and say no bills were found. This should cause the self-check to refund the patron's money.

To get the latest fix for testing, I suggest the following:

git clone git://git.evergreen-ils.org/Evergreen.git
cd Evergreen
git remote add working git://git.evergreen-ils.org/working/Evergreen.git
git fetch --all
git checkout -b SIP23738 origin/master
git cherry-pick 413cd8
git cherry-pick c5c459

Instead of the two cherry-picks you could just

git merge <email address hidden>/SIP23738

However, I recommend the cherry-picks, particularly if you based your branch on origin/rel_2_1 or origin/rel_2_0 instead of origin/master as listed above.

I won't be doing any more commit amends, so those revisions should remain unchanged.

Jason Stephenson (jstephenson) wrote :

You will now what to also

git cherry-pick 36d9a08

The above use the event textcode in the screen message as an alternative to the event descr for those events that lack a descr.

Jason Stephenson (jstephenson) wrote :

I rebased the SIP23738 branch at git://git.mvlcstaff.org/jason/ILS.git this morning.

The commit ids changed and the last 3 commits were rolled into 1.

I suggest using this branch if you're going to merge into master.

If you're using the collab branch from git.evergreen-ils.org, then you also want to cherry-pick commits c7fd06 & 2f9516f. They have some typo and bug fixes.

description: updated
Bill Erickson (berick) on 2011-08-09
Changed in evergreen:
assignee: nobody → Bill Erickson (erickson-esilibrary)
Bill Erickson (berick) wrote :

Quick note, I've reviewed the code and done some initial testing with positive results. Will merge to master after a little more testing. -b

Changed in evergreen:
status: New → In Progress
Bill Erickson (berick) wrote :

Pushed to master: 0d77bd8..581a37e

Thanks Jason!

Changed in evergreen:
status: In Progress → Fix Committed
Changed in evergreen:
milestone: none → 2.2.0
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers