Deleted? column for Record Buckets not working

Bug #795564 reported by Jason Etheridge on 2011-06-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

In 2.1 beta1, you can add bib records to a bucket, delete the records, and they don't show up as deleted via the Deleted? column.

tags: added: 2.1beta staffclient
Changed in evergreen:
status: New → Confirmed
Jason Stephenson (jstephenson) wrote :

I believe that they do if you refresh the bucket view.

Can you still confirm this?

Changed in evergreen:
status: Confirmed → Incomplete
Erica Rohlfs (erohlfs) wrote :

I tested this in Evergreen Version 2.4.2.

I can verify that the deleted? column does not show a value at all. Even after a refresh of the bucket view, the deleted? value does not show “Yes” or “No” for any of the records.

Erica Rohlfs (erohlfs) on 2013-09-12
Changed in evergreen:
status: Incomplete → Confirmed
Jason Boyer (jboyer) wrote :

There's little point in fixing this now, but I do know the cause. The column list used for the column picker comes from calling circ.util.columns, and only the few bib-related columns in those circ columns work properly (that Deleted? column referrers to a copy, which there of course is none). This is still useful information though, as it underscores that care must be taken in how the list of available columns is built, especially since these interfaces will have to be rebuilt for the web client. (I've seen other examples of this, but unfortunately can't remember them.)?field.comment=There's little point in fixing this now, but I do know the cause. The column list used for the column picker comes from calling circ.util.columns, and only the few bib-related columns in those circ columns work properly (that Deleted? column referrers to a copy, which there of course is none).

This is still useful information though, as it underscores that care must be taken in how the list of available columns is built, especially since the bucket interfaces will have to be rebuilt for the web client. (I've seen at least one other example of this, but unfortunately can't remember it.)

Elizabeth Thomsen (et-8) wrote :

Changed status to Invalid -- see https://bugs.launchpad.net/evergreen/+bug/1746360
Deleted? is one of several columns missing from record buckets in the web client
(confirmed that it's still missing in R 3.2 Beta 1)

Changed in evergreen:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers