web client: Record Bucket: Deleted is not on the column picker

Bug #1746360 reported by tji@sitka.bclibraries.ca on 2018-01-30
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
3.1
Undecided
Unassigned

Bug Description

Web client EG 3.0.2

Deleted bib records are displayed in Record Bucket. But Deleted column is not on the column picker. It's not possible to tell deleted bibs on the list.

Elaine Hardy (ehardy) wrote :

Deleted? is a column choice in the XUL client.

Changed in evergreen:
status: New → Confirmed
Jennifer Pringle (jpringle-u) wrote :

Edition is also missing as a column choice in record buckets (was one of the default columns in XUL).

As well, there are two Record ID columns in the picker that appear to be identical (both show the same record ID for a given item).

Michele Morgan (mmorgan) on 2018-05-10
tags: added: webstaffcolumns
Anna Goben (agoben) wrote :

Both of these are reported issues for my catalogers!

Andrea Neiman (aneiman) on 2018-05-24
tags: added: cataloging
Elizabeth Thomsen (et-8) wrote :

Confirmed in Release 3.2 Beta 1

Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Elaine Hardy (ehardy) wrote :

While deleted? is present in the XUL client, it does not indicate when a record is deleted. I merged two records in a bucket and the Deleted? column remains blank.

Terran McCanna (tmccanna) wrote :

Patch available to add Edition and Deleted columns to Record Bucket:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mccanna/lp1746360_record_bucket_missing_columns

ID field is being added manually as well as being pulled in automatically and I'm not sure of the reason so I did not remove the duplicate.

tags: added: pullrequest
Terran McCanna (tmccanna) wrote :

The edition info is coming in in quotes, and I'm not sure yet how to resolve that.

I have made both of these columns visible by default, but I can change them to hidden by default if people prefer.

Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
Remington Steed (rjs7) wrote :

Terran, thanks for your work on this! Your code change looks good to me. Two questions:

1. Your commit sign-off is missing your first name (it just says "Signed-off-by: McCanna ..."). Was that intended?

2. I also see the quotes around Edition when using your code. But when I enable the Edition column in the Patron Items Out screen, I don't see any quotes around it there. The JS for that screen fetches that data explicitly (rather than letting the grid auto-fetch it) and I notice the following code, which might be stripping the quotes. I'm not sure how to manipulate data that the grid auto-fetches. This is where I'd start asking Bill or others for help. :-)

staff/circ/patron/items_out.js:130
----------------------------------
// Translate bib display field JSON blobs to JS.
// Collapse multi/array fields down to comma-separated strings.
egBibDisplay.mwdeJSONToJS(
  circ.target_copy().call_number().record().wide_display_entry(), true);

Terran McCanna (tmccanna) wrote :

Thanks, Remington! Removing the pullrequest while I dig deeper.

I'm not sure what I did to lose my first name... :D

Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
tags: removed: pullrequest
Bill Erickson (berick) wrote :

Grabbing to push an extra commit for de-JSON-ifying the edition values and repairing the sign-off...

Changed in evergreen:
assignee: Terran McCanna (tmccanna) → Bill Erickson (berick)
Bill Erickson (berick) wrote :
Changed in evergreen:
milestone: none → 3.2.4
assignee: Bill Erickson (berick) → nobody
tags: added: pullrequest
Changed in evergreen:
importance: Undecided → Low
Terran McCanna (tmccanna) wrote :

Awesome, thanks Bill!!!

Terran McCanna (tmccanna) wrote :

Bill, we applied this to our test server and now we're getting console errors for each item in the bucket saying:

SyntaxError: "JSON.parse: unexpected character at line 1 column 1 of the JSON data"

Enabling the Deleted column works fine, but then enabling the Edition column doesn't display any data at all (see screenshots with console).

Any ideas?

Terran McCanna (tmccanna) wrote :
Bill Erickson (berick) wrote :

Hmm, I tested with empty values (to be safe) and they seemed fine, so I'm a little surprised. In any event, I may just need more sanity checking of the data before parsing. I've force-pushed a modified version of the patch to the same branch. Let me know if that helps. If not, then I'll want to add some debug logs.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1746360-buckete-deleted-column

Terran McCanna (tmccanna) wrote :

After applying that version, we're no longer seeing the browser console errors, but enabling the Edition column still prevents anything on the grid from loading. Will test more tomorrow!

Bill Erickson (berick) wrote :

I've pushed another commit (that we'll eventually want to remove) to add some logging. It logs the grid item object and the extracted value for edition. Hopefully it will shed some light on the problem.

Terran McCanna (tmccanna) wrote :

Okay, I put this on a test server with a Concerto database and it's working great. We'll revisit and see if we can pinpoint the difference.

Bill Erickson (berick) wrote :

Terran, I think this might be a slow-loading issue. I tested on a larger data set and the bucket took a very long time to render. If you leave the interface up for a few minutes, limiting to 5 rows, does it eventually display? We may have a bad DB query plan...

Changed in evergreen:
milestone: 3.2.4 → 3.2.5
Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Terran McCanna (tmccanna) wrote :

Okay - started over and just did a patch for the Deleted column since that was the original bug report and since I suspect the Edition column is the one that is slowing it down. (I'll create a second bug report for the Edition column.)

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mccanna/lp1746360_add_deleted_to_record_bucket

Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
Terran McCanna (tmccanna) wrote :

New bug report for Edition column created here:
https://bugs.launchpad.net/evergreen/+bug/1818694

Bill Erickson (berick) wrote :

Thanks, Terran. Merged to 3.1 and above.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers