Port holds pull list to Angular / Wide Holds API

Bug #1919465 reported by Bill Erickson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Evergreen 3.6

Working on porting the pull list to Angular. I've included the addition from bug #1898114 (org selector).

Work in progress here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lpxxx-hold-pull-list-angular

Revision history for this message
Bill Erickson (berick) wrote :
summary: - Port holds pull list to Angular
+ Port holds pull list to Angular / Wide Holds API
Bill Erickson (berick)
Changed in evergreen:
milestone: none → 3.next
tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Jessica Woolford (jwoolford) wrote :

This is looking really good! One of the things our libraries miss is the ability to filter the pull list. I know this is possible with the Angular grids. Any chance that could be added?

Revision history for this message
Jessica Woolford (jwoolford) wrote :

One more thing - I'm not sure if holds are retargeting correctly? When I find a user with the right permissions, it says the hold has successfully retargeted but it still appears on the pull list. I would expect that it would move on to one of the other eligible copies.

Revision history for this message
Bill Erickson (berick) wrote :

Thanks, Jessica.

I was not able to reproduce the retargeting issue you raised. When I retarget a hold in the list, it disappears. Any chance it just found another target at the same branch or simply retargeted the same item?

Also, I looked at the filtering and found that the data structures used by the grid filter are not compatible with the new wide holds API we use to render the page. It will take some work to implement. I suggest opening a new LP bug for the filtering feature.

Here's a rebased branch for good measure:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1919465-hold-pull-list-angular-v2

Changed in evergreen:
assignee: nobody → Josh Stompro (u-launchpad-stompro-org)
Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :

I'm planning on testing this out tomorrow, and was looking it over and noticed that Open-ILS/src/eg2/src/app/staff/circ/holds/pull-list.component.html contains two printTemplate entries.

"hold_pull_list" is referenced elsewhere in the branch, while holds_pull_list seems like it is only referenced in xul client code so maybe that is a mistake?

+<eg-holds-grid
+ printTemplate="holds_pull_list" <------
+ persistKey="circ.holds.pull_list"
+ printTemplate="hold_pull_list"

I can fix that in the signoff if it really is a mistake. It probably doesn't cause any problems since the second assignment is correct.

Josh

Revision history for this message
Bill Erickson (berick) wrote :

Posting a new branch in a moment that addresses Josh's comment and rebases to current master.

Revision history for this message
Bill Erickson (berick) wrote :

Aforementioned branch:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1919465-hold-pull-list-angular-v3

Note the print template fixed is squashed into the main commit.

Changed in evergreen:
milestone: 3.next → 3.8-beta
Revision history for this message
Bill Erickson (berick) wrote :

Pushed another commit to the same branch to fix an issue with the default pull list sorting. It should now sort by default the same as other pull lists (copy location order, etc.)

Revision history for this message
Michele Morgan (mmorgan) wrote :

As suggested in IRC, I'm adding for consideration a list and order of default columns for the pull list grid:

Item Location
CN Full label
Part
Author
Title
Current Item
Pickup Library
Hold Type
Potential Items
Request Time

Revision history for this message
Michele Morgan (mmorgan) wrote :

Also meant to add that according to the current convention, the "Item Location ..." columns should actually read "Shelving Location ..."

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

+1 to Michele's default columns and updating "Item Location" to "Shelving Location"

Revision history for this message
Terran McCanna (tmccanna) wrote :

+1 to Michele's and Jennifer's order and naming.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

In the Detail View (Actions -> Show Hold Details) the Record Summary is missing.

The record summary shows the title of the hold so I think it's important to keep on this page.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Mark as Discard/Weed is missing from the Actions menu. This is an option in 3.7

Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :

Hello, the current sort doesn't include the call number prefix and suffix.

We use call number prefix almost like a shelving location for many of our items, so we always like to include that in the pull list sort.

Josh

Changed in evergreen:
assignee: Josh Stompro (u-launchpad-stompro-org) → nobody
Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
tags: removed: pullrequest
Revision history for this message
Bill Erickson (berick) wrote :

Rebased branch pushed:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1919465-hold-pull-list-angular-v4

Includes patches:

* Include call number prefix/suffix in sorting
* Adds Discard/Weed action
* Default columns as discussed above
* Display bib record summary on hold summary view

tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :

Hello, here are my testing notes

Marking items as damaged, missing and discard/weed seems to work fine from the pull list.

I see call number prefix and suffix in the print out, and it seems to be sorting correctly.

I did notice one possible problem, I'm seeing the same copy listed multiple times in the report when there are both copy, part and title holds for the same copy. But I have been messing with the holds quite a bit... so I'm not sure if that is a problem or not. And I'm not sure if that is a pre-existing problem?

If I switch back to the older hold pull list interface, I don't see duplicates like that.
https://tiffany-master.gapines.org/eg/staff/circ/holds/pull

Josh

Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Here's a rebased branch that addresses the duplicate copy issue:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1919465-hold-pull-list-angular-v5

The commit makes 2 changes:

1. Only show a value for "Current Item" when a hold has a targeted item (i.e. hold.current_copy).

2. Adds a new column called "Requested Item" which displays the copy barcode for copy-level holds regardless of whether the hold has a current_item.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Bill Erickson (berick) wrote :

Though I suppose the bigger question is why copy level holds with no target are appearing on the pull list. Another fix en route.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Fix for my last comment pushed. The Pull List now only shows pulls with a targeted item.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Jennifer Weston (jweston) wrote :

Looking very nice!
I found one thing in my testing: "Print Full List" button returns only items on list for registered workstation even if you are viewing list for another OU (does not honor view pull list choice).

Example: using workstation registered for BR1; viewing pull list for BR2; click on Print Full List and results are for items on hold list for BR1

https://terran-master.gapines.org/eg/staff/circ/holds/pull

Revision history for this message
Bill Erickson (berick) wrote :

Hi Jennifer, https://terran-master.gapines.org/eg/staff/circ/holds/pull is not the correct interface.

The new one is at /eg2/en-US/staff/circ/holds/pull-list though I suspect it's no longer installed on terran-master.

Revision history for this message
Jennifer Weston (jweston) wrote :

Hi Bill,
It does help if I test on the correct interface. Retested on tiffany-master (https://tiffany-master.gapines.org/eg2/en-US/staff/circ/holds/pull-list) per bug squashing list -- and the "Print Full List" behavior works as expected and is quite lovely.

I have tested this code and consent to signing off on it with my name, Jennifer Weston, and my email address, <email address hidden>

tags: added: signedoff
Changed in evergreen:
assignee: nobody → Chris Sharp (chrissharp123)
Revision history for this message
Chris Sharp (chrissharp123) wrote :

Pushed to master! Thanks, Bill and Jennifer and everyone who participated.

Changed in evergreen:
status: New → Fix Committed
assignee: Chris Sharp (chrissharp123) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers