Booking Module Search by resource type box not populating

Bug #1916949 reported by Steve Callender
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.6
Medium
Unassigned

Bug Description

Tested in numerous 3.6 instances.

When going into Booking > Create Reservation, the Search by resource type box is not populating even if you click your mouse in the box. You have to enter either a letter, or space bar for it to show anything, and even then the letter or space has to match the resource type for it to display. It also is not limiting to just the org owner, it is showing all of them if the letter matches.

Jane Sandberg (sandbej)
Changed in evergreen:
status: New → Confirmed
tags: added: angular booking
Changed in evergreen:
assignee: nobody → Jane Sandberg (sandbej)
importance: Undecided → Medium
Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks for reporting this, Steve! It looks like this is happening to all comboboxes that have an idlClass and asyncSupportsEmptyTermClick="true". When a user clicks, we fetch all the data from pcrud, and get it all ready to go, we just... never display the fruits of our labors. :-)

Fix at user/sandbergja/lp1916949_async_comboboxes_show_values_on_click
Here's a link: https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1916949_async_comboboxes_show_values_on_click

Here are testing notes from the (probably over-lengthy) commit message:

To test:
1) Apply this patch.
2) Go to Booking > Create Reservation
3) Click inside the Resource Type box.
4) Note that the available resource types display!

To make sure that asyncSupportsEmptyTermClick="false" still also
works as expected:
5) Go to Acquisitions > General Search.
6) Perform an empty search.
7) In the search results grid, some filter comboboxes have
   asyncSupportsEmptyTermClick, while others do not. For example, the
   Status column has it, so if you click in the Status filter, a list of
   possible statuses will show up. However, the Selecting User column
   (you have to enable this column) does not have it, so if you click in
   that filter, it doesn't automatically display a useless list of 100
   users.

As far as resource types that don't belong to the org owner go, that should be controlled by the VIEW_BOOKING_RESOURCE_TYPE permission. If a user has that at a consortium level, they will see all the booking resource types. If we'd like to re-think this behavior, or if that is not working consistently, I think it should be a separate ticket.

Changed in evergreen:
assignee: Jane Sandberg (sandbej) → nobody
tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.6.3
Revision history for this message
Terran McCanna (tmccanna) wrote :
Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
assignee: Terran McCanna (tmccanna) → nobody
tags: added: signedoff
Changed in evergreen:
milestone: 3.6.3 → 3.6.4
Galen Charlton (gmc)
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Changed in evergreen:
milestone: 3.6.4 → 3.7.2
Revision history for this message
Galen Charlton (gmc) wrote :

It looks like there were at least three independent implementations of a fix for click-on-empty async eg-combobox. Commit 1b70eb2e1 made it in first, so I think Jane's patch is obviated - however, I'll look into whether backporting that commit is advisable.

Revision history for this message
Galen Charlton (gmc) wrote :

That one indeed backported cleanly, so I've done so to fix this bug. I agree with Jane regarding the way it currently handles VIEW_BOOKING_RESOURCE_TYPE. Thanks!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers