Staff Client Whitescreen on login on all browsers on iOS/Android

Bug #1901760 reported by Llewellyn Marshall
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.5
Undecided
Unassigned

Bug Description

Evergreen Version: 3.5.1
Postgres version: 9.6
Server OS: Ubuntu
Devices affected: iPad, iPad Pro, iPhone, Android phones, potentially Windows vista

Our consortium has recently upgraded to Evergreen 3.5.1 and staff who used Evergreen with their iOS and Android devices in the past have been unable to login to the staff client. Staff can enter their username and password, but once their information is submitted, the screen turns white except for the top navigation bar. This appears to be happening on the workstation administration page. Staff have tried to login from Safari, Firefox, and Google Chrome. I’m not able to replicate his issue on Windows except from Internet Explorer, but we have had a report of this issue on Vista.

Chrome console output we’ve received from staff show a “SharedWorker() not supported” warning followed by a “possibly unhandled rejection: undefined” error. This led us to think that the SharedWorker wrapper on Lovefield could be the source of the error. This is consistent with the SharedWorker compatibility chart at this link: https://developer.mozilla.org/en-US/docs/Web/API/SharedWorker

Revision history for this message
Llewellyn Marshall (lbmarshallv) wrote :
Revision history for this message
Terran McCanna (tmccanna) wrote :

We are currently testing in preparation for our upgrade to 3.6.1 in January and seeing this problem as well on all types of mobile devices.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → High
tags: added: regression
Revision history for this message
Jason Stephenson (jstephenson) wrote :

It looks like Firefox 83.1 on Android supports shared workers. The web staff client works for me with Firefox 83.1 on both my phone (Samsung Galaxy S9 with Android 10) and my tablet (Samsung Galaxy Tab E 32GB with Android 8.1).

It's not going to work on iOS until it works with Safari because Apple does not allow the other browsers on iOS to use their own web engines. They all must use Safari underneath.

It's possible that the shared worker code could be removed from the web staff client, but I'll leave that someone more knowledgeable than I.

Revision history for this message
Terran McCanna (tmccanna) wrote :

I also confirm that Firefox on Android is working for me, but Chrome on Android does not.

Revision history for this message
Terran McCanna (tmccanna) wrote :
Revision history for this message
Christopher Burton (cburton) wrote :

There was a bug for this on 3.1 that had a patch pushed and it may be related to this issue https://bugs.launchpad.net/evergreen/+bug/1789747

Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :
Changed in evergreen:
milestone: none → 3.6.2
assignee: Bill Erickson (berick) → nobody
tags: added: pullrequest
Revision history for this message
Terran McCanna (tmccanna) wrote :

Thanks, Bill! Our iOS testers are now able to get into the staff client. They did not test everything, but tested basic circ/patron functions and all worked well.

I consent to signing off with my name, Terran McCanna, and email address, <email address hidden>

tags: added: signedoff
Revision history for this message
Michele Morgan (mmorgan) wrote :

This is great! But I need to mention that I was looking at this today also, and had problems when the device did not already have a registered workstation for the server.

I was able to enter credentials for my test server, and could see by the url that I was redirected to the workstation registration page, but there I had a whitescreen and could not get further.

I hope this is because there was something wrong with my test server, but Terran, by chance did you try registering a workstation?

Revision history for this message
Bill Erickson (berick) wrote :

Michele, I was able to reproduce the workstation registration error. Pushing a fix shortly.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
tags: removed: pullrequest signedoff
Revision history for this message
Bill Erickson (berick) wrote :

Correction, I was testing the wrong branch :\. I am unable to reproduce the workstation registration issue. However, I did find a problem with my previous branch where I had left some test code in the final commit.

Here's a new branch with the test code removed and with Terran's sign off's on the first 2 commits. Final commit will also need a sign off.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1901760-shared-worker-protection-part3

tags: added: pullrequest
Revision history for this message
Tiffany Little (tslittle) wrote :

I just tested this on my test server, and I'm still seeing the workstation registration error. I get to the sign-in screen, but after that I'm directed to the workstation registration screen but it's whitescreened.

Revision history for this message
Terran McCanna (tmccanna) wrote :

Hrrm. Applying the most recent commit re-broke it.

Revision history for this message
Bill Erickson (berick) wrote :

Are you seeing the same "SharedWorker() not supported" message in the console when you get the blank pages? Any other errors?

Revision history for this message
Jason Boyer (jboyer) wrote :

Hi, I tried out the part3 branch and while I did have to reload a couple times to get my phone to stop using a cached version everything is working for me (as best it can at these resolutions, anyway). I was able to successfully use the staff client in Safari on a Mac, iPhone, and iPad without trouble. Signoff is here: https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1901760_shared_worker_signoff / working/user/jboyer/lp1901760_shared_worker_signoff

tags: added: signedoff
Revision history for this message
Jason Stephenson (jstephenson) wrote :

We're seeing this behavior on 3.2.10 with the patch from bug 1848550 backported and installed. I suspect that patch could be a proximal cause of this issue. Hopefully, that can help find a solution.

Bill Erickson (berick)
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Revision history for this message
Jason Stephenson (jstephenson) wrote :

After testing on 3.5.2 we've confirmed that this patch is working for us. I"ve added John Amundson's and my sign offs and pushed to master, rel_3_5, and rel_3_6.

Thanks, everyone!

Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers