OPAC only shows the first 505 (contents note)

Bug #1896266 reported by Jane Sandberg on 2020-09-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

In current master, in both the classic TPAC and the new bootstrap OPAC:

For really long contents notes, catalogers will sometimes split them over two 505 fields. However, only the first contents note displays in the OPAC.

Here's an example: https://libcat.linnbenton.edu/eg/opac/record/591947?locg=7;detail_record_view=1;query=literacy%20kit%20linn-benton

Note that if you remove the query parameter from that url, the second contents note *will* display: https://libcat.linnbenton.edu/eg/opac/record/591947

Steps to recreate:
1) Create a bib record with multiple 505s (in can be formatted contents note or not -- both are affected by this bug)
2) Search for the record in the OPAC
3) Click on the result that matches your bib record
4) Look for the contents note (in the bootstrap OPAC, click on the More details button)
5) Note that only the first contents note displays

Janet Schrader (jschrader) wrote :

This is a new bug but I thought I remembered a discussion about this before. This is not the only repeatable field that does not display in the OPAC.

I can confirm that this is happening on REL 3.2.8. in both the web client and in the public OPAC. I can also confirm that with multiple contents note, it's not always the same one that displays.
https://bark.cwmars.org/eg/opac/record/4248805?fi%3Asearch_format=blu-ray;locg=1;detail_record_view=0;page=0;sort=poprel;query=title%3Abeatles%20white%20album;badges=1;expand=marchtml#marchtml
In this example, the bib record for "Beatles White album" has six 505 fields for the music CDs. The first time I looked at it in the public OPAC, the contents for CD one displayed, the next time it was CD six.

Note: the same problem exists for multiple 520 (annotation) fields.
https://bark.cwmars.org/eg/opac/record/3763461?query=grisham%20asociado;qtype=keyword;fi%3Asearch_format=;locg=1;detail_record_view=0;_adv=1;page=0;fi%3Aitem_lang=spa;sort=poprel
This record has two 520 fields, one in Spanish and one in English. The English one is first in the bib record, but only the second, the Spanish one, displays.

Note: there is also a bug that if there are multiple edition fields, only one displays, LP# 1802128.

This is somewhat out of the scope of this bug, but I think it's important, that if MARC fields are repeatable in the bib record, then the fields should all display in the web client and public OPAC.

Janet

Elaine Hardy (ehardy) wrote :

This record has 22 505s and it appears all are displaying in the OPAC

https://gapines.org/eg/opac/record/705294?_special=1;detail_record_view=0;locg=1;query=identifier%7Ctcn%3A%20ocm14359362

We are on version 3.4.1

Anna Goben (agoben) wrote :

I see this happen frequently, albeit intermittently, with repeatable fields. Most commonly with 520 entries, but also 505 entries. Often if you reload the record, then the rest of the fields magically appear, but they definitely didn't the first time around.

Garry Collum (gcollum) wrote :
Changed in evergreen:
status: New → Confirmed
Elaine Hardy (ehardy) wrote :

Looking at the MARC record display in the OPAC for the demo.evergreencatalog record 46, the 505s were missing the 1st indicator. It should be 0. I corrected the indicators in the staff catalog and now all the 505s display in the Patron OPAC view

Garry Collum (gcollum) wrote :

I'm still only seeing the last 505 displayed, if I do a search by tcn, as opposed to going to the record directly.

Oddly enough, if I do a keyword search on Elliott Carter to get to the record, I see only the first 505 displayed. https://demo.evergreencatalog.com/eg/opac/record/46?query=elliott%20carter;qtype=keyword;locg=1;detail_record_view=0;_adv=1;page=0;_special=1;expand=marchtml#marchtml

But it seems to have something to do with the query/qtype strings in the url. If I remove that combination of strings from the url, all of the 505s display.

Elaine Hardy (ehardy) wrote :

Interesting -- I searched keyword elliott writings after I corrected the indicator and saw all the 505s. Now, doing the search, only the first 505 displays.

When I search by title (writings of elliott carter), only the last 505 displays.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers