Angular catalog recall, force, and part holds

Bug #1851882 reported by Bill Erickson
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Medium
Unassigned

Bug Description

Wishlist circa Evergreen 3.4

The Angular staff catalog needs entry points for recall (item), force (item), and part-level holds.

Branch en route which allows for seamless toggling between item, recall, and force holds when the initial entry point for the hold is any of those types.

Similarly, allow the user to optionally select a part for title-level holds (thus morphing them into part holds).

Part-level hold changes are applied per row/record in the batch hold list. For item-level holds, changing the type affects the whole batch.

Revision history for this message
Bill Erickson (berick) wrote :

Code with release notes here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1851882-ang-cat-more-hold-types

To test, place item-level or title-level holds in the Angular catalog and note the additional buttons/selector for item-level types and bib-to-part selection.

tags: added: holds pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Revision history for this message
Mike Rylander (mrylander) wrote :

Thanks, Bill.

Scanning the code, it looks sane, but I think we may want to restrict the part list returned by the perl to only non-deleted parts. IIUC, that is only used for changing the part, and I think we want to avoid selecting a deleted part.

Revision history for this message
Bill Erickson (berick) wrote :

Doh, thanks Mike! Pushing a patch for that now.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Bill Erickson (berick)
tags: added: staffcatalog
Revision history for this message
Bill Erickson (berick) wrote :
Changed in evergreen:
milestone: 3.5-beta → 3.5.0
Changed in evergreen:
milestone: 3.5.0 → 3.5.1
Changed in evergreen:
milestone: 3.5.1 → 3.5.2
Revision history for this message
Elaine Hardy (ehardy) wrote :

Tested on http://angular-acq-test.evergreencatalog.com/

Using catadmin login Diana Beck Cataloging Administrator br1dbeck 99999361901 BR1 BR1 dianab1234

From Holdings view -- actions -- recall item for TCN 49

Was able to place Item hold successfully. A little confusing at first for how to return to the bib record since there is no return or continue option that mirrors current staff client. Did click on title link for bib record.

Was unable to place recall or force hold PERM_FAILURE. This corresponds to current staff client -- PINES hasn't implemented either of those holds so perms are used to block their use.

Since recall item is an item hold, I didn't see a parts hold option, even after adding parts to TCN/Record ID 49

Erica Rohlfs (erohlfs)
Changed in evergreen:
assignee: nobody → Erica Rohlfs (erohlfs)
Revision history for this message
Erica Rohlfs (erohlfs) wrote :

It took me a moment to understand how to place different hold types in this interface. I logged in as Admin and successfully placed Force and Recall holds. I do not see a way to place part level holds. Also, a bit of strangeness. I searched for Elaine's record (via TCN search) and I was given the older view than what I have in my original search. In the attached image, you'll see the difference in view for Record TCN 64 (the record I retrieved via catalog search) versus Record TCN 49 (Elaine's test record I retrieved via TCN search). Also, confirming that, when I went back and search for my test record TCN 64 via TCN search, it reverted back to older view, as well. Also of note, there is not a Parts column in holding view, so it's not easily discernible if there are any parts associated with items (to know whether a part hold option should be expected).

Changed in evergreen:
assignee: Erica Rohlfs (erohlfs) → nobody
Revision history for this message
Bill Erickson (berick) wrote :

Thanks, Erica.

1. For missing columns in the Holdings view, including parts: bug #1892077

2. For part holds, if parts are available there will be a selector in the row for each hold to select a part or default to Any Part.

3. It sounds like there's another spot that needs updating to point to the new catalog. I'll look into that and open a separate LP.

Revision history for this message
Jennifer Weston (jweston) wrote :

Thanks for the development, Bill!

Tested on https://tiffany-master.gapines.org/eg/staff/

Additional holds functionality works as expected.
Added bib for DVD set with multiple discs & created parts for testing, TCN 251
Able to successfully toggle between item, recall and force hold types and place holds for each type.
Able to successfully select a part from title-level hold.
It's lovely to see parts added to the Holdings view (from fix committed for bug #1892077)

Noting that searching today by title keyword or by TCN returns the same result for Holdings View in new Angular style display.

I have tested this code and consent to signing off on it with my name and my email address, Jennifer Weston, <email address hidden>

tags: added: signedoff
Revision history for this message
Chris Sharp (chrissharp123) wrote :

Pushed to master and rel_3_5. Thanks, Bill and Jennifer!

Changed in evergreen:
status: New → Fix Committed
Revision history for this message
Galen Charlton (gmc) wrote :

Noting per IRC discussion that this bug, which was originally classified as a wishlist item, is being treating more as a functionality regression now that the Angular staff catalog is the default for 3.6. I've adjusted the bug importance and tag accordingly.

Changed in evergreen:
importance: Wishlist → Medium
tags: added: regression
Revision history for this message
Mary Llewellyn (mllewell) wrote :

Can you add a Parts column to the Item Table? It feels like an incomplete display without it.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers