Failure reason autorenewal notifications to patrons should not include the event code

Bug #1842431 reported by Michele Morgan on 2019-09-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned

Bug Description

When a patron is notified of a failed autorenewal attempt, the item data in the email message looks like this example.

    Title: Harry Potter and the prisoner of Azkaban
    Author: Rowling, J. K.
    Library: Danvers
    Status: **NOT RENEWED, PLEASE RETURN**
    Reason: COPY_NEEDED_FOR_HOLD : Copy is needed to fulfill a hold
    Due Date: 07-23-2019

    Title: Call the midwife Season six
    Author: Agutter, Jenny
    Library: Danvers
    Status: **NOT RENEWED, PLEASE RETURN**
    Reason: MAX_RENEWALS_REACHED : Circulation has no more renewals remaining
    Due Date: 07-23-2019

Patrons don't need to see the failure code (COPY_NEEDED_FOR_HOLD, MAX_RENEWALS_REACHED, etc.) for failed renewals, just the description.

Michele Morgan (mmorgan) on 2019-09-03
Changed in evergreen:
assignee: nobody → Michele Morgan (mmorgan)
Jason Stephenson (jstephenson) wrote :

I have made a "fix" for this and loaded it on our testing server, I'm sharing it here so that Michele and others may review it:

user/dyrcona/lp1842431-autorenew-split-event-textcode-description

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1842431-autorenew-split-event-textcode-description

I'm not trying to compete with Michele, it's just that we had a branch ready to share.

Changed in evergreen:
importance: Undecided → Wishlist
milestone: none → 3.next
Michele Morgan (mmorgan) wrote :

Thanks for sharing your branch Jason! This is what I've been working with:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mmorgan/lp1842431_fix_renewal_failure_reason

[% udata.reason %] is what gets used in the stock AutorenewNotify action trigger template, so that's where I made the change.

Adding a pullrequest tag. Comments welcome.

tags: added: pullrequest
Changed in evergreen:
assignee: Michele Morgan (mmorgan) → nobody
Jason Stephenson (jstephenson) wrote :

Michele, while I like the simplicity of your fix, I wonder if someone would want to display the text code in a patron notice.

I made my change to follow the principle of least surprise, i.e. the current behavior of the default template is unchanged. I added separate fields for the textcode and the description in case someone would want to display either of those individually. I'll admit that my branch is probably overkill, but I'll leave it to others to decide which fix is better, of if some combination of the two should be done, i.e. removing textcode from the reason but adding it as its own field.

Anyway, I give my signoff to your change if that's the direction that others want to go.

Changed in evergreen:
status: New → Confirmed
Michele Morgan (mmorgan) wrote :

Maybe both changes should go in. In that way, the stock notices would give a friendlier message, but the option to include the text code would be there, too.

I added Jason's changes to this branch:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mmorgan/lp1842431_fix_renewal_failure_reason_take_two

Jason Stephenson (jstephenson) wrote :

I have rebased Michelle's latest branch on master and added my signoff to her first commit here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1842431_fix_renewal_failure_reason_take_two-signoff

I say this is ready to go, but would like another set of eyes before pushing it.

Changed in evergreen:
status: Confirmed → Won't Fix
milestone: 3.next → 3.5-alpha
status: Won't Fix → Confirmed
tags: added: signedoff
Bill Erickson (berick) wrote :

Moving from Wishlist to Low-priority bug fix. I see this as a usability bug. Input welcome.

tags: added: usability
Changed in evergreen:
importance: Wishlist → Low
no longer affects: evergreen/3.4
Changed in evergreen:
milestone: 3.5-alpha → 3.4.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers