Combined Aged and Active Circulations Report Source not Exposed to Auto-Renewal Fields

Bug #1835577 reported by John Amundson on 2019-07-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.2
Undecided
Unassigned
3.3
Undecided
Unassigned

Bug Description

Evergreen 3.2.4

The circulation and aged_circulation tables both have new fields for auto_renewal and auto_renewal_remaining. These fields are also present in the all_circulation database view.

These fields are also available in the Circulation Report Source. The fields are not available, however, in the Aged (patronless) Circulation report source or the Combined Aged and Active Circulations report source.

It's imperative for especially the latter to have access to these fields. We have several report templates that count/list circulations by renewal type, and without access to the Auto Renewal field, there is no way to separate out auto-renewals.

We anonymize circulations after a set period, so the Circulation source will not always have complete data.

This makes it difficult to count initial circulations vs renewals.

This is also compounded by Bug #1835085, which currently sets both desk and auto renew to TRUE for auto-renewals.

Changed in evergreen:
status: New → Confirmed
Jason Stephenson (jstephenson) wrote :

This appears to be caused by the auto_renewal and auto_renewal_remaining fields not being included in the IDL entries for acirc and combcirc.

Changed in evergreen:
milestone: none → 3.4-beta1
assignee: nobody → Jason Stephenson (jstephenson)
Changed in evergreen:
status: Confirmed → In Progress
Jason Stephenson (jstephenson) wrote :

We've added the IDL changes on our training system and the fields appear for us and work in report templates. I'm adding a pull request for the following branch:

user/dyrcona/lp1835577-add-missing-autorenewal-IDL-fields

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1835577-add-missing-autorenewal-IDL-fields

Changed in evergreen:
status: In Progress → Confirmed
assignee: Jason Stephenson (jstephenson) → nobody
tags: added: pullrequest
Jason Stephenson (jstephenson) wrote :

I have force-pushed a rebased version of the branch with an additional commit on top. The top commit adds some additional missing instances of auto_renewal and auto_renewal_remaining to the IDL and to four database views.

These missing instances were not required to fix this bug, but I "found" them while working on other auto_renewal changes. I thought that they would fit in better with this branch than with the others.

My pullrequest still stands.

Galen Charlton (gmc) on 2019-09-11
Changed in evergreen:
milestone: 3.4-beta1 → 3.4-beta2
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_3, and rel_3_2. Thanks, Jason!

Changed in evergreen:
status: Confirmed → Fix Committed
Galen Charlton (gmc) on 2019-10-02
Changed in evergreen:
milestone: 3.4-beta2 → 3.4-rc
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers