Improve Angular admin grids with friendlier linked object display

Bug #1819179 reported by Mike Rylander on 2019-03-08
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

The new Angular grid component, as used in the admin interfaces, shows linked objects with a has_a relationship to the main type as the pkey value of the linked objects. When there is a selector set for the linked object type, we can do better by showing the value from the selector field. Branch forthcoming to make it so...

Mike Rylander (mrylander) wrote :
tags: added: pullrequest
Bill Erickson (berick) wrote :

Follow up branch which merges the code from bug #1812670 into this branch and adds some additional logic to the auto-fleshing layers to handle "map"-ed fields.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1819179-and-1812670-pcrud-etc-flesh

Going to mark bug #1812670 as a duplicate of this one since they cover the same ground.

Changed in evergreen:
assignee: Mike Rylander (mrylander) → nobody
tags: added: admin-pages
removed: admin
Dan Wells (dbw2) on 2019-03-22
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

Does the job as described; pushed to master. Thanks, Mike and Bill!

Even though it isn't targeted, I tried to backport to rel_3_2, but it had conflicts. Any opinions on the necessity of that backport from others?

Changed in evergreen:
assignee: Dan Wells (dbw2) → nobody
status: In Progress → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
Mike Rylander (mrylander) wrote :

Follow-up for Dan Wells: I don't think it's important for 3.2, as there's no Angular7 exposed for Official(tm) production use.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers