Unable to place holds from item bucket

Bug #1806394 reported by Jason Boyer on 2018-12-03
16
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.1
Medium
Unassigned
3.2
Medium
Unassigned

Bug Description

All versions of the web client affected

Item buckets have a feature in the Actions menu to place requests (holds) on selected items. When using this feature staff can't actually place any holds because the list of copy ids sent to the server is populated only with undefined entries. (Cue WH official Rachel Constantine from Contact: But why does it have the same number of undefined entries as selected items?!)

Simple fix coming soon.

Jason Boyer (jboyer) wrote :
tags: added: pullrequest
Jason Boyer (jboyer) on 2019-01-16
Changed in evergreen:
milestone: none → 3.next
Jason Boyer (jboyer) on 2019-01-28
Changed in evergreen:
milestone: 3.next → 3.3-beta1
Millissa (millissam) on 2019-02-26
Changed in evergreen:
assignee: nobody → Millissa (millissam)
Changed in evergreen:
milestone: 3.3-beta1 → 3.3-rc
Millissa (millissam) wrote :

Tested on the sandbox 3/5/19. Was able to place holds on different items in item bucket. Confirmed the hold was placed. Looks like it is working.

Changed in evergreen:
assignee: Millissa (millissam) → nobody
Terran McCanna (tmccanna) wrote :

Millissa, can you please add a sign off comment? You can put it in this format:

"I have tested this code and consent to signing off on it with my name, [enter name or consistent alias] and my email address, [enter email address]."

tags: added: signedoff
Rogan Hamby (rogan-hamby) wrote :

Worked as advertised, signoff here: user/rogan/lp1806394

Millissa (millissam) wrote :

This might be redundant now but here goes:

I have tested this code and consent to signing off on it with my name, Millissa Macomber and my email address, <email address hidden>.

Changed in evergreen:
milestone: 3.3-rc → 3.3.1
Galen Charlton (gmc) on 2019-05-07
Changed in evergreen:
importance: Undecided → Medium
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_3, rel_3_2, and rel_3_1. Thanks, Jason, Millissa, and Rogan!

Changed in evergreen:
status: New → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers