Advanced Search Default Pane workstation setting not working

Bug #1799963 reported by Angela Kilsdonk on 2018-10-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Tested on 3.2.0

Setting the Advanced Search Default Pane to 'Numeric' or 'MARC Expert' in Admin>Workstation Admin does not appear to work. The Advanced Search interface continues to default to the regular advanced search tab.

Based on my testing the Default Search Library and Preferred Library settings appear to be working as expected in 3.2.

There was a similar bug a while back (https://bugs.launchpad.net/evergreen/+bug/1437112), but this appears to be a new bug. All workstation search preferences worked as expected in 3.1.

Anna Goben (agoben) wrote :

Confirming I see this on our 3.2 test server too.

Cesar V (cesardv) on 2018-10-25
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :
tags: added: pullrequest webstaffclient
Angela Kilsdonk (akilsdonk) wrote :

Confirming that Cesar's patch worked for me on master. Thanks, Cesar!

Angela Kilsdonk (akilsdonk) wrote :

And to make it official-- I have tested this code and consent to signing off on it with my name, Angela Kilsdonk, and my email address, <email address hidden>.

Andrea Neiman (aneiman) on 2018-10-26
Changed in evergreen:
milestone: none → 3.2.2
status: New → Confirmed
importance: Undecided → Medium
tags: added: signedoff
Cesar V (cesardv) on 2018-10-26
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Changed in evergreen:
milestone: 3.2.2 → 3.2.3
Jason Boyer (jboyer) wrote :

That branch breaks any opac page that isn't eventually reached via the advanced search page. (i.e. loading a record by id, etc.) This branch adds a second commit that makes everything that's not advanced search related work the same as it does today:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1799963-staff-default-adv-search / working/user/jboyer/lp1799963-staff-default-adv-search

Changed in evergreen:
milestone: 3.2.3 → 3.3-beta1
Jane Sandberg (sandbej) wrote :

Thanks for your work, Cesar, Angela, and Jason. I can confirm that Cesar's code with Jason's fix works for me.

I created a signoff branch here: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1799963-staff-default-adv-search-signedoff

The name of the branch is user/sandbergja/lp1799963-staff-default-adv-search-signedoff

Galen Charlton (gmc) wrote :

Pushed to master and rel_3_2. Thanks, Cesar, Angela, Jason, and Jane!

Changed in evergreen:
milestone: 3.3-beta1 → 3.2.4
no longer affects: evergreen/3.2
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers