Web Client - CTRL+Click Required to Open http Links

Bug #1777954 reported by Jennifer Pringle on 2018-06-20
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Medium
Unassigned
3.1
Medium
Unassigned

Bug Description

Evergreen 3.1

In the staff catalogue any links for e-resources that use http rather than https will not open unless you hold down CRTL when you click them. This is happening in both Chrome and Firefox.

The ideal solution is to have all links for e-resources use https but some vendors may not currently offer https.

Jennifer Pringle (jpringle-u) wrote :

Also, http links open without issue in the OPAC.

Terran McCanna (tmccanna) wrote :

As a workaround in our implementation, we added target="_blank" so that those links will always open in a new tab.

Mike Rylander (mrylander) wrote :

IMO, Terran's suggestion is the best solution for both patron and staff views.

Remington Steed (rjs7) on 2018-06-22
Changed in evergreen:
status: New → Confirmed
Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Terran McCanna (tmccanna) wrote :
Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
tags: added: pullrequest
Dan Wells (dbw2) on 2018-07-13
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

This looks good, Terran. Thank you! I have signed off on the existing commit, then added a second to do the same for the results list. Branch is here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dbwells/lp1777954_opening_http_links

working/collab/dbwells/lp1777954_opening_http_links

Changed in evergreen:
milestone: none → 3.2-beta
assignee: Dan Wells (dbw2) → nobody
importance: Undecided → Medium
Kathy Lussier (klussier) wrote :

Thank you Terran and Dan! It works for me. Merged to master, release 3.1 and release 3.0.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers