Web client: Edit function in merge screen does not keep edits

Bug #1776736 reported by Kate Coleman on 2018-06-13
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

When merging records in the webclient, in the merge screen there is an option to Edit and another option to Edit using full editor. Edits can be made with either of those options, but even after hitting save, edits are not actually saved in the merged record.

Web client version 3.0.2
Tested in both Chrome and Firefox

Elaine Hardy (ehardy) on 2018-06-13
Changed in evergreen:
status: New → Confirmed
Sarah Childs (sarahc) wrote :

Aside from flat out not working, the current functionality of this is extraordinarily clunky even if the edits were savable. The main use case for this is to copy information from a record or records to be merged into the lead record. In the XUL client you can have all the records to be merged side by side and open to the flat text editor which allows you to easily copy information from one record to another.

Here, in order to access the flat text editor for the Lead record you have use "Edit using full editor" which opens in a window on top of the merging window, so you can no longer see or copy from the other records.

Elaine Hardy (ehardy) wrote :

Confirmed in 3.2 beta 1

Bill Erickson (berick) wrote :

Was going to open an new LP, but Sarah's comments match those of our staff, so I'll add mine here.

We also need the ability to copy (multiple) values from the sub-ordinate records into the lead record. Copying values from the HTML-view of the subordinate records works fine -- it's essentially a read-only flat-text view -- but if you want to use the flat-text editor to modify the lead record, you are out of luck (unless I'm missing something), since it's not available when editing inline.

My proposal is to make it possible to use the flat-text editor when editing records inline (via the "Edit" button), since that seems to be the missing piece.

Elaine Hardy (ehardy) wrote :

I agree -- flat text editor is much more efficient for copying and pasting fields from one record to another. And you do need to see both records in order to be able to do so readily.

Janet Schrader (jschrader) wrote :

In the xul client (3.0) it's possible to **drag** fields from one record to another when tiled side-by-side both in flat text mode. I've been using this to add annotations, subjects, ISBNs or contents notes when merging so the kept record has the info of both records combined.
With the advent of baskets merging, or simply tiling, to a few records can become even easier so I'd definitely welcome improving flat text editing along with the improvements in the merging development.

Now-- if only the merged record had that red bar signally it's been deleted. bug #1746611.

Bill Erickson (berick) wrote :

I just accidentally discovered that the inline MARC editor in the record merge interface will use the flat text editor that's how the MARC editor was last used. I'm guessing having a toggle there would still be nice.

Janet, you should be able to drag text from the sub-ordinate record into the lead record when you are in the flat text editor mode. Select the text you want to copy, click on it with the mouse, then drag it over into the lead record. This works for me in Chrome, but I have not tested Firefox.

Bill Erickson (berick) on 2019-03-14
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Fixes pushed:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1776736-rec-merge-edit-repairs

From the commit:

1. Fixes issues where edits to MARC records would fail to save during merge.

2. Provide options to select flat or non-flat text editor in edit mode for record merges.

3. Allow record editor action buttons/selectors to flow down horizontally when they don't fit in a narrow space.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.2.5
assignee: Bill Erickson (berick) → nobody
Bill Erickson (berick) wrote :

Updating solution to this bug to use the API consistent with bug #1693580.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
tags: removed: pullrequest
Bill Erickson (berick) wrote :

Branch updated in place to use open-ils.cat API instead of pcrud. This has the added benefit of allowing permission failures on update to prompt for an override.

tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Dan Wells (dbw2) on 2019-03-20
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

This branch does the three things it claims, and I don't see any negative effects. Thanks, Bill!

I have pushed it to master (3.3) and rel_3_2, but it didn't apply cleanly to rel_3_1. The merge window code seems to have been significantly reformatted at some point between 3.1 and 3.2. It still seems to work, so here is my attempt at a rebase:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbwells/lp1776736-rec-merge-edit-repairs_3_1_rebase

working/user/dbwells/lp1776736-rec-merge-edit-repairs_3_1_rebase

Changed in evergreen:
milestone: 3.2.5 → 3.3-rc
no longer affects: evergreen/3.0
no longer affects: evergreen/3.3
Changed in evergreen:
assignee: Dan Wells (dbw2) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers