Web Client: Bill Display Issues (Full Details)

Bug #1743783 reported by Sam Link on 2018-01-17
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.1
Undecided
Unassigned
3.2
Undecided
Unassigned

Bug Description

In 3.0.2:

The Patron Bill display is missing several useful pieces of information:

1) The owning library of the item is not shown.
2) The type of bill is not shown.
3) While the billing location is available as a column option, it is always blank.

Andrea Neiman (aneiman) wrote :

Bug 1737603 was previously opened for issue #2 above, billing type. Sam, do you mind confirming that bug? Thanks!

Sam Link (slink-g) wrote :

Gladly!

tji@sitka.bclibraries.ca (tji) wrote :

3) While the billing location is available as a column option, it is always blank.

I believe the location is for grocery bills only. For circulation bills, the circ library field indicates the location.

Tina

Changed in evergreen:
status: New → Confirmed
John Amundson (jamundson) wrote :

Testing in Web Client 3.0.7

1) I can confirm the Owning Library is not shown. This is very important for CW MARS libraries and is our top priority on this bug. Libraries use this field to ensure money is returned to the correct library.

2) The Type column is also empty for us.

3) Confirming Comment #3. Billing Location only shows for grocery bills. There is another column simply called Location that combines Billing Location and Checkout/Renew Library.

In addition to these, we have also found the following fields have issues are are simply missing:

4) There are two columns for Checkout/Renewal Library. One of them lists the library as desired, the other field outputs an array of information that is not helpful on this screen.

5) Circulation library can be added, but after the initial add, subsequent visits to the page do not load information in this column. Very similar to how some fields behaved in this bug: https://bugs.launchpad.net/evergreen/3.1/+bug/1760997

6) Last Payment Type is missing.

7) Last Payment Note is missing. (Last Billing Note exists and displays under the column header "Note").

Some of these fields are mentioned in bug 1739607, which also covers other patron interface outside of Billing.

Dawn Dale (ddale) wrote :

I can agree with John on the problems he is reporting. It would be very beneficial to PINES to have these issues resolved in the web client. The billing location is something we need as well. In the XUL client it was listed at the top of the full details of a bill. In Webby this field is blank. I am attaching 2 screen shots to show the difference.

Dawn Dale (ddale) wrote :

Adding the second attachment

Dawn Dale (ddale) wrote :

Adding the second attachment

Jennifer Pringle (jpringle-u) wrote :

A related bug with additional information about columns missing in Bills is https://bugs.launchpad.net/evergreen/+bug/1662535

Michele Morgan (mmorgan) on 2018-05-31
tags: added: webstaffcolumns
Remington Steed (rjs7) wrote :

Dawn, it looks like you uploaded the same screenshot twice. Any chance you still have the second screenshot available, or could you re-make it?

Dawn Dale (ddale) wrote :

Hi Remington,

Here is the first screenshot. Let me know if this is not what you are referring to.

Thanks,

Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Terran McCanna (tmccanna) wrote :

This patch further fleshes out the retrieved data and updates template to be able to display the billing location for both circulation and grocery bills on the bill details page. (The other two items in this bug report are already fixed in 3.2.1).

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=20839047a7c4a53cfbec8b6537af94ce8dd2bb40

tags: added: pullrequest
John Amundson (jamundson) wrote :

I wanted to note that at least 1) and 2) in the initial report appear to refer to the patron's bills tab, (circ/patron/xxxxx/bills), and not necessarily the full details screen.

On our 3.2.2 system, Item Owning Library is still not an available column and Type still displays blank.

Terran McCanna (tmccanna) wrote :

There are a lot of different issues here that should probably be split into different bugs to make them easier to resolve. At least into separate bugs for the main bills grid and the bill details screen.

Terran McCanna (tmccanna) wrote :

I've changed the title of this bug to just be for the Full Details page.

Bug 1662535 addresses all of the missing columns on the main bills page except Type, which is addressed in Bug 173703.

The Billing Location column on the main bills page only shows the Billing Location for circ items, but Location shows both circ and grocery. Not ideal, but it is there.

The remaining two problems with the Full Details page, Billing Location and Owning Library, are addressed in this updated patch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=6dd1cba40f85f4367c6e2fafcb575174e7711dfd

tags: added: billing
summary: - Web Client: Bill Display Issues
+ Web Client: Bill Display Issues (Full Details)
Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
Changed in evergreen:
assignee: nobody → John Amundson (jamundson)
John Amundson (jamundson) wrote :

Tested on a 3.2.2 system with this patch and the one for Bug #1662535 installed.

This looks good. On both the Statement and Details pages, Billing Location displays for both circulation and grocery bills, and owning library is present on circ transactions.

Thanks for your work on this, Terran.

I have tested this code and consent to signing off on it with my name, John Amundson, and my email address, <email address hidden>

Changed in evergreen:
assignee: John Amundson (jamundson) → nobody
tags: added: signedoff
Changed in evergreen:
milestone: none → 3.3-beta1
Jason Stephenson (jstephenson) wrote :

I have tested this on rel_3_1 and it works there, too.

I signed off and committed to master, rel_3_1, and rel_3_2 along with the branch from bug 1662535. I also added a combined release notes file for both bugs.

Thanks, Terran, John, and everyone else who participated in the discussion on this bug!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers