web client: full library names truncated in holdings view

Bug #1735807 reported by Chris Sharp on 2017-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

In the Holdings View of the OPAC in the web client, the full names of the library (currently "Full System Name ... Full Branch Name" become truncated to the point of non-usability if enough columns are displayed. A preferred solution to this according to an informal consensus in IRC is to use the short (policy) names of the libraries/branches instead (see http://irc.evergreen-ils.org/evergreen/2017-12-01#i_336142 for discussion).

Evergreen 3.0.1/Master
OpenSRF 3.0.0/Master
PostgreSQL 9.5
Ubuntu 16.04
Chrome 62 on Fedora 27

Chris Sharp (chrissharp123) wrote :
Bill Erickson (berick) on 2017-12-01
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: New → Confirmed
Bill Erickson (berick) wrote :
tags: added: pullrequest usability
Changed in evergreen:
milestone: none → 3.0.3
assignee: Bill Erickson (berick) → nobody
Kathy Lussier (klussier) on 2017-12-01
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Chris Sharp (chrissharp123) wrote :

I hesitated a day since I saw Kathy assign this bug to herself, but I have a signoff branch here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/lp1735807-holdings-lib-shortname

tags: added: signedoff
Kathy Lussier (klussier) wrote :

It looks good, but I'm coming across one strange problem. When I first retrieve a record and then click the Holdings View tab, on the first try, I either get no org units listed or I get a limited number of holdings listed. If I click OPAC view again and then click back into Holdings View, all holdings display as expected.

I have a screencast showing the behavior I'm seeing. https://drive.google.com/file/d/14WmqhYs-YTTHHk6lqO_GINGL1PQC_UmG/view

I don't see the same behavior on a clean master system.

Since this change will primarily affect catalogers, I'll throw out a message to the cataloging list to bring attention to this bug to verify that they see this change as an improvement.

Thanks Bill!

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Kathy Lussier (klussier) wrote :

On further investigation into the previously-reported issue, I think I was seeing a pre-existing bug related to the "Show empty volumes", "Show copy detail" and "Show volume detail" checkboxes. I'll file those issues in another bug if it hasn't already been filed.

Changed in evergreen:
assignee: nobody → Jason Etheridge (phasefx)
Jason Etheridge (phasefx) wrote :

Pushed to master, thanks!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Jason Etheridge (phasefx) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers