Webstaff option to show/hide multiple grid columns

Bug #1730752 reported by Bill Erickson on 2017-11-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Evergreen 3.0 / Wishlist

When showing and hiding grid columns in the browser client, it would be nice to be able to show/hide multiple columns at a time so the user does not have to reopen the column picker each time.

One option discussed at the hack-a-way was a column-picker dialog, similar to the Dojo-grid column config dialog, where users can view and modify all available columns. The dialog would start as a simple visibility selector, but could potentially pick up other functionality, like moving the "sort" options into the dialog.

Bill Erickson (berick) wrote :

Force-pushed a squashed commit back to the same branch with a few additional changes.

====

Adds a new "Manage Columns" grid action which opens a batch grid column configuration dialog. In the dialog, users can show/hide multiple columns at once. The column position actions (left/right/far-left/far-right) and sort priority settings have also been moved to this new UI.

The existing 'Configure Columns' action has been renamed to 'Managed Column Widths' and now only supports making columns wider and narrower.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.next
milestone: 3.next → 3.0.2
Kathy Lussier (klussier) on 2017-11-09
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

I like it! It bears further testing, but I'm also not seeing the problems I noted in bug 1728952 when I was testing this code.

I have a couple of follow-up comments:
- When I columns is set to be visible, it continues to display in the manage columns interface lower in the order. I think most users would expect visible columns to display right at the top since they appear to display first. It also makes it easier to reorder those columns among the other visible columns. Bill and I discussed the possibility to add a 'move visible columns' to the top so that the user could force them to sort to the top.

- When moving a column, the column header highlights in green so that the user can see which column they are working with. When the user closes the manage columns interface, the highlighting should be removed.

Thanks Bill!

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Bill Erickson (berick) wrote :

Thanks, Kathy! Fixes pushed to same branch with a new commit.

Changed in evergreen:
milestone: 3.0.2 → 3.0.3
Kathy Lussier (klussier) wrote :

My signoff is available at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1730752-eg-grid-columns-dialog-signoff

Although it's targeted to 3.0, it might also be considered a new feature, so I'm leaving it for the 3.0 release maintainer to make that determination.

tags: added: signedoff
Changed in evergreen:
milestone: 3.0.3 → 3.0.4
Bill Erickson (berick) wrote :

Going to do one more round of testing, then merge to master (for 3.1).

Changed in evergreen:
milestone: 3.0.4 → 3.1-beta
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Found a minor bug in the move-to-last-visible action that moved the column to one past the last index (when moving down). Fix pushed to new branch, including Kathy's sign offs.

One more sign-off needed.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1730752-eg-grid-columns-dialog-signoff-2

tags: removed: signedoff
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: New → Confirmed
Remington Steed (rjs7) wrote :

I have one tiny fix to Bill's last commit (< should be <= to prevent strange behavior if I am the last visible). I will push a branch tomorrow.

Bill Erickson (berick) wrote :

Ah, good catch, Remington. Thanks. I'll give it another whirl then merge.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Fix confirmed and signed off. Merged to master in prep for 3.1. Thanks, everyone.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers