Unable to delete copy notes / remove items from buckets, etc.

Bug #1724223 reported by Jason Boyer on 2017-10-17
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Eg 3.0

One of the upgrade scripts in bug 1708291 changed the type of fkey constraints on asset.copy to be trigger based to allow serial.unit items to be used in many of the same places. But a combination of issues (calling the trigger on DELETE and using NEW when TG_OP='DELETE') it's not possible to remove anything that has an fkey relationship protected with these triggers. (So you can't delete a copy note or copy tag, remove a copy from a bucket, and so on.) Since most of the tables affected allow real deletes there's little point in worrying about whether they point to a real copy before deleting them. Small fix incoming.

Jason Boyer (jboyer) wrote :

Sigh. Removing pullrequest for now, I edited the numbered upgrade script rather than putting together a new one. I'm about to disappear for the rest of the day but I hope to fix this as soon as I'm near a computer again.

tags: removed: pullrequest
Jason Boyer (jboyer) wrote :

The Pullrequest tag has returned, following a forced update to do things the right way.

tags: added: pullrequest
Galen Charlton (gmc) on 2017-11-09
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 3.0.2
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Pushed to master and rel_3_0. Thanks, Jason!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers