web client serials: cannot delete expected issues

Bug #1717593 reported by Andrea Neiman on 2017-09-15
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

3.0 beta

An attempt to delete an 'expected' issue from the Manage Issues tab fails silently, with the following in console:

grid.js:611 Error executing handler for "Delete items" => TypeError: Cannot read property 'delete' of undefined
TypeError: Cannot read property 'delete' of undefined
    at Object.$scope.delete_items [as handler] (view-items-grid.js:101)
    at b.$scope.actionLauncher (grid.js:609)
    at fn (eval at compile (angular.js:15126), <anonymous>:4:709)
    at b (angular.js:16213)
    at e (angular.js:26592)
    at b.$eval (angular.js:17994)
    at b.$apply (angular.js:18094)
    at HTMLAnchorElement.<anonymous> (angular.js:26597)
    at HTMLAnchorElement.dispatch (jquery.min.js:3)
    at HTMLAnchorElement.r.handle (jquery.min.js:3)

The ability to delete expected issues was previously working in web client serials.

Andrea Neiman (aneiman) on 2017-09-15
tags: added: webstaffclient
Andrea Neiman (aneiman) on 2017-10-06
Changed in evergreen:
milestone: none → 3.0.1
importance: Undecided → Medium
Changed in evergreen:
milestone: 3.0.1 → 3.0.2
Angela Kilsdonk (akilsdonk) wrote :

I am also unable to delete an Expected issue in the Manage Issues tab in 3.0.1-- it fails silently.

Changed in evergreen:
status: New → Confirmed
Changed in evergreen:
milestone: 3.0.2 → 3.0.3
Kathy Lussier (klussier) wrote :

I also see the same problem when attempting to delete received issues using the same workflow.

Changed in evergreen:
milestone: 3.0.3 → 3.0.4
Kathy Lussier (klussier) wrote :

I noticed that there isn't an option to delete issuances in the web client, as there was in the xul client, so I wanted to add a couple of other thoughts on this.

In the xul client, when the last item attached to an issuance was deleted, the issuance was also deleted. I don't know if the same behavior was seen in the web client when this action was working, but, if not, it's even more critical now to make sure it does so since there is now no other way for staff to delete an issuance.

Also, the benefit of being able to delete an issuance in the old client is that it also updated the summary statement in the catalog record. If you deleted an item, which then automatically deleted an issuance, the summary statement was NOT updated. See bug 1414197.

Now that there is no other way to delete the issuance, it becomes more important that bug 1414197 be fixed since there isn't a workaround to getting that statement updated.

Jason Stephenson (jstephenson) wrote :

I'm setting the importance to High because it has been identified to me as critical to fix this.

Changed in evergreen:
importance: Medium → High
Changed in evergreen:
milestone: 3.0.4 → 3.0.5
Mike Rylander (mrylander) wrote :

Arg ... I finally got to looking at this and it's just a case of missing I18N string definitions. Branch is here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/miker/lp-1717593-missing_item_change_strings

This does not attempt to address Kathy's concerns (I haven't looked into them, yet) but it will fix the OP's console error.

tags: added: pullrequest
Jason Stephenson (jstephenson) wrote :

We're testing this branch on our training server with 3.0.4 installed. We should have some feedback/sign off later this week.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
John Amundson (jamundson) wrote :

I have tested this code on the server set up by Jason Stephenson and consent to signing off on it -
John Amundson, <email address hidden>.

I want to note that this branch may have also fixed bug 1727815. That bug prevented the user from marking serial items as claimed, not published, etc. Prior to the upgrade to 3.0.4 and the installation of this branch, I was not able to update an item's status. I am now able to do so.

As per Kathy's question on deleting issuances. In my testing, when the last item attached to an issuance was deleted, the issuance was also deleted. However, deleting an item did not update the summary statement in the catalog. What is interesting to note, though, is that if another item attached to the subscription is received or reset, the summary method is updated to reflect all the changes. The same thing happens to any attached copy records; deleting the item does not delete the copy record, but the next time an item is received or reset, the copy record is deleted. I'll update the corresponding bugs with these observations, as well.

tags: added: signedoff
Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
Jason Stephenson (jstephenson) wrote :

Our testing at CW MARS shows this work and fixes another issue.

It does not address Kathy's concerns or bug 1414197, but those are best addressed on that bug.

Thanks, Andrea, Angela, Mike, Kathy, and John!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers