Web Client: Adding bill without billing type fails silently

Bug #1712646 reported by Terran McCanna on 2017-08-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned

Bug Description

In 2.12.4 web client:

Adding a manual bill to a patron's account allows me to submit without selecting a billing type, but fails with no error message.

Cesar V (cesardv) on 2017-09-05
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :

I was not able to reproduce the error as described, I tested on the latest master from the working repo.

In the webstaff client, when in a patron record's Bill section, manually adding a bill to a patron via Bill Patron button without selecting anything in the "BillingType" dropdown still created a bill for me and I noticed no errors. The billing defaulted to "misc."

Kathy Lussier (klussier) wrote :

Confirming that I see the same behavior described by Cesar on current master.

Kathy Lussier (klussier) wrote :

Having said that, it might not be a bad idea to force the user to select a billing type rather than falling back to misc.

Cesar V (cesardv) wrote :

I've pushed a branch that requires the user to select a billingType.

I think the reason it wasn't doing that before was because attempting validation there exposed an ugly angular wart/bug that affects value attribute conversions in ng generated <select> tag options. A work-around helper directive had to added to make it work. Kudos to gmcharlt for his help with figuring out that mess!
Now you'll see expected html5 form validation goodness.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1712646_make_patron_bill_modal_billingType_required

Cesar V (cesardv) on 2017-09-08
tags: added: pullrequest
Kathy Lussier (klussier) on 2017-09-12
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Andrea Neiman (aneiman) on 2017-09-15
Changed in evergreen:
assignee: nobody → Andrea Neiman (aneiman)
Andrea Neiman (aneiman) wrote :

Tested on MassLNC sandbox.

I have tested this code & consent to signing off on it with my name, Andrea Neiman, and my email address <email address hidden>

Changed in evergreen:
assignee: Andrea Neiman (aneiman) → nobody
tags: added: signedoff
Changed in evergreen:
milestone: none → 3.0-beta2
importance: Undecided → Low
Galen Charlton (gmc) on 2017-09-15
Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) wrote :

We discovered an issue with return parseInt(val, 10); in this patch while testing a patch for bug 1714390 on this Sandbox. See the IRC discussion at http://irc.evergreen-ils.org/evergreen/2017-09-15#i_324520

Changed in evergreen:
milestone: 3.0-beta2 → 3.0-rc
Bill Erickson (berick) on 2017-09-26
tags: added: needsrepatch
removed: signedoff
tags: removed: pullrequest
Galen Charlton (gmc) on 2017-09-27
Changed in evergreen:
milestone: 3.0-rc → 3.0.1
Changed in evergreen:
milestone: 3.0.1 → 3.0.2
Kathy Lussier (klussier) wrote :

More specifically from the aforementioned blog, JBoyer noted the the branch 'either needs to change the directive name, switch over to the parseFloat function, or move that directive into the app controller that it's used in' to prevent the conflict we found with bug 1714390.

Changed in evergreen:
milestone: 3.0.2 → 3.0.3
Terran McCanna (tmccanna) wrote :

Is someone currently working on completing this one?

Jason Boyer (jboyer) wrote :

Terran, I'm planning to look into it soon since there's another situation in the copy editor where a similar directive is needed I think the correct way to address this bug is to rework the patch from 1714390 and this bug into the one I'm planning to put together for bug 1713064.

Terran McCanna (tmccanna) wrote :

jboyer++

Jason Boyer (jboyer) wrote :

A patch is available here: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jboyer/lp1712646-require-btype

NOTE! It requires the patch to bug 1741072 to work.

With both patches applied staff won't be able to add a billing without choosing a specific billing type.

tags: added: pullrequest
removed: needsrepatch
Bill Erickson (berick) on 2018-01-05
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Issue and fix confirmed. It now defaults to Misc (consistent w/ XUL) and complains if I try to clear the billing type value. Merged to rel_3_0 and master. Thanks, All!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers