webclient: actions menu in checkin missing several options

Bug #1685929 reported by Andrea Neiman on 2017-04-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

The actions menu in Webby's checkin screen is missing several options from XUL, including:

Add Items to Bucket
Show Holds on Bib
Show Last Few Circulations
Edit __Item Attributes__ Volumes & Copies
Mark Item Missing Pieces
Print Spine Label

EG 2.12

Galen Charlton (gmc) on 2017-04-25
summary: - webclient: actions menu in checking missing several options
+ webclient: actions menu in checkin missing several options
Kathy Lussier (klussier) on 2017-05-09
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Cesar V (cesardv) on 2017-07-25
description: updated
description: updated
description: updated
Cesar V (cesardv) on 2017-07-26
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Cesar V (cesardv) wrote :

I've pushed a branch here: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1685929_checkin_actions_itemSvc

Note that Print Spine Labels code is commented out until bug 1704873 hits master, and we can utilize that new feature.

Also, still waiting on feedback on what the best practice is regarding when a user who checked-in an item (without the "Suppress Holds and Transits") and immediately after decides to do a "mark as missing pieces" on the copy (which now is status "In-Transit"). Currently, trying to mark as missing pieces to an item/copy that's in transit will silently fail.

Lastly, in order to efficiently add the needed grid action, the itemSvc in cat/item/app.js into it's own separate service "egItem" that lives in staff/circ/services/item.js. This effectively DRY'd up the "Scan as Missing Pieces" page/workflow code.

tags: added: pullrequest
Kathy Lussier (klussier) wrote :

Thanks Cesar! For the missing pieces issue, are you looking for feedback beyond what was provided in bug 1257910? Also, do you want to handle that item through this bug, or should we review/merge this code now and handle the missing pieces over on the other bug?

Cesar V (cesardv) wrote :

Hi Kathy,

Thanks. Yeah I was hoping for a bit more feedback, both from technical and the user/circulation side.
Tina's workflow diagram is pretty good but it does have some gotchas/assumptions that will need to be discussed a bit further.

This task, or my patch for it at least, is already a large enough change to require a fair bit of testing, as I had to do some refactoring to keep the code DRY and make a lot of the check-in grid actions work (via the extracted/shared angular item service).

So, yea, I think it's probably best for this task to get a review/merge as it stands, and not spill over the original intent/scope of it which was just to add some of the actions lacking in the Webstaff's CheckIn grid, with the hairiness of missing pieces. Let's deal with details of missing pieces on bug 1257910.

Mike Rylander (mrylander) wrote :

Just a head's up, the merge of the branch on bug 1695007 will cause a merge conflict here, due to the service moving. It should be a simple, mechanical resolution, though.

Cesar V (cesardv) wrote :

Mike, I've rebased my branch with the lastest master, and the last commit is the one that re-extracts itemSvc to it's own js file... with the relevant changes affected from bug 1695007 should be in there.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1685929_REBASED_checkin_actions_itemSvc_Refactr

Cesar V (cesardv) on 2017-08-10
Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Cesar V (cesardv) wrote :

I've rebuilt the branch for this once again... sorry... but it makes the rebasing of 1695007's changes a bit less confusing...

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1685929_Rebuilt_checkin_actions_itemSvc_Refactr

Andrea Neiman (aneiman) on 2017-08-16
Changed in evergreen:
milestone: none → 3.0-alpha
Changed in evergreen:
assignee: nobody → Skye Howard (showard1110)
Changed in evergreen:
assignee: Skye Howard (showard1110) → nobody
Kathy Lussier (klussier) on 2017-08-23
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

It looks like this branch needs to be rebased against current master again.

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Galen Charlton (gmc) on 2017-08-25
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

Because of the refactoring and the multiple rebases that Cesar's been put through, I'm taking RM privilege to bend the process a bit. I've rebased it for one last time, tested it, written some follow-ups, and pushed to master. Thanks, Cesar!

I've removed the 2.12 target given the refactoring, and will help out to sort any any branches that just got affected by the refactoring of portions of cat/item/app.js to circ/services/item.js.

no longer affects: evergreen/2.12
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers