Docs: Updates needed to languages info

Bug #1643998 reported by Terran McCanna
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Low
Unassigned

Bug Description

The "Setting a default language and adding optional languages" page refers to the /etc/apache2/sites-available/eg.conf file, but it should now refer to the /etc/apache2/sites-available/eg_vhost.conf file.

Also, the Spanish language option is now available (as of 2.11.1):

    PerlAddVar OILSWebLocale "es_es"
    PerlAddVar OILSWebLocale "/openils/var/data/locale/opac/es-ES.po"

Changed in evergreen:
assignee: nobody → Jeanette Lundgren (jlundgren)
Revision history for this message
Jeanette Lundgren (jlundgren) wrote :

when I view the files listed under /openils/var/data/locale I find the following missing from the documentation:

ar-AR.po
de-DE.po
es-ES.po (mentioned above)
fi-FI.po
he-IL.po
hu-HU.po
hy-AM.po
oc-FR.po
sv-SE.po
tr-TR.po

Do you want me to add all of these or just Spanish?
Is there a place I can look up the language names and codes that go with these files?

Thanks!

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Ben Shum (bshum) wrote :

I think Terran might have meant /etc/apache2/eg_vhost.conf (not in sites-available subdir) in the original description. But otherwise, that seems logical. I'm not sure if we want to keep adding additional languages into the examples already setup there, but I'll leave that for others to comment on.

For Jeanette's question, there was an email thread awhile back where we discussed Evergreen translation by the numbers and came up with some rough estimation of what the community at large would consider "supported". This is a link to that discussion thread: http://markmail.org/message/sthmnbvfpt47pe7n

As a baseline (cause using a translation requires more work if you have catalog customizations, etc. that require additional translation work beyond what is initially provided), I think we can reasonably say some, but not all contain enough translation strings to give you enough to start with. From the email thread, the following languages were listed out (and still appear relevant to me):

cs-CZ -- Czech
hy-AM -- Armenian
fi-FI -- Finnish
en-CA -- English (Canada)
en-GB -- English (UK)
pt-BR -- Brazilian Portuguese
fr-CA -- French
es-ES -- Spanish

Also, I know there's movement on Arabic translation (ar-AR currently, though there is bug 697926 to someday soon change that to ar-JO since the localization effort is being done in Jordan, not Argentina). So I would consider adding Arabic in a future release once support for RTL (right to left) languages is worked out and added to core code.

tags: added: i18n
Changed in evergreen:
importance: Undecided → Low
Revision history for this message
Kathy Lussier (klussier) wrote :

Since the documentation in the referenced page says it is a table of currently-supported languages, I'm +1 to adding the supported languages cited by Ben, holding off on Arabic until will get the l-to-r styles in the core code.

I think potential adopters and current Evergreen cites are likely to ask the question of what languages are available, and it's nice to have them listed in an easily-accessible place.

Revision history for this message
Jeanette Lundgren (jlundgren) wrote :

Thanks Ben and Kathy!

Updated file here - http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jlundgren/lp1643998_docs_update_languages_info

Here is what I updated:

changed etc/apache2/sites-available/eg.conf to etc/apache2/eg_vhost.conf

fixed typo in file name pt_BR.po to pt-BR.po

made languages match list above (alpha order):
removed - Russian
added - Armenian, Finnish, Spanish

Changed in evergreen:
assignee: Jeanette Lundgren (jlundgren) → nobody
tags: added: pullrequest signedoff
Kathy Lussier (klussier)
tags: removed: signedoff
Revision history for this message
Kathy Lussier (klussier) wrote :

Adding a note that in speaking with Eva Cerninakova, who has volunteered to serve as the translations coordinator, she identified the following languages as ones that are supported in 2.12:

Arabic (ar)
Armenian (hy)
Czech (cs)
English (Canada) (en_CA)
English (United Kingdom) (en_GB)
French (fr)
Brazilian Portuguese (pt_BR)
Spanish (es)

This adds Arabic to Ben's list (Arabic is new to 2.12) and removes Finnish. The reason behind removing Finnish is that, although there are many translated strings for Finnish, it is no longer actively maintained.

Galen Charlton (gmc)
Changed in evergreen:
milestone: none → 2.12.1
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master and rel_2_12, along with a follow-up implementing the changes per comment #5. Thanks, Jeanette!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers