Web Staff Client - Group Members Don't Display

Bug #1642036 reported by Terran McCanna on 2016-11-15
124
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Medium
Unassigned
3.1
Medium
Unassigned
3.2
Medium
Unassigned

Bug Description

In the 2.11 web client:

When I'm viewing a patron account that is in a group and click on Other > Group Member Details, the members do not display.

(I confirmed that they do display in the 2.11 web client, so they are grouping properly both when Cloned and when added to the group manually.)

Andrea Neiman (aneiman) wrote :

2.12 web client

Noting that Group Members will display correctly after a manual refresh or an action (like adding a group member) that causes a refresh.

Changed in evergreen:
status: New → Confirmed
Terran McCanna (tmccanna) wrote :

Manual refresh does work. Adding a group member to trigger a refresh doesn't work because the action menu is greyed out when there is no list.

Related issue: Actions button is greyed out unless at least one person on the group list is checked. That is non-intuitive for the "Move another patron to this group" option.

Kathy Lussier (klussier) wrote :

For the last related issue, take a look at bug 1670457.

Blake GH (bmagic) wrote :

This bug seems like it could be pretty easy to fix. Especially with the added clue that the grid DOES show the member details when the web page is refreshed from the group member details screen. Looking at the browser development tools console I see that it's complaining about:

grid.setQuery is not a function

This code is executed in ui/default/staff/circ/patron/app.js in the section about $scope.initTab('other'

here it's calling grid.setQuery which apparently is not instantiated if the page was loaded on a different section of the patron account before toggled to "Group Member Details". Thoughts on this?

Galen Charlton (gmc) on 2017-10-02
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

I tested the patch, and I was still sometimes able to make the race condition between the completion of initialization of the group tab's egGrid (by which point grid.setQuery is guaranteed to exist) and the post-initTab handler occur. What did work was wrapping that call to grid.setQuery() in a $timeout.

So, we're close, but not for 3.0.0. Setting milestone to 3.0.1.

Changed in evergreen:
milestone: 3.next → 3.0.1
importance: Undecided → Medium
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
milestone: 3.0.1 → 3.0.2
Kyle Huckins (khuckins) wrote :

Hey Galen, I was wondering what steps you were able to take to make that race condition occur? I'm looking at tacking this unless Blake's got any objections, but having trouble replicating it with Blake's patch.

Changed in evergreen:
milestone: 3.0.2 → 3.0.3
Blake GH (bmagic) wrote :

Kyle,

The $timeout approach is going to be the full-proof approach. I didn't think of that when I was working on this one. My patch just delays the execution arbitrarily via "more code".

Changed in evergreen:
milestone: 3.0.3 → 3.0.4
Changed in evergreen:
milestone: 3.0.4 → 3.0.5
Changed in evergreen:
milestone: 3.0.5 → 3.0.6
Changed in evergreen:
milestone: 3.0.6 → 3.0.7
Changed in evergreen:
milestone: 3.0.7 → 3.0.8
Jennifer Pringle (jpringle-u) wrote :

Confirming that this is still an issue in 3.1

Changed in evergreen:
milestone: 3.0.8 → 3.2-beta
Changed in evergreen:
milestone: 3.2-beta → 3.1.3
no longer affects: evergreen/3.1
Changed in evergreen:
milestone: 3.1.3 → 3.1.4
Changed in evergreen:
milestone: 3.1.4 → 3.1.5
Cesar V (cesardv) wrote :

3.1 is still suffering from this apparently...

Here's a branch that includes the above mentioned $timeout fix:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/lp1642036-Patron_Group_Grid_bug

tags: added: pullrequest
Changed in evergreen:
milestone: 3.1.5 → 3.1.6
Dawn Dale (ddale) wrote :

I am testing this bug patch.

Changed in evergreen:
assignee: nobody → Dawn Dale (ddale)
Dawn Dale (ddale) wrote :

I tested this and I still have to refresh the screen to see group member details.

Dawn Dale (ddale) on 2018-09-13
Changed in evergreen:
assignee: Dawn Dale (ddale) → nobody
Dawn Dale (ddale) on 2018-09-13
Changed in evergreen:
assignee: nobody → Dawn Dale (ddale)
Terran McCanna (tmccanna) wrote :

Actually, we may have been seeing a problem with our test server when we tested this, we will try again.

Dawn Dale (ddale) wrote :

I tested this one and the screen still has to be refreshed to see the group details. Also "Actions" is still grayed out unless at least one person is checked.

Changed in evergreen:
assignee: Dawn Dale (ddale) → nobody
Scott Thomas (scott-thomas-9) wrote :

This is a major nuisance for us since upgrading to 3.1.

Scott

Changed in evergreen:
milestone: 3.1.6 → 3.2.1
Meg Stroup (mstroup) wrote :

Still occurring in 3.1.5.

Still occurring 3.1.6

Changed in evergreen:
milestone: 3.2.1 → 3.2.2
Changed in evergreen:
milestone: 3.2.2 → 3.2.3
Changed in evergreen:
status: Confirmed → New
milestone: 3.2.3 → 3.3-beta1
Terran McCanna (tmccanna) wrote :

This has been an even bigger problem since our move to 3.2.2.

Chris Sharp (chrissharp123) wrote :

Current status of our testing this: We are not seeing any change after applying Cesar's branch alone. We are seeing Blake's branch work consistently. Was Cesar's branch meant to fix the issue Galen mentions in Comment #6? We have not tested them together.

tags: removed: pullrequest
Meg Stroup (mstroup) wrote :

Remains an issue of great concern/significant workflow hinderance to SCLENDS circulation workgroup, per last workgroup meeting. We're 3.1.8/Chrome.

Terran McCanna (tmccanna) wrote :

Update at PINES: We have Blake's and Cesar's fixes on our production server, and it helps some people, but a lot of people are still needing to refresh their browser window every time.

Changed in evergreen:
milestone: 3.3-beta1 → 3.3-rc
Changed in evergreen:
milestone: 3.3-rc → 3.3.1
Bill Erickson (berick) wrote :

Here's another patch:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1642036-grp-member-details

This one addresses how we apply the grid.setQuery function specifically to resolve the "grid.setQuery is not a function" error. I am now able to load details, but I have not confirmed (w/ limited test data) that it always loads all members every time.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) on 2019-04-24
tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: New → Confirmed
Terran McCanna (tmccanna) wrote :

Wishing I could add a gif to this so I could show Kermit the Frog waving his hands in the air with delight. Thanks Bill and Blake!

John Amundson (jamundson) wrote :

Jason Stephenson loaded this patch on a system to test, and the group members are indeed loading initially now. However, if I reload the page, the group members fail to display. Does anyone else see this, too?

I'm also seeing inconsistent behavior with certain actions. For example, I selected the action to add my user to another group. The list reloaded but was blank. I had to click another tab in the patron's account and come back to the group member details to see the member appear.

Jason Stephenson (jstephenson) wrote :

I have added my signoff in a branch here: user/dyrcona/LP1642036_Repair_group_member_details_display_error-signoff

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/LP1642036_Repair_group_member_details_display_error-signoff

I'm waiting on some feedback from staff at CW MARS, but will push the fix this evening because it is working for me in my testing, too.

Thanks, Bill and Blake!

tags: added: signedoff
Bill Erickson (berick) wrote :

Here's another one.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1642036-grp-member-details-v2

It improves and ultimately replaces my previous commit. Now members display during reloads and tab navigation.

John Amundson (jamundson) wrote :

Thanks, Bill. This new patch is working for me.

I have tested this code and consent to signing off on it with my name, John Amundson and my email address, <email address hidden>.

Jason Stephenson (jstephenson) wrote :

Works for me, too!

Pushed to master, rel_3_1, rel_3_2, and rel_3_3.

You still have to reload after changing group membership, but that's a different bug in my opinion.

Thanks to everyone who commented, shared code, and tested!

Changed in evergreen:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers