Hold placed on grouped metabib result displays wrong title

Bug #1454884 reported by Terran McCanna on 2015-05-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.8
Medium
Unassigned
2.9
Medium
Unassigned

Bug Description

If we group search results by format/edition in the OPAC, then click to view the holdings of that group of records, then click to place a hold on a specific format, it will sometimes show the title for a different format.

In the attached screenshot, there was a group of titles that included "Gone with the wind" (which was for a book) and "Gone with the wind [videorecording]". I clicked to place a hold on the book record, but it shows the title for the DVD record. It still appears to place the hold correctly, just shows the incorrect format sometimes (not all of the time).

Evergreen 2.7

Terran McCanna (tmccanna) wrote :
Kathy Lussier (klussier) on 2015-05-28
tags: added: metarecords
Blake GH (bmagic) wrote :

This is a tough problem to fix. The issue is that there needs to be a bib that represents the group. The group of bibs is decided by your settings in Evergreen. If you decide to group all the formats into "same title and author" - and the system chooses a "leader" as the displayed record for the group. That leader might be the video version. Either the cataloging needs to change, or the system needs to (at the very least) only display the title that they have in common, stripping any extra stuff that the leading bib might have.
Just some thoughts.

Terran McCanna (tmccanna) wrote :

My inclination is to replace "attrs.title_extended" in the /var/templates/opac/parts/place_hold.tt2 file with "attrs.title" - see before & after attachment.

Thoughts?

Kathy Lussier (klussier) wrote :

I like the idea of using an IF statement to use attrs.title when the hold type is M, but continuing to use attrs.title_extended for other hold types.

I generally like seeing the extended title info for title-level holds, but, yes, it is confusing when it's used for metarecord holds.

Terran McCanna (tmccanna) wrote :

I like the IF idea, too.

Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Terran McCanna (tmccanna) wrote :

I've submitted a change that uses the IF behavior suggested by Kathy:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=8e0b745c1f03320a8e7b6dc361831d10cdc9a5fb

Example in the Concerto data set of a short title versus its extended title:
- Récits laurentiens
- Récits laurentiens / Fr. Marie-Victorin, des E. C. ; préface d'Albert Ferland

To test, check whether a short title or an extended title displays on the holds screen for each of the following situations:
- Click place hold from search results screen (or from item details screen) for a standard single-title hold (place hold screen shows extended title)
- From ^ screen, click Advanced Hold Options (place hold screen shows short title)
- On Search Results screen, click Group Formats and Editions (or, do an advanced search with group formats and editions checked), then click place hold (place hold screen shows short title)

Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
tags: added: holds pullrequest
Kathy Lussier (klussier) on 2016-03-03
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) on 2016-03-04
Changed in evergreen:
status: New → Confirmed
milestone: none → 2.10-rc
Kathy Lussier (klussier) wrote :

Thank you Terran! It works for me. I had a couple of thoughts when testing it.

1. In some cases, I almost wanted to get rid of the subfield b in the display as well as it could sometimes be misleading. However, I think if we were to do so, we should see the same display in the initial metarecord search results display so that the two are consistent. Also, in many cases, it was misleading because the metarecord grouping is a bit imperfect, which should be the topic of another bug.

2. I haven't seen this happen in the wild yet, but I imagine there may be times where the foreign language version of a title is the master record and ultimately displays here. I think that's a more difficult issue to address.

Overall, though, your patch addresses the majority of use cases and provides more accuracy on the screen. Merged to master and backported to 2.10, 2.9 and 2.8.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Kathy Lussier (klussier) → nobody
Terran McCanna (tmccanna) wrote :

Thanks, Kathy! Those are excellent points. I agree this may not necessarily resolve all corner cases, but at least it should immediately resolve the confusion with metarecord groups that have books + dvds + audiobooks with the same short title.

Galen Charlton (gmc) on 2016-03-14
Changed in evergreen:
importance: Undecided → Medium
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers