Fast Item Add does not work with Z39.50 imports when unified vol/item creator is enabled

Bug #1093856 reported by Erica Rohlfs on 2012-12-26
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.3
Medium
Unassigned
2.4
Medium
Unassigned

Bug Description

Evergreen version 2.3.0 and 2.3.2

After importing a record via Z39.50 and selecting Fast Item Add, the Volume and Copy Creator window does not open. A tab with the new bib record opens, recognizing the volume information but not item information. This is only happening with fast item add from a Z39. 50 record import; the volume and copy creator bypass does not occur with a fast item add via Create New MARC Record. Also, the Library Setting, GUI: Unified Volume / Item Creator / Editor value is set to True.

When setting the value to False, the Volume and Copy Creator window will open as expected for the fast item add from a Z39. 50 record import, and the item information will be added.
I can provide detailed steps if needed.
 Thank you very much for your time.

Ben Shum (bshum) wrote :

Confirmed for me. It looks like it adds the new volume to the imported bib, but the combined item editor doesn't spawn and thus no copy gets created.

Changed in evergreen:
milestone: none → 2.4.0-alpha
status: New → Confirmed
importance: Undecided → Medium
Ben Shum (bshum) on 2013-03-03
Changed in evergreen:
milestone: 2.4.0-alpha1 → 2.4.0-beta
Ben Shum (bshum) on 2013-03-17
Changed in evergreen:
milestone: 2.4.0-beta → 2.4.0-rc
Ben Shum (bshum) on 2013-04-27
Changed in evergreen:
milestone: 2.4.0-rc → none
Changed in evergreen:
assignee: nobody → Jason Etheridge (phasefx)
Jason Etheridge (phasefx) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Jason Etheridge (phasefx) → nobody
Mike Rylander (mrylander) wrote :

Picked for master and 2.4, thanks!

Changed in evergreen:
status: Confirmed → Fix Committed

Presumably fixed long ago in a release without a specific milestone target.

Changed in evergreen:
status: Fix Committed → Fix Released
tji@sitka.bclibraries.ca (tji) wrote :

We just upgraded to 2.8. I believe this fix should be included in it. But we see the issue again. With the unified copy volume editor, the record is imported, volume record is created. But the copy editor does not show up and the copy record is not created.

Tina Ji
BC Libraries Co-op

Kathy Lussier (klussier) wrote :

Tina,

Can you verify that autogen was run after your upgrade? I recall that there were some issues that occurred with Fast Item add around the 2.7 release if autogen had not been run.

Kathy

Dale Rigney (drigney) wrote :

I can confirm that this bug has resurfaced in 2.8.5. I tested after autogen was ran. This only happens on z39.50 import fast add when the the Library Setting, GUI: Unified Volume / Item Creator / Editor value is set to True. When the library setting is set to false the screen pops up as normal.

Erica Rohlfs (erohlfs) wrote :

I can also confirm the same behavior in version 2.9.

Changed in evergreen:
status: Fix Released → Confirmed
Kathy Lussier (klussier) wrote :

Thanks Dale and Erica!

Since there was a fix included on this report that is in general release, rather than re-opening this bug, I would suggest filing a new one and perhaps pointing a link back to this one. I'm going to set this one back to Fix Released.

I'll take a look at one of my test servers to see if I can replicate the issue.

Kathy

Changed in evergreen:
status: Confirmed → Fix Released

I have created a new bug report for this issue - https://bugs.launchpad.net/evergreen/+bug/1559273

Issue still exists on EG beta 2.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers