/services/Heartbeat fails on exception

Bug #443325 reported by chris grzegorczyk on 2009-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
chris grzegorczyk
eucalyptus (Ubuntu)
High
Dustin Kirkland 
Karmic
High
Dustin Kirkland 

Bug Description

The logs show:
17:17:11 [FilteredPipeline:New I/O server worker #1-24] ERROR Error unrolling pipeline: heartbeat
17:17:11 [FilteredPipeline:New I/O server worker #1-24] ERROR Forced pipeline to close due to except
ion:
java.lang.IllegalArgumentException: Duplicate handler name.

This is because the timeout handlers are being added twice.

chris grzegorczyk (chris-grze) wrote :

Fix ready pending merge.

Changed in eucalyptus:
status: New → In Progress
assignee: nobody → chris grzegorczyk (chris-grze)
chris grzegorczyk (chris-grze) wrote :

------------------------------------------------------------
revno: 913
committer: decker <decker@personal-army>
branch nick: 1.6
timestamp: Mon 2009-10-05 13:07:29 -0700
message:
  - fix system address selection (lp:#443314)
  - fix regression in heartbeat (lp:#443325)
  - fix NPE in system mode (lp:#443325)
    ------------------------------------------------------------

Changed in eucalyptus:
status: In Progress → Fix Committed
Thierry Carrez (ttx) wrote :

We used Heartbeat to determine if sc and walrus were ready to be registered.
Without the fix, registration happens too late (after timeout) thanks to another bug, bug 444504.

Changed in eucalyptus (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Thierry Carrez (ttx) on 2009-10-06
Changed in eucalyptus (Ubuntu Karmic):
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

I'm looking at the diff for revision 913, and it's huge.

There's quite a bit of whitespace and non-functional changes in there.

This makes it extremely difficult for me to review and cherrypick without risking serious regressions.

Chris, in the future, could you try to fix one bug per commit, and separate non-functional or whitespace-only changes to a separate commit? That would really help your downstreams in processing your commits.

Thanks a lot.

:-Dustin

Dustin Kirkland  (kirkland) wrote :

I'm going to hold off on merging this massive commit into karmic right now, as we really must avoid regressions at all costs. I'll go over this commit with Dan tomorrow.

:-Dustin

Hi Dustin,

The merge to the 1.6 branch consisted of several separate commits to
my private dev branch. The individual commits should be available in
the commit log if you are so inclined.

thanks.
chris

On 10/6/09, Dustin Kirkland <email address hidden> wrote:
> I'm looking at the diff for revision 913, and it's huge.
>
> There's quite a bit of whitespace and non-functional changes in there.
>
> This makes it extremely difficult for me to review and cherrypick
> without risking serious regressions.
>
> Chris, in the future, could you try to fix one bug per commit, and
> separate non-functional or whitespace-only changes to a separate commit?
> That would really help your downstreams in processing your commits.
>
> Thanks a lot.
>
>
> :-Dustin
>
>
> --
> /services/Heartbeat fails on exception
> https://bugs.launchpad.net/bugs/443325
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>
> Status in Eucalyptus: Fix Committed
> Status in “eucalyptus” package in Ubuntu: Triaged
> Status in eucalyptus in Ubuntu Karmic: Triaged
>
>
> Bug description:
> The logs show:
> 17:17:11 [FilteredPipeline:New I/O server worker #1-24] ERROR Error unrolling pipeline: heartbeat
> 17:17:11 [FilteredPipeline:New I/O server worker #1-24] ERROR Forced pipeline to close due to except
> ion:
> java.lang.IllegalArgumentException: Duplicate handler name.
>
>
> This is because the timeout handlers are being added twice.
>

--
Chris Grzegorczyk
Co-Founder and Engineer
Eucalyptus Systems, Inc.

130 Castilian St. | Goleta, CA | 93117
Office: 805-968-1400 x e^1 | Cell: 805-807-8237
Email: <email address hidden>
www.eucalyptus.com
________________________________________

Dustin Kirkland  (kirkland) wrote :

Aha! So it is...

bzr log --include-merges | less

Okay, thanks a lot Chris. I'll parse this. Thanks!

:-Dustin

Thierry Carrez (ttx) on 2009-10-07
Changed in eucalyptus (Ubuntu Karmic):
assignee: Dustin Kirkland (kirkland) → Thierry Carrez (ttx)
importance: Medium → High
milestone: none → ubuntu-9.10
status: Triaged → In Progress
Thierry Carrez (ttx) on 2009-10-07
Changed in eucalyptus (Ubuntu Karmic):
status: In Progress → Fix Committed
Changed in eucalyptus (Ubuntu Karmic):
assignee: Thierry Carrez (ttx) → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr916-0ubuntu1

---------------
eucalyptus (1.6~bzr916-0ubuntu1) karmic; urgency=low

  * Merge upstream revision 916
  * This snapshot is expected to fix the following bugs:
    - LP: #443314 - fix system address selection
    - LP: #443325 - fix regression in heartbeat, fix NPE in system mode
    - LP: #444838 - fix meta-data service in multi-cluster
    - LP: #444908 - fix running instances on multi-cluster
    - LP: #445206 - fix remote bootstrap on walrus+sc
  * debian/eucalyptus-cc.eucalyptus-cc-publication.upstart,
    debian/local/euca_find_cluster.c: when doing the avahi-publish, use
    $CC_IP_ADDR rather than $(hostname) for the "name" of the service;
    use this ip address in the case where euca_find_cluster gets the
    link-local 169.254.169.254 address, LP: #445738

 -- Dustin Kirkland <email address hidden> Wed, 07 Oct 2009 20:01:56 -0500

Changed in eucalyptus (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers