Update be2net driver in 12.10 (Quantal)

Bug #1083088 reported by Sarveshwar Bandi on 2012-11-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
The Emulex project
High
Jesse Sung
linux (Ubuntu)
High
Jesse Sung
Precise
High
Jesse Sung
Quantal
High
Jesse Sung
Raring
High
Jesse Sung

Bug Description

I am attaching a list of 29 net-next patches that need to be applied to the tree. I am attaching two files: be2net_update_upstream_patch_list (contains list of upstream patches with upstream commit id)
be2net_update_quantal_patches.tgz (contains the git formatted patches after applying to quantal tree).

All the patches are bug fixes. 4 of them listed below have already been applied to 12.04 (precise) tree.

- Fix to parse RSS hash from Receive completions correctly (Commit c297977ec18deb36b2c0a5ee57101f7ab736ec00)
- dont pull too much data in skb linear part (commit ac1ae5f33fd225f46da0072e2091962410a0431b)
- Fix Endian (Commit e8efcec5394cbf7ae67ccb137cb1a45ae3e6f6c8)
- Fix to trim skb for padded vlan packets to workaround an ASIC Bug ( Bug 93040ae5cc8dcc893eca4a4366dc8415af278edf)

Thanks,
Sarvesh

details of upstream (net-next) patches to be applied

Patches applied to quantal

information type: Proprietary → Public

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1083088

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux:
status: New → Incomplete
tags: added: quantal
Chris Van Hoof (vanhoof) on 2012-12-07
Changed in emulex:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Jesse Sung (wenchien)
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Changed in linux (Ubuntu Quantal):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
importance: Undecided → High
Changed in linux (Ubuntu Quantal):
importance: Undecided → High
Changed in linux (Ubuntu):
assignee: nobody → Jesse Sung (wenchien)
Jesse Sung (wenchien) on 2012-12-11
Changed in emulex:
status: Confirmed → In Progress
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Changed in linux (Ubuntu Precise):
status: Confirmed → In Progress
Changed in linux (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in linux (Ubuntu Precise):
assignee: nobody → Jesse Sung (wenchien)
Changed in linux (Ubuntu Quantal):
assignee: nobody → Jesse Sung (wenchien)
Jesse Sung (wenchien) wrote :

Hi Sarveshwar,

Is commit 30e80b55 in upstream also needed for quantal merge?

commit 30e80b55dd250b17c2570e234d2be34a0718063e
Author: Yuval Mintz <email address hidden>
Date: Sun Jul 1 03:19:00 2012 +0000

    be2net: set maximal number of default RSS queues

That commit is dependent on following commit which doesnt seem to be in quantal yet.

commit 16917b87a23b429226527f393270047069d665e9
Author: Yuval Mintz <email address hidden>
Date: Sun Jul 1 03:18:50 2012 +0000

    net-next: Add netif_get_num_default_rss_queues

    Most multi-queue networking driver consider the number of online cpus when
    configuring RSS queues.
    This patch adds a wrapper to the number of cpus, setting an upper limit on the
    number of cpus a driver should consider (by default) when allocating resources
    for his queues.

    Signed-off-by: Yuval Mintz <email address hidden>
    Signed-off-by: Eilon Greenstein <email address hidden>
    Signed-off-by: David S. Miller <email address hidden>

Jesse Sung (wenchien) wrote :

Hi Sarveshwar,

Humm... So 30e80b55 is not a "must have" fix right? I'll skip it then.

No its not a "must have".

Thanks,
Sarvesh

Ubuntu kernel team is requesting some indication of the testing that has been done. Sarvesh, could you please provide some test results?

Thanks.

The following test cases were executed and passed with the latest driver:
1) Driver parameters(rx_frag_size, multi_rxq)
2) Driver load/reload multiple times and ping with different payloads
3) Ifdown/ifup and TCP, UDP traffic (iperf, netperf)
4) Ethtool options
5) IPv6
6) VLAN
7) Multicast
8) Promiscous
9) Bonding
10) Bridge
11) Bonding+Bridge+VLAN
12) Firmware flash using ethtool or sysfs
13) Latency using Netpipe

Thanks,
Sarvesh

In addition to the above test cases, SRIOV and UMC features were also tested.

Thanks,
Sarvesh

Tim Gardner (timg-tpi) on 2013-01-07
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-24.37). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (28.9 KiB)

This bug was fixed in the package linux - 3.5.0-24.37

---------------
linux (3.5.0-24.37) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1117492

  [ Tim Gardner ]

  * [Config] CONFIG_ALX=m for x86 only
    - LP: #927782

linux (3.5.0-24.36) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1116501

  [ Adam Lee ]

  * [Config] Enable RTSX_PCI modules
    - LP: #1057089

  [ Andy Whitcroft ]

  * [Config] enable various HVC consoles
    - LP: #1102206

  [ Brad Figg ]

  * Revert "SAUCE: samsung-laptop: disable in UEFI mode"
    - LP: #1111689

  [ Herton Ronaldo Krzesinski ]

  * [Config] updateconfigs for 3.5.7.3 stable update
  * d-i: Add mellanox ethernet drivers to nic-modules
    - LP: #1015339

  [ Kamal Mostafa ]

  * SAUCE: alx driver import script
    - LP: #927782

  [ Qualcomm Atheros, Inc ]

  * SAUCE: alx: Update to heads/master
    - LP: #927782

  [ Seth Forshee ]

  * SAUCE: samsung-laptop: Add quirk for broken acpi_video backlight on
    N250P
    - LP: #1086921

  [ Stefan Bader ]

  * (config) Move 9p modules into generic package
    - LP: #1107658

  [ Tim Gardner ]

  * [debian] Remove dangling symlink from headers package
    - LP: #1112442
  * [config] CONFIG_ALX=m
    - LP: #927782
  * [Config] Add alx to d-i nic-modules
    - LP: #927782

  [ Upstream Kernel Changes ]

  * Revert "8139cp: revert "set ring address before enabling receiver""
    - LP: #1102417
  * Revert "ath9k_hw: Update AR9003 high_power tx gain table"
    - LP: #1102417
  * Revert "drm/i915: no lvds quirk for Zotac ZDBOX SD ID12/ID13"
    - LP: #1102417
  * Revert "ALSA: hda - Shut up pins at power-saving mode with Conexnat
    codecs"
    - LP: #1106966, #886975
  * be2net: don't call vid_config() when there's no vlan config
    - LP: #1083088
  * be2net: cleanup be_vid_config()
    - LP: #1083088
  * be2net: do not modify PCI MaxReadReq size
    - LP: #1083088
  * be2net: fix reporting number of actual rx queues
    - LP: #1083088
  * be2net: do not use SCRATCHPAD register
    - LP: #1083088
  * be2net: Fix driver load for VFs for Lancer
    - LP: #1083088
  * be2net: Explicitly clear the reserved field in the Tx Descriptor
    - LP: #1083088
  * be2net: Regression bug wherein VFs creation broken for multiple cards.
    - LP: #1083088
  * be2net: Fix to trim skb for padded vlan packets to workaround an ASIC
    Bug
    - LP: #1083088
  * be2net: Fix Endian
    - LP: #1083088
  * be2net: Fix error while toggling autoneg of pause parameters
    - LP: #1083088
  * be2net : Fix die temperature stat for Lancer
    - LP: #1083088
  * be2net: Fix initialization sequence for Lancer
    - LP: #1083088
  * be2net: Activate new FW after FW download for Lancer
    - LP: #1083088
  * be2net: Fix cleanup path when EQ creation fails
    - LP: #1083088
  * be2net: Enable RSS UDP hashing for Lancer and Skyhawk
    - LP: #1083088
  * be2net: dont pull too much data in skb linear part
    - LP: #1083088
  * be2net: Fix VF driver load for Lancer
    - LP: #1083088
  * be2net: Ignore physical link async event for Lancer
    - LP: #1083088
  * be2net: Fix to parse RSS hash from Receive compl...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released

These patches are available for precise via linux-lts-quantal (12.04.2). I will mark the precise task won't fix. Please change the status to Confirmed if there is a need to have these patches in 12.04 3.2 kernel.

Changed in linux (Ubuntu Precise):
status: In Progress → Confirmed
status: Confirmed → In Progress
Jesse Sung (wenchien) on 2013-04-15
Changed in linux (Ubuntu Precise):
status: In Progress → Won't Fix
Changed in emulex:
status: In Progress → Fix Released
Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers