Chat app, and Telepathy user interface

Support contact grouping (metacontacts)

Reported by Timo Jyrinki on 2008-08-09
696
This bug affects 148 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
Nominated for Trunk by Christopher Martin
People
Undecided
Unassigned
empathy (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: empathy

Empathy does not support grouping contacts, ie. specifying a friend which exists in several IM networks. This results in same friend being showed over and over again in the list(s).

The problem is being solved using libfolks (http://telepathy.freedesktop.org/wiki/Folks) which can aggregate contacts from multiple sources like People (https://launchpad.net/people-project) and/or Soylent (http://live.gnome.org/Soylent)

 - According to the Roadmap (http://live.gnome.org/Empathy/Roadmap).

Changed in empathy:
status: Unknown → Confirmed
C de-Avillez (hggdh2) wrote :

marking as wishlist. This bug just documents the corresponding upstream bug.

Changed in empathy:
importance: Undecided → Wishlist
status: New → Triaged
Serge Matveenko (lig) wrote :

this is the main blocking issue to use empathy instead of pidgin and think for a several folks too

summary: - Multi-protocol contacts not supported
+ Support contact grouping (metacontacts)
Kẏra (kxra) wrote :

The roadmap (http://live.gnome.org/Empathy/Roadmap) says that People (https://edge.launchpad.net/people-project) or Soylent (http://live.gnome.org/Soylent) will be used. Can we discuss the differences and start working on that?

description: updated
jeremy-list (quick-dudley) wrote :

This is the only reason I'm still using pidgin at all. I'm happy to do some work to implement this. I'd prefer to do so using the people-project unless someone really wants me to use soylent.

Kẏra (kxra) wrote :

What are the differenced between the two projects? You should probably post to upstream Empathy if you want to help out. Thanks for picking up on this-- tons of us users are dying for it =)

Kẏra (kxra) on 2009-12-06
description: updated
description: updated
Kai Mast (kai-mast) wrote :

Is there any progress update? I think this bug really needs to be fixed to make empathy a state of the art messenger.

Just imagine. I sometimes have 4 buddies that are the same person. That means my contact list at the moment ist completely clustered with the same names over and over...

Phil Moorhouse (phil-moorhouse) wrote :

The empathy roadmap lists this feature as planned for Gnome 3.0... there really should be a stopgap solution even if it's not the ideal one in the meantime as it seems bizarre to support multiple protocols and not have this ability.

Tom Verdaat (tom-verdaat) wrote :

Nice quote by Paul Kishimoto on the related bug on GNOME bugzilla:

------------------------------------------------------------------------------------------------------------

So the following have all been mentioned:

People (0.0.6 release two years old, https://launchpad.net/people-core)
Soylent (no commits for 20+ months, http://git.gnome.org/browse/soylent)
Galago (unmaintained, per comment #19)
EDS-feed (unmaintained, per comment #19)
EDS-sync (apparently no releases in 2+ years? http://vcs.maemo.org/svn/eds/trunk/eds-sync/ChangeLog)
GNOME Online Desktop (apparently not actively developed)

...unless there is better evidence that these are or will become usable, that leaves:
* No outside library to wait on,
* One developer who thinks "metacontacts like in pidgin" are "stupid", and
* 50+ others (including https://bugs.launchpad.net/bugs/392507 & duplicates) who want such "stupid" metacontacts.

I would grant that, *if* any of the above projects actually was usable, they would be a better solution than Pidgin-style contact grouping. No one has explained how contact grouping is worse than no contact grouping.

Jerry (priegog) wrote :

What Tom and Phil said...
A little more than a year ago Ubuntu made the bold choice of replacing Pidgin, which I'll concede, is a stagnant and no-longer innovating project, but that is nevertheless pretty much "up there" feature AND stability-wise (except for video and some other "extras" that it's been clear all along that will probably never get added) with Empathy, which is a cool new (well not so much anymore) project with an interesting completely modular design and a much greater room for improvement in the grand scheme of the always-online desktop, in the hopes that doing so would inject empathy with the neccesary developers and innovating drive required to make it a top-of-the-line IM solution perfectly suited for Ubuntu. Now, one year later, Ubuntu has done a GREAT job in the workflow of the DE in general but has done almost nothing for Empathy (except for the webcam thing which doesn't really work that well either). Today, empathy feels almost as primitive, aphla-y, unstable and generally unusable as it did a year ago. Simple things like this bug's metacontacts, the control over chat logs or even the keyboard shortcut for switching between tabs (Ctrl-tab) are sorely missing. And the responses we get from gnome developers range from a simple "no, and we'll never add that kind of control" (in the case of the keyboard shortcut, to an elusive "it's planned for Gnome 3" which is (IMHO) inacceptable not only for the fact that Gnome 3 is in all probability more than a year away (and even more so before it can be considered "production stable"), but also because it denotes the unflexible and disregarding nature of the people in charge of this project.
I just think the folks at Ubuntu should have given that decision a little more thought, specially given the controversy and uproar that it caused when it was proposed.
And I wish someone could hack-in this functionality, because small and insignificant as it may be, makes a day-and-night difference for people with >3 IM accounts.

Frank Abel (frankabel) wrote :

Just look at http://ubuntuforums.org/showthread.php?p=9199695 to get an idea of the amount of people that need this bug fixed.

Danjones (goodevilgenius) wrote :

Why is this so far back on the Roadmap? This is a serious problem with Empathy. With it being the official IM client in Gnome and Ubuntu, it needs to behave like people expect multi-protocol IM clients to behave, and contact grouping is a feature that pretty much every other similar program does. I am certain that there are a large number of people who would switch from pidgin if this one issue was fixed.

Ian Gustafson (iangustafson) wrote :

+1

Empathy is getting closer, but without this feature it won't hold a candle to Pidgin's usability.

Shimi Chen (shimi-chen) wrote :

Definitely the "killer feature" keeping me from using Empathy.

Omen_20 (omen20) wrote :

I'd love to use Empathy for its integration, but all my friends have multiple accounts. I have to use this. Can you imagine having 4 versions of everyone?

Felix Zweig (f.zweig) wrote :

Thank you all for showing support of this bug. However, those "me too" comments are of no use and just create noise. Thus, would you be so kind and refrain from adding those? Selecting "This bug affects me too" is adequate. Thank you!

Jamin W. Collins (jcollins) wrote :

Considering the bug has been open for just short of two years, and has at best a Wishlist state. The upstream report for this is nearly three years old. Yet somehow this has still been selected as the default client for Ubuntu. As others have pointed out this is a fairly standard feature of multi-network chat clients.

Couple this with the apparent complete lack of support for keyboard binds and I fail to see how this client was remotely ready to be selected as the default chat client. Especially in an LTS release. I'd say the noise is needed.

Brian Curtis (bcurtiswx) wrote :

@Jamin, no, the noise is truly unnecessary. If you don't like it then don't use it. If you are a "mee too" then click "this bug affects me too" you are not forced to use empathy as uninstalling it and using another IM client is well within the simplicities of Ubuntu. Thats what makes it such a great OS.

Jamin W. Collins (jcollins) wrote :

Not quite, see the Indicator applet is forced upon those of use that want a volume icon regardless of whether we want the mail icon or it's other bits. As such it's either use the default or have forced bloat in terms of the systray/notification area. If there's a way to do away with the indicator applet yet still have the previous functionality in terms of volume control and bluetooth, I'll happily do so and leave this report in peace.

Serge Matveenko (lig) wrote :

Jamin, Pidgin supports indicator-applet.

Kẏra (kxra) on 2010-05-13
description: updated
Asaf Zamir (asaf-zamir) wrote :

Is it a fair guess that the logs would be merged between the contacts or would it be by ID (so John@MSN won't be the same log as John@ICQ)?
How is it on Pidgin? Log merging or not?

i suggest to think in persons, not protocols
that comes to one more naturally.

On Sun, May 16, 2010 at 17:04, Asaf Zamir <email address hidden> wrote:

> Is it a fair guess that the logs would be merged between the contacts or
> would it be by ID (so John@MSN won't be the same log as John@ICQ)?
> How is it on Pidgin? Log merging or not?
>

there is no need to merge anything here. logs should and hopefully will be
displayed, threaded to a person, honoring the user's rules for each
metacontact..

pidgin: can't tell you about how logs are handled there.. all i know is that
two semantically different models of the concept "group" are mixed in the
pidgin contact list..

> Is it a fair guess that the logs would be merged between the contacts or
> would it be by ID (so John@MSN won't be the same log as John@ICQ)?
> How is it on Pidgin? Log merging or not?
>

Pidgin saves each log separately, but shows them together. This way, John@MSN and John@ICQ are stored separately in disk, but when shown, all John's log are shown together as John's log. I think this is a great option, specially since, if we later decide that these are two different Johns (the merging was a mistake), we still have each log separate.

Kai Mast (kai-mast) wrote :

It seems like the plan is now to use "libfolks". Look here: http://telepathy.freedesktop.org/wiki/Folks

Xavier Guillot (valeryan-24) wrote :

Hello,

That's right for libfolks, here is the mail received on the bugzilla
list for this point.

And as others I hope for this feature which is essential today with
multiplication of networks (Facebook, Jabber, MSN...).

Best regards.

-------- Original Message --------
Subject: [Bug 460647] Support metacontacts
Date: Thu, 13 May 2010 17:21:51 +0000 (UTC)
From: empathy (bugzilla.gnome.org) <email address hidden>
To: <email address hidden>

https://bugzilla.gnome.org/show_bug.cgi?id=460647
   empathy | General | 2.28.x

Olivier Le Thanh Duong<olivier> changed:

            What |Removed |Added
----------------------------------------------------------------------------
                  CC| |<email address hidden>

--- Comment #40 from Olivier Le Thanh Duong<email address hidden> 2010-05-13 17:21:44 UTC ---
Work is going on to implement metacontacts using the new libfolks library which
will be able to support what ever crazy backend you may want and isn't
restricted to Empathy, help on it would surely be appreciated. See here
http://telepathy.freedesktop.org/wiki/Folks for more info.

Lee Braiden (lee-braiden) wrote :

Just one additional thought: this should support priorities, on a general and per-contact basis. For example, given a contact with both jabber and MSN, a FOSS user may prefer to contact someone through Jabber as a general rule. But a particular user may use jabber in work, and MSN on his phone, in which case MSN might be the better choice for that contact.

I'd suggest implementing a protocol-priority widget, and adding instances to both session-wide preferences, and individual contact properties.

Felix Zweig (f.zweig) wrote :

The upstream bug report (gnome-bugs #460647) lists this issue as fixed:
> Thanks to the hard work of Travis and Philip, Empathy master is now able to
> link contacts together and meta-contacts are displayed in the contact list. I
> think it's finally time to close this bug \o/

The change will come in Empathy 2.31.91 which is to be included in Maverick 10.10.

Changed in empathy:
status: Confirmed → Fix Released
Omer Akram (om26er) wrote :

this bug will be fixed after Maverick beta is released as empathy 2.31.91 will then be uploaded

Changed in empathy (Ubuntu):
status: Triaged → Fix Committed
Changed in people-core:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 2.31.91.1-0ubuntu1

---------------
empathy (2.31.91.1-0ubuntu1) maverick; urgency=low

  * New upstream release
  * debian/control:
    - add libgcr-dev build-dep
  * debian/patches/91_git_unref_empathyindividualview_later.patch:
    - additional fix from git requested by upstream

empathy (2.31.91-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Support metacontacts (Travis Treitter, Philip Treitter) (LP: #256478)
    - Initial empathy account wizard (Welcome Screen) does not offer IRC as an
      account (Guillaume Desmottes) (LP: #433714)
    - Dragging and dropping a chat tab hides the original window (Guillaume
      Desmottes) (LP: #512746)
    - After upgrade to 2.31.90 (from 2.31.6) empathy does not list users of irc
      chat (Guillaume Desmottes) (LP: #622684)
  * debian/control:
    - Bump build-depends on libgnome-keyring-dev, libfolks-dev,
      libfolks-telepathy-dev, libnautilus-sendto-dev
    - Add build-depends on libgnutls-dev
    - Drop build-depends on libebook1.2-dev
 -- Didier Roche <email address hidden> Thu, 02 Sep 2010 12:40:03 +0200

Changed in empathy (Ubuntu):
status: Fix Committed → Fix Released
Changed in empathy:
importance: Unknown → Medium

Now grouping of contacts works, that's right.
But if a contact chooses to switch the protocol (which many of my friends with multiprotocol clients do randomly), another chat window opens.
The behavior I expect is like in pidgin: merged contacts share a single chat window.

frizzle21 (frederik-nnaji) wrote :

file a seperate bug.

2011/1/1 Martin Schröder <email address hidden>

> Now grouping of contacts works, that's right.
> But if a contact chooses to switch the protocol (which many of my friends
> with multiprotocol clients do randomly), another chat window opens.
> The behavior I expect is like in pidgin: merged contacts share a single
> chat window.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/256478
>
> Title:
> Support contact grouping (metacontacts)
>
> Status in Chat app, and Telepathy user interface:
> Fix Released
> Status in People:
> Invalid
> Status in “empathy” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: empathy
>
> Empathy does not support grouping contacts, ie. specifying a friend which
> exists in several IM networks. This results in same friend being showed over
> and over again in the list(s).
>
> The problem is being solved using libfolks (
> http://telepathy.freedesktop.org/wiki/Folks) which can aggregate contacts
> from multiple sources like People (https://launchpad.net/people-project)
> and/or Soylent (http://live.gnome.org/Soylent)
>
> - According to the Roadmap (http://live.gnome.org/Empathy/Roadmap).
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/empathy/+bug/256478/+subscribe
>

Hi To all! I have to resume this thread... I'm on Ubuntu 12.04 and I have no group contacts option in the context menu of contacts in the contact list... It used to be there since months ago... but one day just disappeared!

I have written today the following question and I've been suggested to do a bug report, so here I am!

This is the link to my question with all the details of my problem

https://answers.launchpad.net/ubuntu/+source/empathy/+question/207839

Thanks

Rudy

Timo Reimerdes (timorei) wrote :

So it WAS there, and I'm NOT crazy. I have the exact same issue as Rodolfo Gonella Diaza: I can't group the contacts anymore. Since some of my best friends have up to seven different accounts linked to various of my own accounts... well, basically the display isn't enough to tell who is online and who isnt.

running current elementaryos beta1 (wich is based on ubuntu 12.04).

Renato (renatoat) wrote :

I'm using Ubuntu 13.04 and no Link/Unlink options too.

Should a new bug report be created?

Renato (renatoat) wrote :

Oh, this worked:

https://bugzilla.gnome.org/show_bug.cgi?id=687856

Incredibly awkward.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.