inverse/natural scrolling by default

Bug #952170 reported by Sergey "Shnatsel" Davidoff on 2012-03-11
56
This bug affects 15 people
Affects Status Importance Assigned to Milestone
elementary OS
0.2-luna
Won't Fix
Wishlist
Unassigned
0.3-freya
Fix Released
Medium
Cody Garver

Bug Description

Use inverse/natural scrolling by default, but only for touchpads and touchscreens.

description: updated
Changed in elementaryos:
status: New → Confirmed
importance: Undecided → Wishlist
milestone: none → luna-beta1
tags: added: defaults
Heimen Stoffels (vistaus) wrote :

I support this idea fully.

Changed in elementaryos:
milestone: luna-beta1 → none
Radvin Bringas (johallins) wrote :

Would like this feature added as well.

dannycandel (danny-candle) wrote :

Hi guys. I have system wide native natural scrolling that's done through xorg rather than a 3rd party app. I think that implementing this by default in elementary would be as simple as editing the file "xorg.conf" at /etc/X11/

For me, adding the following text to the file brought be perfect natural scrolling on a macbook 6,1 but I'm sure it must be different with different computers and input devices.

Section "InputClass"
    Identifier "Touchpad"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "ClickFinger3" "2"
    Option "HorizTwoFingerScroll" "1"
    Option "VertScrollDelta" "-85"
    Option "HorizScrollDelta" "-85"
    Option "TapButton1" "0"
    Option "TapButton2" "0"
    Option "TapButton3" "0"
    Option "FingerHigh" "8"
    Option "FingerLow" "8"
EndSection

Albert (optimisme) wrote :

+1 - I really need "natural" scrolling or a way to enable it from "touchpad" settings.

Right now scrolling makes no sense for touchpads, because you move "up" your fingers when you want to scroll "down".

Daniel Fore (danrabbit) wrote :

The xorg method doesn't effect any of the newer GTK stuff that using smooth/inertial scrolling. Instead, we should actually invert the values in the synaptics touchpad driver. This ensures that we're also not messing with mouse users.

You can do this with a command like "synclient VertScrollDelta=-n" where -n is the inverse of whatever the value currently is for you. For full effect, you can also invert horizontal scrolling with "synclient HorizScrollDelta=-n"

Cody Garver (codygarver) on 2013-05-15
Changed in elementaryos:
milestone: none → luna-rc1

This was implemented in newer versions of the GNOME stack. Not sure what we'd need to backport or if it would just make sense to hold off for L+1 to do it right.

Daniel Fore (danrabbit) on 2013-05-25
Changed in elementaryos:
milestone: luna-rc1 → 0.3-beta1
Cody Garver (codygarver) on 2013-05-25
no longer affects: elementaryos
Albert (optimisme) wrote :

As said before, it is very easy to do just changing the synaptics configuration:

 more /usr/share/X11/xorg.conf.d/50-synaptics.conf

...
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
 Option "VertScrollDelta" "-111"
 Option "HorizScrollDelta" "-111"
...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers