Use light-locker as lockscreen

Bug #951066 reported by Sergey "Shnatsel" Davidoff
148
This bug affects 33 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
Wishlist
Cody Garver

Bug Description

Current state of lock screen dialog is this: http://i39.tinypic.com/n5isdl.png
Do we want to change anything for Luna?

Tags: os-patch
Changed in elementaryos:
assignee: nobody → elementary UX Team (elementary-design)
milestone: none → luna-beta1
Revision history for this message
Maxwell Barvian (mbarvian-deactivatedaccount) wrote :

Can we change anything relatively easily here? That'd be great, I think.

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Well, it's C code. Includes a config dialog for itself. Nothing too fancy or huge, as far as I can judge.
Maybe it would be better to write one from scratch if we want consistency and media keys and farewell-like stuff.

Revision history for this message
Zahirovic Mensur (nookienoq) wrote : Re: [Bug 951066] Re: Lock screen dialog could use a facelift

Actually if i'm not wrong it can be edited with glade =) So you can modify
it quite fast.
I think i did it long time ago, but i'n not 100% sure.. I think it should
be changed for luna, since it'q quite often people lock their screens
atleast at work.
Correct me if I'm wrong.

2012/3/9 Sergey "Shnatsel" Davidoff <email address hidden>

> Well, it's C code. Includes a config dialog for itself. Nothing too fancy
> or huge, as far as I can judge.
> Maybe it would be better to write one from scratch if we want consistency
> and media keys and farewell-like stuff.
>
> --
> You received this bug notification because you are a member of
> elementary UX Team, which is a bug assignee.
> https://bugs.launchpad.net/bugs/951066
>
> Title:
> Lock screen dialog could use a facelift
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/951066/+subscriptions
>

Revision history for this message
Zahirovic Mensur (nookienoq) wrote :

I've created a small mock which is possible to implement very quick today..
http://i39.tinypic.com/vxaq0.jpg

Have a look...
Cheerz

2012/3/10 Mensur Zahirovic <email address hidden>

> Actually if i'm not wrong it can be edited with glade =) So you can modify
> it quite fast.
> I think i did it long time ago, but i'n not 100% sure.. I think it should
> be changed for luna, since it'q quite often people lock their screens
> atleast at work.
> Correct me if I'm wrong.
>
>
> 2012/3/9 Sergey "Shnatsel" Davidoff <email address hidden>
>
>> Well, it's C code. Includes a config dialog for itself. Nothing too fancy
>> or huge, as far as I can judge.
>> Maybe it would be better to write one from scratch if we want consistency
>> and media keys and farewell-like stuff.
>>
>> --
>> You received this bug notification because you are a member of
>> elementary UX Team, which is a bug assignee.
>> https://bugs.launchpad.net/bugs/951066
>>
>> Title:
>> Lock screen dialog could use a facelift
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/elementaryos/+bug/951066/+subscriptions
>>
>
>

Revision history for this message
Danielle Foré (danrabbit) wrote : Re: Lock screen dialog could use a facelift

We're past feature freeze, so let's concentrate on a small facelift and we can think about adding things like media controls for next cycle. I've attached a mockup of a relatively small update.

Changed in elementaryos:
status: New → Confirmed
assignee: elementary UX Team (elementary-design) → nobody
Changed in elementaryos:
importance: Undecided → Medium
tags: added: os-patch
Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

Any way we could get Tom Beckmann to take a look? :D

Revision history for this message
Eduard Gotwig (gotwig) wrote :

Ubuntu 12.04 beta had one time a link to lightdm, which managed the lock screen.

That is consistent.

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Not really critical for Luna, marking wishlist.

Changed in elementaryos:
importance: Medium → Wishlist
status: Confirmed → Triaged
Changed in elementaryos:
milestone: luna-beta1 → none
Cody Garver (codygarver)
Changed in elementaryos:
milestone: none → 0.3-beta1
Revision history for this message
E G (salsaton) wrote :

can't you use something similar to the greeter (flat window with profile picture) and especially with the clock at the right? Would be very concistent and shiny ;-)

Cody Garver (codygarver)
summary: - Lock screen dialog could use a facelift
+ Use light-locker as lockscreen
Changed in elementaryos:
assignee: nobody → Cody Garver (codygarver)
status: Triaged → In Progress
Revision history for this message
Timo Reimerdes (timorei) wrote :

Just found this because I felt it was weird to get that "gnome1.2 style lock screen" on my luna install.

I get to see it rather often, because I hardly ever shut down the computer but rather suspend/resume+lock it. I think this is getting more common behaviour with all those smartphones, tablets, hybrids, ultrabooks and laptops around. (see PC-Sales-Numbers).

Cody Garver (codygarver)
Changed in elementaryos:
status: In Progress → Fix Committed
Changed in elementaryos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments