indicator-keyboard is missing [$50]

Bug #1343063 reported by Jirayu Yingthawornsuk on 2014-07-17
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
High
Cody Garver

Bug Description

There is no keyboard layout indicator.
"Key(s) to change layout" also not working

Step to reproduce:
1. Go to switchboard > Keyboard > Layout
2. Add another keyboard Layout (in this case: Thai)
3. Go to Options > Key(s) to change layout
4. Set your key (in this case: ctrl+shift)

At this point, Layout indicator still not show up, Still unable to switch layout using key in step 4.
Restart won't help
apt-get update & upgrade also won't help

Link to Bountysource bounty: https://www.bountysource.com/issues/3177070-indicator-keyboard-is-missing

tags: added: freya
Cody Garver (codygarver) wrote :

indicator-keyboard is getting removed during the blacklist phase of the iso build even though it's not blacklisted

Changed in elementaryos:
importance: Undecided → Medium
milestone: none → freya-beta2
status: New → Confirmed
summary: - Unable to switch keyboard layout, No layout indicator
+ indicator-keyboard is missing
Cody Garver (codygarver) on 2014-07-31
Changed in elementaryos:
importance: Medium → High
milestone: freya-beta2 → freya-beta1
harris (harrismrubin) on 2014-08-05
summary: - indicator-keyboard is missing
+ indicator-keyboard is missing [$50]
description: updated
Cody Garver (codygarver) on 2014-08-06
tags: added: bounty
removed: freya
Raphael Isemann (teemperor) wrote :

I think there is some weird thing going on with the plug. At least for me i could add swedish to my german default, and i got a indicator after i installed indicator-keyboard.

But now i can remove or add any language via the plug but the indicator-keyboard still stays at german/swedish.

Raphael Isemann (teemperor) wrote :

DConf isn't written correctly by the plug, that's the reason. Patch incoming if everything goes right.

Changed in elementaryos:
assignee: nobody → Raphael Isemann (teemperor)
Raphael Isemann (teemperor) wrote :

Ok, specific report now (sorry for spamming):

Keyboard plug writes to org.gnome.libgnomekbd.keyboard and the keyboard-indicator reads from org.gnome.desktop.input-sources

There seems to be some sync to be setup somewhere as it sometimes syncs up, but i think the correct way is to just use org.gnome.desktop.input-sources in the plug.

Changed in elementaryos:
status: Confirmed → In Progress
Cody Garver (codygarver) on 2014-08-11
Changed in elementaryos:
assignee: Raphael Isemann (teemperor) → Cody Garver (codygarver)
status: In Progress → Fix Released
Jirayu Yingthawornsuk (jirayu) wrote :

I tried Beta 1 in VirtualBox, Still unable to switch keyboard layout.

Also, I found that I have to add keyboard layout in Keyboard plug and then go to language plug to enable layouts. and keyboard-indicator will appear.

But shortcut to switch layout still not working.

You have to install updates and try, because fixes got merged
https://code.launchpad.net/~teemperor/switchboard-plug-keyboard/fix-layouts/+merge/230324

On Wed, Aug 13, 2014 at 11:37 PM, Jirayu Yingthawornsuk <email address hidden>
wrote:

> I tried Beta 1 in VirtualBox, Still unable to switch keyboard layout.
>
> Also, I found that I have to add keyboard layout in Keyboard plug and
> then go to language plug to enable layouts. and keyboard-indicator will
> appear.
>
> But shortcut to switch layout still not working.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1343063
>
> Title:
> indicator-keyboard is missing [$50]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1343063/+subscriptions
>

--
Cody Garver

Jirayu Yingthawornsuk (jirayu) wrote :

Updated, still unable to switch layout. (but indicator is showing)

SeLo (selogm) wrote :

I confirm the problem. Indicator is displayed, but shortcuts do not work

Jirayu Yingthawornsuk (jirayu) wrote :

Shortcuts defined in Keyboard > Shortcut are working fine.

But Shortcuts defined in Keyboard > Options are not working

Jirayu Yingthawornsuk (jirayu) wrote :

I tried dbus-monitor and found that shortcuts defined in Keyboard > Options didn't send out any dbus message.

> Indicator is displayed, but shortcuts do not work

The same for me.

Still unable to switch layout.

ilian (9-ilian) wrote :

Same there. I`ve tryed to disable or fully remove Ibus, changing stuff in 'desktop -> ibus -> general and hotkeys.
Also edited "org -> gnome -> desktop -> input-sources -> sources and xkb-options" - no effect
Same with "org -> gnome -> libgnomekbd -> keyboard" my layouts are "['us', 'bg+phonetic']" and options to "['grp\tgrp:alt_shift_toggle']" still not working shortcut.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers