The elementary GTK Theme

Theme Parsing Error in Newer Versions of GTK/GNOME

Reported by Mystilleef on 2012-05-14
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
elementary GTK
Undecided
Unassigned

Bug Description

Egtk crashes gnome-settings-daemon and some other gnome apps, perhaps because there have been changes to the new theme API. I'm using GTK3+ version 3.5.2 on Fedora Rawhide. My .xsession-errors log is as follows:

============================================================================================================
(nm-applet:1759): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.

(gnome-screensaver:1788): Gtk-WARNING **: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.

(gnome-tweak-tool:6467): Gtk-WARNING **: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.
Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.

(Germinal:2003): Gtk-WARNING **: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.

(notification-daemon:1767): Gtk-WARNING **: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:1591): Gtk-WARNING **: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.
gnome-session[1579]: Gtk-WARNING: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.

(nm-applet:1759): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(nm-applet:1759): GLib-GObject-WARNING **: gtype.c:4206: type id `0' is invalid

(nm-applet:1759): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

(gnome-settings-daemon:1591): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(gnome-settings-daemon:1591): GLib-GObject-WARNING **: gtype.c:4206: type id `0' is invalid

(gnome-settings-daemon:1591): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
gnome-session[1579]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11

(gnome-tweak-tool:6467): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable
/usr/lib/python2.7/site-packages/gi/types.py:47: Warning: gtype.c:4206: type id `0' is invalid
  return info.invoke(*args, **kwargs)
/usr/lib/python2.7/site-packages/gi/types.py:47: Warning: can't peek value table for type `<invalid>' which is not currently referenced
  return info.invoke(*args, **kwargs)
Window manager warning: Log level 32: Failed to load module "pk-gtk-module"
0.000006:
0.000133: Failed to load module "pk-gtk-module"
0.002613: cairo-compmgr(ccm_log_print_backtrace+0x1d) [0x805639d]
0.002703: /lib/libglib-2.0.so.0(g_logv+0x219) [0xb6e7ecf9]
0.002718: /lib/libglib-2.0.so.0(g_log+0x34) [0xb6e7ee64]
0.002730: /lib/libgtk-x11-2.0.so.0() [0x4f1fb08b]
0.002744: /lib/libgtk-x11-2.0.so.0() [0x4f1fb43c]
0.002783: /lib/libgtk-x11-2.0.so.0() [0x4f260642]
0.002797: /lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__PARAM+0xaa) [0xb6f68d4a]
0.002811: /lib/libgobject-2.0.so.0(+0xbd2e) [0xb6f64d2e]
0.002824: /lib/libgobject-2.0.so.0(g_closure_invoke+0x197) [0xb6f65f07]
0.002836: /lib/libgobject-2.0.so.0(+0x1f733) [0xb6f78733]
0.002849: /lib/libgobject-2.0.so.0(g_signal_emit_valist+0xd50) [0xb6f81430]
0.002861: /lib/libgobject-2.0.so.0(g_signal_emit+0x34) [0xb6f815c4]
0.002875: /lib/libgobject-2.0.so.0(+0x118df) [0xb6f6a8df]
0.002887: /lib/libgobject-2.0.so.0(g_object_notify+0x180) [0xb6f6c670]
0.002900: /lib/libgtk-x11-2.0.so.0() [0x4f263dc4]
0.002913: /lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x425) [0x4f1da065]
0.002926: /lib/libgdk-x11-2.0.so.0() [0x4f7f8009]
0.002939: /lib/libglib-2.0.so.0(g_main_context_dispatch+0x14b) [0xb6e770cb]
0.002952: /lib/libglib-2.0.so.0(+0x47470) [0xb6e77470]
0.002964: /lib/libglib-2.0.so.0(g_main_loop_run+0x83) [0xb6e778d3]
0.002977: /lib/libgtk-x11-2.0.so.0(gtk_main+0xb0) [0x4f1d8c60]
0.002990: cairo-compmgr(main+0x1ba) [0x805587a]
0.003002: /lib/libc.so.6(__libc_start_main+0xf5) [0xb6c91635]
0.003015: cairo-compmgr() [0x80559b9]
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"

(notification-daemon:1767): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(notification-daemon:1767): GLib-GObject-WARNING **: gtype.c:4206: type id `0' is invalid

(notification-daemon:1767): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
Gtk-Message: Failed to load module "pk-gtk-module"

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:200:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:201:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:231:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:232:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: button.css:164:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: button.css:165:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: content-view.css:62:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: content-view.css:68:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Theme parsing error: content-view.css:80:20: Not using units is deprecated. Assuming 'px'.

(gnome-settings-daemon:6480): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(gnome-settings-daemon:6480): GLib-GObject-WARNING **: gtype.c:4206: type id `0' is invalid

(gnome-settings-daemon:6480): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
gnome-session[1579]: WARNING: App 'gnome-settings-daemon.desktop' respawning too quickly
gnome-session[1579]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Gtk-Message: Failed to load module "pk-gtk-module"

=============================================================================================================

Related branches

Daniel Fore (danrabbit) on 2012-05-15
Changed in egtk:
status: New → Fix Committed
milestone: none → 3.2
Mystilleef (mystilleef) wrote :
Download full text (4.2 KiB)

Unfortunately, it still crashes with the following error. The "Style property "border-top-left-radius" is not gettable" warning may be the culprit.

=================================================================================================
(gnome-tweak-tool:8778): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-settings-daemon:1574): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(gnome-settings-daemon:1574): GLib-GObject-WARNING **: gtype.c:4206: type id `0' is invalid

(gnome-settings-daemon:1574): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

(nm-applet:1737): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(nm-applet:1737): GLib-GObject-WARNING **: gtype.c:4206: type id `0' is invalid

(nm-applet:1737): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced

(notification-daemon:1745): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable

(notification-daemon:1745): GLib-GObject-WARNING **: gtype.c:4206: type id `0' is invalid

(notification-daemon:1745): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
gnome-session[1558]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11

(gnome-tweak-tool:8778): Gtk-WARNING **: Style property "border-top-left-radius" is not gettable
/usr/lib/python2.7/site-packages/gi/types.py:47: Warning: gtype.c:4206: type id `0' is invalid
  return info.invoke(*args, **kwargs)
/usr/lib/python2.7/site-packages/gi/types.py:47: Warning: can't peek value table for type `<invalid>' which is not currently referenced
  return info.invoke(*args, **kwargs)
Window manager warning: Log level 32: Failed to load module "pk-gtk-module"
0.000006:
0.000117: Failed to load module "pk-gtk-module"
0.001877: cairo-compmgr(ccm_log_print_backtrace+0x1d) [0x805639d]
0.001960: /lib/libglib-2.0.so.0(g_logv+0x219) [0xb6ebfcf9]
0.001976: /lib/libglib-2.0.so.0(g_log+0x34) [0xb6ebfe64]
0.001990: /lib/libgtk-x11-2.0.so.0() [0x4f1fb08b]
0.002004: /lib/libgtk-x11-2.0.so.0() [0x4f1fb43c]
0.002018: /lib/libgtk-x11-2.0.so.0() [0x4f260642]
0.002033: /lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__PARAM+0xaa) [0xb6fa9d4a]
0.002047: /lib/libgobject-2.0.so.0(+0xbd2e) [0xb6fa5d2e]
0.002061: /lib/libgobject-2.0.so.0(g_closure_invoke+0x197) [0xb6fa6f07]
0.002075: /lib/libgobject-2.0.so.0(+0x1f733) [0xb6fb9733]
0.002089: /lib/libgobject-2.0.so.0(g_signal_emit_valist+0xd50) [0xb6fc2430]
0.002103: /lib/libgobject-2.0.so.0(g_signal_emit+0x34) [0xb6fc25c4]
0.002117: /lib/libgobject-2.0.so.0(+0x118df) [0xb6fab8df]
0.002131: /lib/libgobject-2.0.so.0(g_object_notify+0x180) [0xb6fad670]
0.002145: /lib/libgtk-x11-2.0.so.0() [0x4f263dc4]
0.002159: /lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x425) [0x4f1da065]
0.002173: /lib/libgdk-x11-2.0.so.0() [0x4f7f8009]
0.002187: /lib/libglib-2.0.so.0(g_main_context_dispatch+0x14b) [0xb6eb80cb]
0.002201: /lib/libglib-2.0.so.0(+0x47470) [0xb6eb8470]
0.002215: /lib/libglib-2.0.so.0(g_main_loop_run+0x83) [0xb6eb88d3]
0.002229...

Read more...

Daniel Svensson (dsvensson) wrote :

Crashes due to #1000545 in unico

Daniel Fore (danrabbit) on 2012-10-12
Changed in egtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers