Update to 3.5.4

Bug #1000545 reported by Robert Ancell on 2012-05-17
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unico
High
Unassigned
gtk+3.0 (Ubuntu)
Wishlist
Robert Ancell
light-themes (Ubuntu)
High
Andrea Cimitan

Bug Description

Branch ready in lp:~ubuntu-desktop/gtk/ubuntugtk3 but light-themes doesn't work well with it

Related branches

Changed in gtk+3.0 (Ubuntu):
status: New → Fix Committed
importance: Undecided → Wishlist
Changed in light-themes (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
Changed in light-themes (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Andrea Cimitan (cimi) wrote :

I have problems testing the theming engines... maybe the package doesn't really work for me

Robert Ancell (robert-ancell) wrote :

Screenshot of rendering errors

kroq-gar78 (kroq-gar78) on 2012-05-18
tags: added: upgrade-software-version
Robert Ancell (robert-ancell) wrote :

As Cimi pointed out it seems to be a packaging bug as the theme modules weren't being loaded. I've fixed that by adding back debian/patches/061_multiarch_module_fallback.patch as the theme packages don't have the modules in a versioned library directory. However GTK+ now crashes when loading the modules, so more investigation required.

Changed in light-themes (Ubuntu):
status: Confirmed → Invalid
Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :
Download full text (9.8 KiB)

OK, so with debian/patches/061_multiarch_module_fallback.patch re-enabled I can confirm that applications work fine with Adwaita, but crash with Unico.

If you are testing, build from the branch and install the packages but be prepared to have the old .debs to roll back to and the appearance preferences window open to switch themes (otherwise you can't start any GTK+ application if using Unico and the 3.5.2 packaging).

I'm testing gcalctool, runs fine in Adwaita, and crashes with Unico:

bob@alchemy:~/bzr/ubuntu/gtk+3.0$ gdb gcalctool
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/gcalctool...(no debugging symbols found)...done.
(gdb) r
Starting program: /usr/bin/gcalctool
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:86:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:193:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:229:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:292:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:326:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:413:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:749:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1097:21: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1190:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1202:21: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1292:21: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1725:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1827:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1844:21: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1860:20: Not using units is deprecated. Assuming 'px'.

(gcalctool:4476): G...

Changed in light-themes (Ubuntu):
status: Invalid → Confirmed
Andrea Cimitan (cimi) wrote :

I see what is happening, it's a change in gtk which reflects in the theming engines. I need a PPA if possible, then next week I might need to work on that.

Andrea Cimitan (cimi) on 2012-05-23
Changed in unico:
status: New → Confirmed
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

See lp:~robert-ancell/light-themes/shadow-offset-units for removing the "px" warnings

Andrea Cimitan (cimi) wrote :

No time to work on that, sorry.

Changed in light-themes (Ubuntu):
assignee: Andrea Cimitan (cimi) → nobody
Robert Ancell (robert-ancell) wrote :

Blocking nautilus update (bug 1008956)

Robert Ancell (robert-ancell) wrote :

Blocking empathy update (bug 1009282)

Robert Ancell (robert-ancell) wrote :

Blocking gnome-online-accounts (bug 1009293)

Andrea Cimitan (cimi) wrote :

Can we have a PPA with updated Gtk+ that needs fix?

Sebastien Bacher (seb128) wrote :
Andrea Cimitan (cimi) wrote :

So, code like that:
  gtk_theming_engine_get (engine, state,
                          /* Can't use border-radius as it's an int for
                           * backwards compat */
                          "border-top-left-radius", &top_left_radius,
                          "border-top-right-radius", &top_right_radius,
                          "border-bottom-right-radius", &bottom_right_radius,
                          "border-bottom-left-radius", &bottom_left_radius,
                          NULL);

is making the engine crash.
what we need to do is replace this with an alternative. Now gtk uses GtkCssValue, we might want to switch over this.

The main unico files that need to be updated is gtkroundedbox.c and gtkroundedboxprivate.h, which were taken from gtk. We need to upgrade following this commit http://git.gnome.org/browse/gtk+/commit/gtk/gtkroundedbox.c?id=edbc8e4f57b871ee151443fe867f6e347682fe8d and switch to the new struts, copying what needed.

Another file that was using those calls is unico-draw.c, while rendering the frame_gap. Again, check gtk to see how it changed.

I know it's ugly, but likely in ubuntu 13.04 we could use CSS for our themes, currently Ambiance requires some extensions thus unico

Robert Ancell (robert-ancell) wrote :

I disabled the rounded corner code in unico, but there also seems to be some rendering issues with labels (see screenshot).

Andrea Cimitan (cimi) wrote :

Could be that in the theme we need to set the background of labels to transparent

Andrea Cimitan (cimi) wrote :

Light themes trunk is fixed, pls update the package. Unico still needs to be patched (temp solution is make all squared and skip the deprecated gtk calls that cause the segfault).

Changed in light-themes (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Andrea Cimitan (cimi)
summary: - Update to 3.5.2
+ Update to 3.5.4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.5.4-0ubuntu1

---------------
gtk+3.0 (3.5.4-0ubuntu1) quantal; urgency=low

  [ Jeremy Bicha ]
  * settings.ini:
    Set gnome-panel menu-bar icon size to 24 so that Ubuntu logo
    for the Applications menu isn't set too small (LP: #986969)

  [ Robert Ancell ]
  * New upstream release (LP: #1000545)
  * debian/control:
    - Bump build-depends on libglib2.0-dev
    - Add breaks older version of gtk3-engines-unico
  * debian/libgtk-3-0.symbols:
    - Updated
  * debian/libgtk-3-0.install.in:
  * debian/rules:
    - Install settings.ini in rules
  * debian/patches/00git_gtkimage_cleanup_crash.patch:
    - Applied upstream

  [ Sebastien Bacher ]
  * Rebase on Debian, including:
    - simplified the build rules and .install
    - dropped the static build (not really useful and costing time and efforts)
  * Remaining diffs:
  * debian/control.in:
    - updated replace versions
  * debian/patches/100_overlay_scrollbar_loading.patch:
    -dropped, the new scollbar code doesn't require that hack
  * Drop fallback support for pre-multiarch loaders
  * Remaining patches:
    - 043_ubuntu_menu_proxy.patch
    - 062_ubuntu-set-grab-add.patch
    - 073_treeview_almost_fixed.patch
    - 075_expose_gdkwidget_for_gtkrange.patch
    - 099_eventbox_scroll_mask.patch
    - git_gtkcellrenderer_grabbing_modifier.patch

  [ Ken VanDine ]
  * debian/patches/101_revert_symbolic_icon_search.patch
    - Revert symbolic icon search changes from 3.4.2, it breaks the icon
      displayed in indicator-power because of the order the icons are searched
      in. It looks like ubuntu-mono should drop the old icon names and
      use the new -symbolic icons. We need to carry this patch until
      ubuntu-mono fixes it's handling of symbolic icons. (LP: #1001229)
 -- Robert Ancell <email address hidden> Fri, 15 Jun 2012 11:36:11 +1200

Changed in gtk+3.0 (Ubuntu):
status: In Progress → Fix Released
Doug McMahon (mc3man) wrote :

Atm this upgrade, using the current light-themes trunk has caused -
Bug 1014481
Additionally -
All dragged files are white
The message, sound & user indicators drop down white menus, the other default indicators are ok

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.10-0ubuntu1

---------------
light-themes (0.1.10-0ubuntu1) quantal; urgency=low

  * New upstream snapshot
    - Updates to work with gtk 3.5.4 (LP: #1000545)
 -- Ken VanDine <email address hidden> Mon, 18 Jun 2012 10:41:59 -0400

Changed in light-themes (Ubuntu):
status: Fix Committed → Fix Released
Changed in unico:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers