audio inidicator broken with GTK 3.14

Bug #1411783 reported by SuperScript on 2015-01-16
134
This bug affects 30 people
Affects Status Importance Assigned to Milestone
elementary Stylesheet
Fix Released
Medium
Daniel Fore

Bug Description

The buttons to pause, play or skip tracks in indicator-sound are invisible (but still there) with the latest upgrade to GTK3.14.

Also, the sound volume slider doesn't function properly. When one tries to drag the handle, it is reset to 0. Clicking around, sometimes you can make it work, but it's messy.

SuperScript (superscript18) wrote :
Daniel Fore (danrabbit) on 2015-01-16
Changed in elementaryos:
status: New → Confirmed
milestone: none → freya-rc1
Derek Pockrandt (derekpock) wrote :

Confirmed. I have the same problem.

Derek Pockrandt (derekpock) wrote :

The buttons are still there, however. If you click in the middle, it will toggle play/pause the music. They are just not displaying at all, as if they are invisible.

Pedro Miguel (mbenites1983) wrote :

i have the same problem!!!!

Changed in elementaryos:
status: Confirmed → Fix Released
Pedro Miguel (mbenites1983) wrote :

Not, I am sorry, the bug even not repair

Derek Pockrandt (derekpock) wrote :

I'm not sure why you put Fix Released. I can't change it back, this problem is still present...

Derek Pockrandt (derekpock) wrote :

Can anybody change it back to Confirmed? This hasn't been fixed yet.

I’m not shure, if there is a »Fix Released« for this problem, but the bug still effects me …

Luciano Porta (lucianoporta97) wrote :

I still have the same problem :(

Cody Garver (codygarver) on 2015-01-19
Changed in elementaryos:
importance: Undecided → Medium
status: Fix Released → Confirmed
t.m (t-martykan-m) on 2015-01-19
description: updated
tags: added: gtk314
SuperScript (superscript18) wrote :

It looks like this is theme-dependent. See my screenshots with various themes applied.

affects: elementaryos → egtk
Changed in egtk:
milestone: freya-rc1 → none
SuperScript (superscript18) wrote :

What the buttons look like is directly affected by what theme is applied.

Here are screenshots with: Numix, Orchis, elementary Dark, and elementary Light themes applied.

description: updated
Daniel Fore (danrabbit) wrote :

Hm I'm having trouble tracking down exactly what the reason is for this.

What I know for sure is that it happened in rev 391. What sucks about that is that this is the gtk 3.14 compat branch so it brought a lot of changes.

I'll definitely need to pick through and figure out just which change is causing the problem. But if someone else has the time and interest first, that is where we need to look.

Changed in egtk:
milestone: none → freya-beta2
Daniel Fore (danrabbit) on 2015-01-24
Changed in egtk:
status: Confirmed → Fix Committed
assignee: nobody → Daniel Fore (danrabbit)
t.m (t-martykan-m) wrote :

For me, the popover arrow is not pointing at the proper location while playing music.
I also noticed that when playing a song without album art, there is just an blank space in the place of albumart.

Daniel Fore (danrabbit) wrote :

t-martykan-m, please report 2 new separate issues for those

As t-martykan-m was saying about the popover arrow and the blank space in the place of albumart, it also affects me.

Daniel Fore (danrabbit) on 2015-02-10
Changed in egtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers