Comment 7 for bug 914880

Yes, looks like you have an old version of VTK. The SetSize function
in VTK should take one argument and it seems to want two arguments
with your version of VTK.

--
Anders

On Wed, Jan 11, 2012 at 08:13:49PM -0000, Johan Hake wrote:
> I do not have a mac build to test against and it looks like it is a VTK
> problem.
>
> Johan
>
> On Wednesday January 11 2012 20:49:15 Ernesto Ismail wrote:
> > The problem still persists and when running the provided code I get the
> > error stream:
> >
> > #######
> > ernesto@Woodchuck:fenics_code$ python poisson_modified.py
> > Calling DOLFIN just-in-time (JIT) compiler, this may take some time.
> > Calling FFC just-in-time (JIT) compiler, this may take some time.
> > Solving linear variational problem.
> > Traceback (most recent call last):
> > File "poisson_modified.py", line 31, in <module>
> > plot(u, interactive=True)
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/d
> > olfin/common/plotting.py", line 121, in dolfin_plot return
> > viper_dolfin.plot(make_viper_object(object, mesh=mesh), *args, **kwargs)
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/v
> > iper/viper_dolfin.py", line 452, in plot fig = _plotter.plot(data,
> > **kwargs)
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/v
> > iper/viper_dolfin.py", line 401, in plot return self.autoplot(plot_object,
> > *args, **kwargs)
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/v
> > iper/viper_dolfin.py", line 415, in autoplot plotter = Viper(plot_object,
> > *args, **kwargs)
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/v
> > iper/viper_dolfin.py", line 60, in __init__ self.plot(data, *args,
> > **kwargs)
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/v
> > iper/viper_dolfin.py", line 85, in plot plot_method(data, *args, **kwargs)
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/v
> > iper/viper_dolfin.py", line 165, in plot_genericfunction
> > vmax=kwargs.get("vmax", None))
> > File
> > "/Applications/FEniCS.app/Contents/Resources/lib/python2.6/site-packages/v
> > iper/viper.py", line 1299, in plot_xy renWin.SetSize(self.window_size)
> > TypeError: function takes exactly 2 arguments (1 given)
> >
> > According to the Question linked above the error was solved in the
> > current release of FEniCS. Despite this, I am running the most current
> > release for OSX and the error persists. Is it possible that the .dmg
> > file does not have the most up to date build of the plot function?
> >
> > Thanks for your efforts thus far,
> >
> > Ernesto
>