Plugins should use translations

Bug #321748 reported by Alex Launi on 2009-01-27
6
Affects Status Importance Assigned to Milestone
Do
Medium
Chris Halse Rogers
Do Plugins
Medium
Chris Halse Rogers

Bug Description

Plugins should actually use translations.

Related branches

Alex Launi (alexlauni) on 2009-01-27
Changed in do-plugins:
importance: Undecided → Medium
status: New → Confirmed
Changed in do:
importance: Undecided → Medium
milestone: none → 0.8.1
status: New → Confirmed

Have a look here:
https://translations.launchpad.net/do-plugins

I'm not sure however, how the translation is made available once it is done. As part of Ubuntu's language pack? Is this made available for people not using Ubuntu?

There is also the issue that the strings describing the plugins in the Preferences interface are not available for translation in that interface.

I think they're not translatable. Probably a call (to something like Catalog.GetString ?) should be made around line 203 in Do.UI/PluginNodeView.cs :

string Description (string name, string desc, string version)
{
 return string.Format (DescriptionFormat, name, desc, version);
}

However, I'm not a Mono/C# programmer, nor do I know much about Do's source, so that might be wrong and/or I might be missing something. Would be cool if somebody could look into those questions? Probably doesn't take long.

On Fri, Feb 27, 2009 at 4:05 PM, Nicolas Chachereau <
<email address hidden>> wrote:

> There is also the issue that the strings describing the plugins in the
> Preferences interface are not available for translation in that
> interface.
>

This needs to be done in the addin manifest itself. We're working on it.
RAOF is heading this up mostly, and he is currently moving so it's unlikely
we'll see this in 0.8.1 unless someone wants to start submitting hella
patches.

--
--Alex Launi

Changed in do:
milestone: 0.8.1 → 0.8.2
Changed in do-plugins:
assignee: nobody → Chris Halse Rogers (raof)
Changed in do:
assignee: nobody → Chris Halse Rogers (raof)
David Planella (dpm) on 2009-06-09
tags: added: i18n
Chris Halse Rogers (raof) wrote :

Looks like this won't actually require core changes.

Changed in do:
status: Confirmed → Invalid
Chris Halse Rogers (raof) wrote :

lp:~raof/do-plugins/plugins-i18n contains most of the work required. What's left is fixing up the stetic-generated gtk-gui files.

Feel free to build these plugins and check that there's some new translating action happening.

Changed in do-plugins:
milestone: none → 0.8.2
status: Confirmed → In Progress
Chris Halse Rogers (raof) wrote :

 status fixcommitted

Well, after that night of stupid manual merging, this has hit do-plugins
trunk. Bon apetit!

Changed in do:
status: Invalid → Fix Committed
Changed in do-plugins:
status: In Progress → Fix Committed
Changed in do:
status: Fix Committed → Fix Released
Alex Launi (alexlauni) on 2009-07-09
Changed in do-plugins:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers