Use squashfs for more recent Ubuntu releases

Bug #1766850 reported by Valery Tschopp on 2018-04-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
diskimage-builder
Undecided
Ian Wienand

Bug Description

The diskimage-builder fails to create Ubuntu 18.04 Bionic image.

The command:

   DIB_RELEASE=bionic disk-image-create vm ubuntu

Fails because it can not download the non existing http://cloud-images.ubuntu.com/bionic/current/bionic-server-cloudimg-amd64-root.tar.gz filesystem tarball for Ubuntu Bionic.

Tested with the latest (master) diskimage-builder version

Log file is attached.

Valery Tschopp (valery-tschopp) wrote :
description: updated
summary: - Fails to create Ubuntu 18.08 Bionic image
+ Does not use squashfs for more recent Ubuntu releases

In an effort to reduce the number of images that we publish on cloud-images.ubuntu.com, we condensed our kernel-less root images to just the squashfs between xenial and bionic (because it can be used directly as a partition for use cases that require that).

Ideally, diskimage-builder would learn how to cache and unpack the squashfs for releases for which it is provided.

description: updated
Stanislav Makar (smakar) on 2018-05-17
summary: - Does not use squashfs for more recent Ubuntu releases
+ Use squashfs for more recent Ubuntu releases
Changed in diskimage-builder:
assignee: nobody → Stanislav Makar (smakar)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/569103

Changed in diskimage-builder:
status: Confirmed → In Progress
Changed in diskimage-builder:
assignee: Stanislav Makar (smakar) → Ian Wienand (iwienand)

Reviewed: https://review.openstack.org/569103
Committed: https://git.openstack.org/cgit/openstack/diskimage-builder/commit/?id=2e6a19a018197f1f9dda54763e65b06e5ad16d1a
Submitter: Zuul
Branch: master

commit 2e6a19a018197f1f9dda54763e65b06e5ad16d1a
Author: Stanislav Makar <email address hidden>
Date: Tue May 15 10:42:31 2018 +0000

    Add Ubuntu 18.04 support

    Use squashfs for more recent Ubuntu releases

    Change-Id: I80df28be6e2a5e03ae1450e84fc05715f21a7750
    Closes-bug: 1766850

Changed in diskimage-builder:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers