Screen stays black if outgoing call is rejected

Bug #1531158 reported by Jean-Baptiste Lallement on 2016-01-05
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
kevin gunn
dialer-app
Undecided
Unassigned
powerd (Ubuntu)
Critical
Alexandros Frantzis

Bug Description

current build number: 210
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en

Test Case:
1. On DUT1 make a call to DUT2 and cover the proximity sensor
2. On DUT2:
  - If call forwarding is set to reject the call immediately (ie not redirect to the voicemail), reject the call
  - Alternatively, you can take the call and immediately hang up.
3. On DUT1, once the call is terminated, uncover the proximity sensor

Expected Result
Screen is on

Actual Result
Screen stays black and cannot be switched on even with the power button. After a moment, the screen blinks and works normally again.

It works as expected on stable.

Related branches

Changed in canonical-devices-system-image:
status: New → Triaged
assignee: nobody → Bill Filler (bfiller)
status: Triaged → New
importance: Undecided → High
importance: High → Critical
Dave Morley (davmor2) wrote :

Confirming screen stays blank for approximately 20-30 seconds. But only if the call is hung up. If the call is transferred to answering machine it works as expected.

Changed in dialer-app:
status: New → Confirmed
tags: added: regression-proposed
description: updated
Dave Morley (davmor2) wrote :

This is a regression over ota 8.5 which works as expected

tags: added: regression-propsed
removed: regression-proposed
tags: added: regression-proposed
removed: regression-propsed
Changed in canonical-devices-system-image:
milestone: none → ww02-2016
Allan LeSage (allanlesage) wrote :

Slightly different case which I assume is the same bug:

TEST CASE
1. DUT2 call DUT1 (subject of test), DUT1 pick up call 1, cover proximity sensor (e.g. by placing to ear)
2. On third phone call DUT1
3. DUT1 beeps to indicate second incoming call, uncover proximity sensor (e.g. by removing from ear to look at screen)
EXPECTED
Screen lit
ACTUAL
Screen black

NOTE: if you don't pick up the second call, the screen will ultimately blink, return to normal as jibel describes--if you've covered/uncovered the proximity sensor n times, *the screen will blink n times*. It feels like something is blocking while the second call is waiting to go to voicemail, then releasing when voicemail picks up.

Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → kevin gunn (kgunn72)
kevin gunn (kgunn72) on 2016-01-06
Changed in dialer-app:
status: Confirmed → Opinion
Changed in unity-system-compositor (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Alexandros Frantzis (afrantzis)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: unity-system-compositor (Ubuntu) → powerd (Ubuntu)
Changed in powerd (Ubuntu):
status: New → Confirmed
Changed in powerd (Ubuntu):
status: New → In Progress
Alexandros Frantzis (afrantzis) wrote :

You can find packages with the fix at: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-025/+packages

Note that when a call is rejected the screen is turned on regardless of proximity status. This is a different issue, not related to this bug (or the fix for the bug).

Changed in dialer-app:
status: Opinion → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerd - 0.16+16.04.20160111.1-0ubuntu1

---------------
powerd (0.16+16.04.20160111.1-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * No-change rebuild.

powerd (0.16+16.04.20160111-0ubuntu1) xenial; urgency=medium

  * Keep the dbus proxy to Unity.Screen (implemented by USC) alive for
    the lifetime of the process. Otherwise we may block when trying to
    create the proxy while servicing a request from USC (LP: #1531158)

 -- Alexandros Frantzis <email address hidden> Mon, 11 Jan 2016 13:34:18 +0000

Changed in powerd (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers