[Upstream] Impress is not playing sounds in pps files

Bug #716439 reported by Luciano Dato on 2011-02-10
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Medium
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libreoffice

1) lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Instalados: 1:3.3.1-1ubuntu3~maverick1
  Candidato: 1:3.3.1-1ubuntu3~maverick1
  Tabla de versión:
 *** 1:3.3.1-1ubuntu3~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main
amd64 Packages
        100 /var/lib/dpkg/status
N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/'
as it has an invalid filename extension

3) What is expected to happen in LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/716439/+attachment/1900142/+files/LouisArmstrong%20MBa.pps && loimpress -nologo LouisArmstrong\ MBa.pps

is the sound plays when viewing the file in Presentation mode.

4) What happened instead is it does not. This occurs in a 64-bit environment. Not reproducible in a 32-bit one.

Luciano Dato, thank you for reporting this bug and helping make Ubuntu better. Could you please attach an Impress file that demonstrates this problem?

If in Maverick or Lucid, please post the results of the following commands to this bug:

lsb_release -rd

apt-cache policy libreoffice-writer

If in Natty, please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 716439
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in libreoffice (Ubuntu):
status: New → Incomplete

apt-cache policy libreoffice-writer

should be:

apt-cache policy libreoffice-impress

These are the result of the commands

lucho@lucho-Studio-1558:~$ lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10
lucho@lucho-Studio-1558:~$ apt-cache policy libreoffice-impress
libreoffice-impress:
  Instalados: 1:3.3.1-1ubuntu3~maverick1
  Candidato: 1:3.3.1-1ubuntu3~maverick1
  Tabla de versión:
 *** 1:3.3.1-1ubuntu3~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main
amd64 Packages
        100 /var/lib/dpkg/status
N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/'
as it has an invalid filename extension

Here is one of the files that don't work. If more are needed please feel
free to ask me for more.

2011/3/10 Christopher M. Penalver <email address hidden>

> apt-cache policy libreoffice-writer
>
> should be:
>
> apt-cache policy libreoffice-impress
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/716439
>
> Title:
> Impress is not playing sounds in pps files
>
> Status in “libreoffice” package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: libreoffice
>
> It seems that every presentation (which include a sound file) I have,
> sound doesn't work. I have tried pps ppsx files.
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/716439/+subscribe
>

--
Luciano Dato

Changed in libreoffice (Ubuntu):
status: Incomplete → New

Luciano Dato, this is unreproducible in Ubuntu 10.10, LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/716439/+attachment/1900142/+files/LouisArmstrong%20MBa.pps && loimpress -nologo LouisArmstrong\ MBa.pps

The song played with the presentation.

lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.1-1ubuntu3~maverick1
  Candidate: 1:3.3.1-1ubuntu3~maverick1
  Version table:
 *** 1:3.3.1-1ubuntu3~maverick1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

MasterPJ (masterpj) wrote :

I have the same problem, no audio in pps or ppt files with libreoffice 3.3.1 on maverick.

Shimi Chen (shimi-chen) wrote :

@MasterPJ, Can you provide a file that does not play sound for you? Or is the file uploaded by Luciano not working for you also?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
description: updated

Luciano Dato, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in df-libreoffice:
status: New → Incomplete
davio smitti (dlsmithmd57) wrote :
  • PPSX Edit (6.0 MiB, application/vnd.openxmlformats-officedocument.presentationml.slideshow)

I cannot get PPSX to play sound.

PANGOLIN

OpenOffice 3.3.0

The Louis Armstrong file plays fine.

davio smitti (dlsmithmd57) wrote :

Oh, in neither OpenOffice 3.3.0, nor in LibreOffice 3.5.2.2

I'm forwarding this bug from Ubuntu Launchpad as it seems to be an upstream one.
This is the original report:
https://bugs.launchpad.net/df-libreoffice/+bug/716439

A file provided by "davio smitti" that illustrates the issue is attached.
I have tried the file in PowerPoint and there is a sound of a man talking through the slideshow, in Impress it is silent.

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Incomplete → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New
summary: - Impress is not playing sounds in pps files
+ [Upstream] Impress is not playing sounds in pps files
tags: added: amd64 lo33
tags: added: maverick

Confirmed with:
LO 4.0.0.0.alpha1+
Build ID: own W7 debug build (dec8fe97d9f48d59b6bb0f98faded0f6aa8397df)
Windows 7 Professional SP1 64 bit

Silence. Only speaker icon is displayed. WAV file is unrecognized.

Changed in df-libreoffice:
status: New → Confirmed
DeMus (jan-mussche) wrote :

Kubuntu 13.04
LibreOffice 4.0.2.2
Kernel 3.8.0-23-generic
I have used various versions of LibreOffice and Ubuntu's (incl. LinuxMint) and I have never had sound when playing a pps file.

Just made a presentation myself, added music but it does not play.

Set platform: All per comment 2

Seems like spesific to 64bit system as described on upstream bug. I can't reproduce on LO 4.0.4.2 (Win7 32bit)

Sorry..I've just realized that attachment on comment 1 is different with attachment in upstream bug:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/716439/+attachment/1900142/+files/LouisArmstrong%20MBa.pps
(pps file which I tested on comment 3)

But I can confirm reproduce problem with ppsx file on comment 1 with:
LO 4.0.4.2 - Win7 32bit
LO 3.6.6.2 - Ubuntu 12.04 32bit

Created attachment 100931
Attachement from Launchpad

Work well on Ubuntu 12.04 x86_64 :
with LibreOffice from Canonical LibreOffice 3.5.7.2 Version ID : 350m1(Build:2)

with LibreOffice 4.2.5.1 Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de from TDF

Not reproducible in Wily.

lsb_release -rd
Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:4.4.4~rc3-0ubuntu1
  Candidate: 1:4.4.4~rc3-0ubuntu1
  Version table:
 *** 1:4.4.4~rc3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.