Comment 84 for bug 349519

Pete Myers (petemyers) wrote :

Just to record my experience with this bug:

Acer One with a fresh install of Jaunty UNR image (i.e. lpia) downloaded 2nd May.

1) I switched to desktop classic, switched back to unr (all in the same session), and got the same error recorded by Scott Evans above:
An error occurred while loading or saving configuration information for
netbook-launcher. Some of your configuration settings may not work
properly. [details] Failed to connect configuration server; some
possible causes are that you need to enable TCP/IP networking for the
ORBit, or you have stale NFS locks due to a system crash. See
http://projects.gnome.org/gconf/ for information. (Details - 1: Could
not send message to gconf daemon: Message did not receive a reply
(timeout by message bus)

2) Rebooted, but UNR loaded without the Gnome panel, and without window decorations (this last bit, I haven't seen in any other comments - but i haven't read them all).

3) switching to desktop classic, and back to unr, gave me some buggy functionality with the UNR, I could see the panels, and window decorations were drawn, but windows weren't drawing properly.

4) In UNR, I tried turning on moderate desktop effects (Preference->appearances->effects tab). Because the window decorations bugs looked like a compiz related bug from about 2 years ago. This didn't help.

5) In UNR, deleted ~/.confg/desktop-switcher (for newbies: use "rm -r ~/.confg/desktop-switcher" from command line)

6) Ran the command from above: "gconftool-2 --set /desktop/gnome/session/required_components_list --type list --list-type=string ["windowmanager","panel"]"

7) Finally, reinstalled desktop-switcher: "sudo apt-get install --reinstall desktop-switcher"

8) Remembered the desktop effects, and turned them off again.

Currently UNR is working, and the bugs have gone. I've rebooted once, and everything loaded fine with no problems. Not sure if every step above is necessary... but it's exactly what I did.