Comment 9 for bug 1039471

Hey Cameron-
  I've looked at this a bit before. Duplicity does need to support glacier
and I did a bit of basic work in that area previously, but not enough to
get it production ready.

Here's what I've done so far:
https://code.launchpad.net/~eric-friedrich84/duplicity/glacier

However the duplicity list and retrieval is _very_ rough around the edges.
I've also gathered some feedback from one of the duplicity maintainer's:
http://lists.nongnu.org/archive/html/duplicity-talk/2013-01/msg00008.html

If you feel like this might provide a good base to continue work, I'm glad
to keep this effort going.

--Eric

On Tue, Apr 9, 2013 at 9:24 PM, Cameron Eagans <email address hidden> wrote:

> I'd like to take this on, but I'm not sure what actually needs done.
> Sounds like duplicity needs to support Glacier, but not sure what else.
> If you guys can point me in the right direction, I'd love to spend some
> time on it.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1039471
>
> Title:
> New feature: Support for Amazon Glacier
>
> Status in Déjà Dup Backup Tool:
> Confirmed
>
> Bug description:
> Amazon has this morning announced a new service called Glacier that
> allows significantly cheaper storage for a time delayed return of the
> data. This is perfect for backup and therefore Deja Dup. It would be
> extremely useful to have this service supported.
>
> http://aws.amazon.com/glacier/
>
> http://docs.amazonwebservices.com/amazonglacier/latest/dev/introduction.html
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/deja-dup/+bug/1039471/+subscriptions
>