Comment 109 for bug 1124250

(In reply to Maurizio Paolini from comment #29)
> I presume you refer to:
>
> echo 1 > /proc/sys/net/ipv4/tcp_tw_recycle
> echo 1 > /proc/sys/net/ipv4/tcp_tw_reuse

Setting net.ipv4.tcp_tw_recycle and net.ipv4.tcp_tw_reuse didn't help in my case. First I have tried this on the nfs client and then on the nfs client and nfs server too.
I have used the following equalent commands:

  sysctl net.ipv4.tcp_tw_recycle=1
  sysctl net.ipv4.tcp_tw_reuse=1

But I tried another thing:
I have increased the value kernel.keys.root_maxbytes. The default was 20000.
First I have increased only kernel.keys.root_maxbytes, leaving kernel.keys.root_maxkeys at default value (200), but this didn't help.
Then I have increased kernel.keys.root_maxkeys too (again). Now all uids and gids on the nfs filesystems are mapped to the correct username, no "4294967294" is displayed anymore.

It seems this solves the "4294967294" nfs problem for me.
I did the following on the nfsv4 client (nfs server was unchanged resp. set to the same state as before the tests):

  sysctl kernel.keys.root_maxkeys=10000
  sysctl kernel.keys.root_maxbytes=200000

I don't know how big the values should be, but it seems they are big enought for our configuration now.