Comment 106 for bug 1124250

we also use NIS, our nfs server is older than yours (Fedora 16, kernel
3.3.5-2.fc16.i686.PAE... however we only have slightly more than 200 users,
so we barely see the problem with the default 200 value for root_maxkeys.
However we do see if if we purposefully decrease the value from 200 to, say, 10.

What comes in mind is that perhaps there is a maximal value (512?) for the
number of keys, or perhaps you hit against the default maximum root_maxbytes
(defaults to 20000). You could try to increase it as well...

(In reply to Edgar Hoch from comment #26)
> Additional info:
>
> "nfsidmap -c" have not solved the problem. /proc/keys was cleared (except of
> some "basic" values), but the nfs idmap problem still occured after listing
> the nfs directories / files.
>
> This is the reason why I have tried the file /etc/sysctl.d/99-maxkeys.conf
> so /proc/sys/kernel/keys/root_maxkeys have the right value (10000) immediate
> after boot. But this haven't solved the problem, too.