odg export still doesn't work

Bug #474956 reported by John M. Długosz on 2009-11-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
inkscape (Debian)
Confirmed
Unknown
inkscape (Ubuntu)
Low
Unassigned

Bug Description

I'm filing a fresh report since the search turned up stuff from 2007. I'm reporting the version of OOO Draw as 3.1.1, and Inkscape is 0.47.
A "binary tree" drawing, exported to ODG, has several problems:
   - of the 7 circles in the picture, only one shows. This could be a problem with clones? Only the "original" shows and all the copies are missing.
   - the circle that is drawn has the wrong outline (stroke) width
   - the lines I drew are also the wrong stroke width
   - the lines are missing the arrow heads or other start/end markers

and less critical, it didn't set the page size and drawing position.

It seems that the SVG importer into Draw isn't working well either. It worked better on a slightly older version of Inkscape, so I wonder if there are changes in the way it writes things.

su_v (suv-lp) wrote :

Could you attach the SVG and ODG file that illustrate the export errors?

tags: added: exporting odg
su_v (suv-lp) on 2009-11-05
Changed in inkscape:
status: New → Incomplete
John M. Długosz (jdlugosz) wrote :
John M. Długosz (jdlugosz) wrote :
su_v (suv-lp) on 2009-11-09
Changed in inkscape:
status: Incomplete → New
jazzynico (jazzynico) wrote :

Confirmed on Vista, Inkscape rev. 22568.

Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.47pre4 and r22566 on OS X 10.5.8, OpenOffice.org 3.1.1

additionally I have issues with the text objects that are exported as unclosed bézier curves with invisible outlines. One has to close each path in OOo Draw to see the text objects at all (happens when locally exporting the above attached test SVG file to ODG as well as when exporting newly created SVG files containing text with fonts that are installed and available for both Inkscape and OpenOffice.org).

su_v (suv-lp) wrote :

Sorry for not checking before commenting - I now see that the font issue is already reported in bug #168268.

John M. Długosz (jdlugosz) wrote :

I saw the text in the odg file. I think the baseline is off, but I don't know what font issue you are discussing.

su_v (suv-lp) wrote :

a) When opening your attached ODG file in OpenOffice.org 3.1.1 for OSX all text is rendered correctly as filled closed paths (bézier curves).
b) When exporting your attached SVG file (or any other SVG file I create) on my mac to ODG, I have font issues which are the same as described in bug #168268.

Alex Valavanis (valavanisalex) wrote :

Would someone mind looking at this report from Debian?

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495715

I think it's the same issue... multiple problems seen when exporting ODG from Inkscape

Changed in inkscape (Ubuntu):
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

Quoted from the Debian report...

Yes, I'm okay with those two issues being merged. Just add "embedded and (possibly) linked bitmaps" to the list of broken things that need fixing.

If a total rewrite is on the cards, might I observe the following opportunity:

If the new filter can be based around UNO ( http://xml.openoffice.org/filter/#2.TheInnardsofanOpenOffice.orgFilterComponent%7Coutline ), you may very well end up with an import SVG/export ODG filter that both projects can utilise.

Changed in inkscape (Debian):
status: Unknown → Confirmed
Alex Valavanis (valavanisalex) wrote :

This appears to have actually become worse in inkscape_0.48.0-1ubuntu1!

* The SVG image renders correctly in Firefox, Chromium and eog
* The SVG image renders incorrectly in Inkscape (file to be uploaded shortly)
* The ODG export renders incorrectly, and differently from the bad rendering in Inkscape (file to be uploaded shortly)

Changed in inkscape (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Alex Valavanis (valavanisalex) wrote :
Alex Valavanis (valavanisalex) wrote :
Changed in inkscape:
status: Confirmed → Triaged
importance: Undecided → Medium
David Mathog (mathog) wrote :

Here is a test file showing a variety of problems in Inkscape 0.48.2-1 when exporting to ODG and then read into LODraw 3.4.4.

1. Line widths are lost (show as 0.0 pts in LODraw).
2. Opacity, gradient, and pattern fills are lost
3. Ends of polylines are joined (see the triangles along the top, they should be "L"

The conversion of square corners to rounded ones is an LODraw bug, it affects other imports too, including from PDF.

David Mathog (mathog) wrote :
David Mathog (mathog) wrote :
David Mathog (mathog) wrote :

Link to bug report on LODraw concerning the rounded corners problem (for PDF, but mentioned that it is common)

https://bugs.freedesktop.org/show_bug.cgi?id=43806

David Mathog (mathog) wrote :

Problem 4, on the "open circle" type of ellipse, bottom row near the bottom/left of the diagram, the objects are not filled.

David Mathog (mathog) wrote :

The filled open bezier issue (problem 4) probably needs a fix something along these lines:

1. Draw a second bezier curve identical to the first except that it is closed and the stroke is not visible.
2. Fill the second bezier curve with the fill properties from the original Inkscape SVG object.
3. Draw the primary bezier curve over it. Do not close this Bezier, do not fill it.

Kris (kris-degussem) wrote :

Some preparatory work to allow gradients in the odg export done and committed in trunk r12264.
Linear fill gradients are now correctly exported, but still do not take gradient orientation or position into account.

Work to export other gradient types in progress ...

Changed in inkscape:
assignee: nobody → Kris (kris-degussem)
status: Triaged → In Progress
Kris (kris-degussem) on 2013-04-20
Changed in inkscape:
status: In Progress → Triaged
assignee: Kris (kris-degussem) → nobody
Kris (kris-degussem) wrote :

Some more work done on the gradients in trunk r12286, which does not lead to correct showing a drawing with gradients (C++-code is improved, but still something is interfering with correct orientation).

Reference to further improve the code: open document format specification
   https://www.oasis-open.org/committees/download.php/20847/OpenDocument-v1.1-cs1.pdf

Beluga (buovjaga) wrote :

Tried with binary-tree 1.svg, but it says it could not be saved to odg :(

Arch Linux 64-bit, KDE Plasma 5
Inkscape 0.92+devel 15099 (GTK3)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.