Direct Messages don't work since July 1st, 2011

Bug #789851 reported by James Gifford on 2011-05-29
480
This bug affects 119 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
gwibber (Debian)
New
Undecided
Unassigned
gwibber (Fedora)
Fix Released
Undecided
gwibber (Ubuntu)
High
Unassigned

Bug Description

According to the Twitter API team, users will not be able to access Direct Messages by default after June 30th, 2011. For more on this, see [1] and [2].

It should not require any change in the codebase, just a change in permissions level on dev.twitter.com [3]

[1] http://groups.google.com/group/twitter-development-talk/browse_thread/thread/e954fc0f8b5aa6ec?pli=1
[2] http://groups.google.com/group/twitter-development-talk/browse_thread/thread/7798d7f728170c5f#
[3] http://dev.twitter.com

Robert Roth (evfool) on 2011-06-05
affects: ubuntu → gwibber (Ubuntu)
Kamus (kamus) on 2011-06-24
Changed in gwibber (Ubuntu):
importance: Undecided → Low
status: New → Triaged
assignee: nobody → Ken VanDine (ken-vandine)
James Gregory (jamgregory) wrote :

This change has now come into effect, which means you cannot use Gwibber to view direct messages any more. I think the importance of this bug is higher than 'low', considering direct messages are a pretty crucial part to Twitter.

Stefano Maffulli (smaffulli) wrote :

Not only direct messages are important, but also the nag is very prominent. To leave it there is Bad Bad user experience. Hopefully the priority is changed and the bug fixed.

Agreed. This should be a "high" priority at this point.

On Jun 30, 2011, at 14:50, James Gregory <email address hidden> wrote:

> This change has now come into effect, which means you cannot use Gwibber
> to view direct messages any more. I think the importance of this bug is
> higher than 'low', considering direct messages are a pretty crucial part
> to Twitter.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/789851
>
> Title:
> Direct Messages view won't work in a few weeks
>
> Status in Gwibber:
> New
> Status in “gwibber” package in Ubuntu:
> Triaged
>
> Bug description:
> According to the Twitter API team, users will not be able to access
> Direct Messages by default after June 30th, 2011. For more on this,
> see [1] and [2].
>
> It should not require any change in the codebase, just a change in
> permissions level on dev.twitter.com [3]
>
> [1] http://groups.google.com/group/twitter-development-talk/browse_thread/thread/e954fc0f8b5aa6ec?pli=1
> [2] http://groups.google.com/group/twitter-development-talk/browse_thread/thread/7798d7f728170c5f#
> [3] http://dev.twitter.com
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gwibber/+bug/789851/+subscriptions

Ken, could you take a look into this issue please, thanks!

Changed in gwibber (Ubuntu):
importance: Low → High
terakin (terakinizers) wrote :

I encountered the same phenomena from Today, July 1 (JST). The message "This Application ..." appears on the top of gwibber window, but the posting can be made as usual. It's very strange, bad appearance, and makes people worrying... I am using gwibber with version 3.1.0-bzr997 (daily build supplied by PPA gwibber-daily).

Silner (silner) wrote :

I've encountered the same issue using Gwibber 3.1.0 on Fedora 14 (testing repo enabled)

Frank Baumeister (baumeisterf) wrote :

This should be fixed as soon as possible.

With respect, this needed fixing when I first filed the bug.

On Jul 1, 2011, at 5:18, Frank Baumeister <email address hidden> wrote:

> This should be fixed as soon as possible.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/789851
>
> Title:
> Direct Messages view won't work in a few weeks
>
> Status in Gwibber:
> New
> Status in “gwibber” package in Ubuntu:
> Triaged
>
> Bug description:
> According to the Twitter API team, users will not be able to access
> Direct Messages by default after June 30th, 2011. For more on this,
> see [1] and [2].
>
> It should not require any change in the codebase, just a change in
> permissions level on dev.twitter.com [3]
>
> [1] http://groups.google.com/group/twitter-development-talk/browse_thread/thread/e954fc0f8b5aa6ec?pli=1
> [2] http://groups.google.com/group/twitter-development-talk/browse_thread/thread/7798d7f728170c5f#
> [3] http://dev.twitter.com
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gwibber/+bug/789851/+subscriptions

Dave Pawson (dave-pawson) wrote :

a) Annoying, hence higher priority please.
Affects FC15 too.

Dave

in twitter api announcements, arnaud posted the steps to allow gwibber (and other clients) to use direct messaging within the new permission model:
"If you wish to read or delete a user's Direct Messages, you need to update your application and have your existing access tokens reauthorized through the OAuth authorize web flow."
here's the url:
http://groups.google.com/group/twitter-api-announce/browse_thread/thread/4956a4dd169be70c

summary: - Direct Messages view won't work in a few weeks
+ Direct Messages don't work since July 1st, 2011
Jürgen Geuter (tante) wrote :

It's really just updating the Application settings in Twitter and Re-auth. And considering that Gwibber recommends to use your own application for each Distribution that is a problem all distros can fix themselves quickly without a lot of trouble.
You distribution just needs to add a patch like: http://gitorious.org/tante_overlay/mainline/blobs/master/net-misc/gwibber/files/gwibber-twitter-api-key.patch

Ken VanDine (ken-vandine) wrote :

I updated the application permissions with twitter weeks ago. Can someone get me a logfile that contains the error twitter returns for accounts that need a re-auth? I can catch that and prompt users to re-auth.

I got this ; at this point, the red banner with the error is showing.

adrian@motoko:~/.cache/gwibber$ gwibber -d
ERROR:dbus.proxies:Introspect error on com.Gwibber.Messages:/com/gwibber/Messages: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name com.Gwibber.Messages was not provided by any .service files

(gwibber:14049): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
(gwibber:14049): LIBDBUSMENU-GTK-DEBUG: Could not handle image type 6

{}
/usr/lib/python2.7/dist-packages/gwibber/gwui.py:870: GtkWarning: gtk_box_pack: assertion `child->parent == NULL' failed
  self.pack_start(content_area, False)

James Gregory (jamgregory) wrote :

I did:

gwibber-service -d -o

but didn't get any useful output (no Python errors etc.) - it merely returned

[..]
Twitter : DEBUG ** Starting Refresh - 2011-07-06 16:13:25.00 **
DEBUG:Twitter:** Starting Refresh - 2011-07-06 16:13:25.00 **
Twitter : DEBUG <twitter:receive> Performing operation
DEBUG:Twitter:<twitter:receive> Performing operation
Twitter : DEBUG <twitter:responses> Performing operation
DEBUG:Twitter:<twitter:responses> Performing operation
Twitter : DEBUG <twitter:receive> Finished operation
DEBUG:Twitter:<twitter:receive> Finished operation
Twitter : DEBUG <twitter:private> Performing operation
DEBUG:Twitter:<twitter:private> Performing operation
Twitter : DEBUG <twitter:responses> Finished operation
DEBUG:Twitter:<twitter:responses> Finished operation
Twitter : DEBUG <twitter:private> Finished operation
DEBUG:Twitter:<twitter:private> Finished operation
Twitter : DEBUG Private Messages Indicator count updated to 0
DEBUG:Twitter:Private Messages Indicator count updated to 0
Twitter : DEBUG Replies Indicator count updated to 0
DEBUG:Twitter:Replies Indicator count updated to 0
Twitter : DEBUG Messages Indicator count updated to 0
DEBUG:Twitter:Messages Indicator count updated to 0
[..]

Description of problem:
I can't view any direct message. The following message displays at the top of my Messages list:
This application is not allowed to access or delete your direct messages

Version-Release number of selected component (if applicable):
gwibber-3.1.0-1.fc15.noarch

How reproducible:
100%

Steps to Reproduce:
1. Launch gwibber
2. From the left nagivation panel, click Private
3. No direct messages are observed
4. Wait a minute or less
5. Receive the error message: This application is not allowed to access or delete your direct messages

Actual results:
Can't view any of the direct messages that I receive

Expected results:
View any of the direct messages that I receive

Additional info:
*** Debug result
$ gwibber --debug
{}
/usr/lib/python2.7/site-packages/gwibber/gwui.py:875: GtkWarning: gtk_box_pack: assertion `child->parent == NULL' failed
  self.pack_start(content_area, False)
Gwibber GNOME Client: INFO Gwibber Client closed

*** Not certain but perhaps a step to fix OAuth issue with the Fedora maintained Gwibber?
http://groups.google.com/group/twitter-api-announce/browse_thread/thread/4956a4dd169be70c

Ehtetur (rutethe) wrote :

While the Direct Message issue affects Gwibber clients across distributions, I believe this thread is for Gwibber clients maintained for Ubuntu.

A bug on this issue for Gwibber clients maintained by Fedora can be found here:
https://bugzilla.redhat.com/show_bug.cgi?id=719448

Yeah, you were right about the OAuth issue, but there was another issue too, where the last update was not using the Fedora OAuth credentials. Both should be fixed, I can see my direct messages in testing. Please test and let me know if it works for you.

gwibber-3.1.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-2.fc14

gwibber-3.1.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-2.fc15

Paul J Stevens (paul-nfg) wrote :

I don't see a workaround mentioned in this report yet so for those of you looking for one:

Simply remove and re-add your twitter account to get rid of the error message.

Mike Rushton (leftyfb) wrote :

Attaching gwibber log after running "gwibber-service -d" per kenvandine's request via IRC

Boletis Georgios (mpoletis) wrote :

Removing and re-adding twitter account solved the problem for me.

It still happens with 3.1.0-2.fc14. I'm wondering if I need to force
reauthorization somehow (there is no button in account page).

Package gwibber-3.1.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gwibber-3.1.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gwibber-3.1.0-2.fc15
then log in and leave karma (feedback).

Yes, that would work because Gwibber had it's API keys updated.

My opinion: Just make an update that makes all users re-auth with Twitter.

Upgrade gwibber-3.1.0-2.fc15 and then remove/add your twitter account in order to utilize the new OAuth method

Changed in gwibber:
assignee: nobody → flags8192 (a-listratenkov)

gwibber-3.1.0-2.fc14 has been pushed to the Fedora 14 stable repository. If problems still persist, please make note of it in this bug report.

gwibber-3.1.0-2.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

nruest (ruestn) wrote :

I removed the account on the client and via the Twitter website, and it did not solve the problem as per: https://bugs.launchpad.net/gwibber/+bug/789851/comments/16 & https://bugs.launchpad.net/gwibber/+bug/789851/comments/18.

graingert (tagrain) wrote :

when re-adding my twitter account I get:

This application will not be able to:
Access your direct messages.
See your Twitter password.

on the authorisation page - so clearly the app is not requesting that authorisation

Chris Roberts (chrisjrob) wrote :

Removing and re-adding twitter account solved the problem for me.

Didn't solve for me either. Which version has the API keys updated?

Here's my apt-cache policy for gwibber:

$ apt-cache policy gwibber
gwibber:
  Installed: 3.1.0~bzr997-0ubuntu1~daily1
  Candidate: 3.1.0~bzr997-0ubuntu1~daily1
  Version table:
 *** 3.1.0~bzr997-0ubuntu1~daily1 0
        500 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
     3.0.0.1-0ubuntu3 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
     3.0.0.1-0ubuntu2 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

James Gifford (jamesgifford) wrote :

It should just work. When I updated my Twitter apps, I didn't get new API keys. I just got new permissions levels.

Cygwin Ports (yselkowitz) wrote :

Removing and re-adding twitter account did NOT help me with 3.0.0.1. Is 3.1.x required to make this work now?

Carlo de Wolf (wolfc) wrote :

It worked out for me by first revoking the authorization on http://twitter.com/settings/applications then re-adding the twitter account in gwibber.

Kai Blin (kai.blin) wrote :

Using the daily ppa doesn't work, the version from the team ppa works just fine for me.

@Kai: thanks for your comment. That is true! I downgraded to the Gnome3 Team PPA version and it works fine now!

$ apt-cache policy gwibber
gwibber:
  Installed: 3.0.0.1-0ubuntu3
  Candidate: 3.0.0.1-0ubuntu3
  Version table:
 *** 3.0.0.1-0ubuntu3 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     3.0.0.1-0ubuntu2 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Downgrading from 3.1.x (daily-PPA) to 3.0.0.1 (team-PPA)
and reauthentication solved the problem for me.

3.1 seems to use the wrong authentication method.

emgsilva (godsiem) wrote :

I also downgraded from 3.1.x (daily-PPA) to 3.0.0.1 (team-PPA) and it worked.

Same here. Haven't tried anything yet. But I just click reload for all accounts and it updates... go figure.
Ubuntu 11.04 64bits, just switched to xubuntu-desktop, same thing.

James Gifford (jamesgifford) wrote :

Are people still experiencing this issue?

Andy Smith (grifferz) wrote :

Yes, I am. I'm on 10.04 and both the version packaged with this, and any version I can get out of a PPA, gives this problem. Re-authenticating with Twitter doesn't make it go away.

I'm not in a position to upgrade the OS yet.

James Gifford (jamesgifford) wrote :

@Andy Try revoking it from your account on Twitter.com and trying again - http://support.twitter.com/articles/76052-how-to-connect-and-revoke-third-party-applications

It works fine here on 10.04 (see attached screenshot)

Andy Smith (grifferz) wrote :

So what should I be doing to make it work? Remove my twitter accounts and add them again?

James Gifford (jamesgifford) wrote :

Yes.

Andy Smith (grifferz) wrote :

OK, after removing 3.1.0~bzr997-0ubuntu1~daily1~lucid, reinstalling 2.30.3-0ubuntu2, removing accounts and re-adding them this does seem to have gone away, thanks!

Adam Funk (a-funk) wrote :

Deleting accounts and adding them again worked for me a few months ago, but since upgrading to oneiric I've given up on Gwibber because I couldn't get the multi-column display up again.

Ken VanDine (ken-vandine) wrote :

This was fixed sometime before 3.2 was released. Still likely broken for users running the daily ppa for lucid and maverick, those users should really revert to the distro version of gwibber.

Changed in gwibber:
assignee: flags8192 (a-listratenkov) → nobody
Changed in gwibber (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
status: Triaged → Fix Released
Changed in gwibber:
status: New → Fix Released
Changed in gwibber (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.